aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-17 16:16:24 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-17 16:16:24 +0000
commitf42c6cee20c15dcc659f23667871ebb273fcd467 (patch)
treefcbe69d7456808e1b978ccafa24dd7c8f318ddda /security
parent1c85e87a77c755e8e1901851f4359e2a02eb1dcd (diff)
downloadports-f42c6cee20c15dcc659f23667871ebb273fcd467.tar.gz
ports-f42c6cee20c15dcc659f23667871ebb273fcd467.zip
The Digest::JHash module allows you to use the fast JHash hashing algorithm
developed by Bob Jenkins from within Perl programs. The algorithm takes as input a message of arbitrary length and produces as output a 32-bit "message digest" of the input in the form of an unsigned long integer. See http://burtleburtle.net/bob/hash/doobs.html for more information. WWW: http://search.cpan.org/dist/Digest-JHash PR: ports/90564 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151405
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-JHash/Makefile24
-rw-r--r--security/p5-Digest-JHash/distinfo3
-rw-r--r--security/p5-Digest-JHash/pkg-descr7
-rw-r--r--security/p5-Digest-JHash/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a8810e4e618e..c4c2da08cc70 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -341,6 +341,7 @@
SUBDIR += p5-Digest-HMAC
SUBDIR += p5-Digest-Hashcash
SUBDIR += p5-Digest-Haval256
+ SUBDIR += p5-Digest-JHash
SUBDIR += p5-Digest-MD2
SUBDIR += p5-Digest-MD4
SUBDIR += p5-Digest-MD5
diff --git a/security/p5-Digest-JHash/Makefile b/security/p5-Digest-JHash/Makefile
new file mode 100644
index 000000000000..a69c99c1c22d
--- /dev/null
+++ b/security/p5-Digest-JHash/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-JHash
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-JHash
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for JHash hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::JHash.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-JHash/distinfo b/security/p5-Digest-JHash/distinfo
new file mode 100644
index 000000000000..5310afe4e5ff
--- /dev/null
+++ b/security/p5-Digest-JHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-JHash-0.02.tar.gz) = eaf88ee120fc16277d0e047601445661
+SHA256 (Digest-JHash-0.02.tar.gz) = 99f0a8d9f6ba95671a78ab9b50eec19705529fc594176d39379a75db768805c1
+SIZE (Digest-JHash-0.02.tar.gz) = 7031
diff --git a/security/p5-Digest-JHash/pkg-descr b/security/p5-Digest-JHash/pkg-descr
new file mode 100644
index 000000000000..3f23c87787c5
--- /dev/null
+++ b/security/p5-Digest-JHash/pkg-descr
@@ -0,0 +1,7 @@
+The Digest::JHash module allows you to use the fast JHash hashing algorithm
+developed by Bob Jenkins from within Perl programs. The algorithm takes as
+input a message of arbitrary length and produces as output a 32-bit
+"message digest" of the input in the form of an unsigned long integer.
+See http://burtleburtle.net/bob/hash/doobs.html for more information.
+
+WWW: http://search.cpan.org/dist/Digest-JHash
diff --git a/security/p5-Digest-JHash/pkg-plist b/security/p5-Digest-JHash/pkg-plist
new file mode 100644
index 000000000000..64d0505070c7
--- /dev/null
+++ b/security/p5-Digest-JHash/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/JHash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/JHash.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/JHash.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/JHash/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true