aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:38:37 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:38:37 +0000
commit072d72d794f879468a38d4ddee214f4cc816ddb0 (patch)
tree30da9e1f6e7a1bbcd14aa3531172f627fabcdba9 /security
parentb836b50aa4fa6bf750c3aac745f5ee9f6629aea1 (diff)
downloadports-072d72d794f879468a38d4ddee214f4cc816ddb0.tar.gz
ports-072d72d794f879468a38d4ddee214f4cc816ddb0.zip
perl5 module to work with PGP messages.
Notes
Notes: svn path=/head/; revision=4119
Diffstat (limited to 'security')
-rw-r--r--security/p5-PGP/Makefile36
-rw-r--r--security/p5-PGP/distinfo1
-rw-r--r--security/p5-PGP/pkg-comment1
-rw-r--r--security/p5-PGP/pkg-descr16
-rw-r--r--security/p5-PGP/pkg-plist4
5 files changed, 58 insertions, 0 deletions
diff --git a/security/p5-PGP/Makefile b/security/p5-PGP/Makefile
new file mode 100644
index 000000000000..d3aa0a416446
--- /dev/null
+++ b/security/p5-PGP/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-PGP
+# Version required: 0.2alpha
+# Date created: October 21st 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= PGP-0.2alpha
+PKGNAME= p5-PGP-0.2a
+CATEGORIES+= security
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/PGP/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/PGP/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5 \
+ pgp:${PORTSDIR}/security/pgp
+
+NO_WRKSUBDIR= YES
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in PGP; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/p5-PGP/distinfo b/security/p5-PGP/distinfo
new file mode 100644
index 000000000000..33241f16a5e2
--- /dev/null
+++ b/security/p5-PGP/distinfo
@@ -0,0 +1 @@
+MD5 (PGP-0.2alpha.tar.gz) = 979ca0729c0f2fb18c088ab16b11848d
diff --git a/security/p5-PGP/pkg-comment b/security/p5-PGP/pkg-comment
new file mode 100644
index 000000000000..e34804aeb7d4
--- /dev/null
+++ b/security/p5-PGP/pkg-comment
@@ -0,0 +1 @@
+perl5 module to work with PGP messages.
diff --git a/security/p5-PGP/pkg-descr b/security/p5-PGP/pkg-descr
new file mode 100644
index 000000000000..7fbde20b8b27
--- /dev/null
+++ b/security/p5-PGP/pkg-descr
@@ -0,0 +1,16 @@
+This is an alpha release of a PGP module for Perl5.This module will allow
+for an easy interface to both Phil Zimmermann'sPGP (v2.6.2) program and the
+international version of PGP (v2.6.2i).
+
+PGP.pm will allow you to sign, encrypt (w/signature), decrypt and perform
+key management. The only requirement being that you alreadyhave PGP
+installed on your system to utilize this module.There are sure to be many
+changes in the structure of this module overthe next couple of months--at
+least until a standard interface is acheived.
+
+If you find this module useful and wish to see future developments of it,
+the contribute to Phil Zimmermann's legal defense fund. Ifyou don't know
+anything about the government's attempt to wrongfully prosecute Phil, then
+go to Yahoo and search for "Zimmermann." After reading for a little while,
+you will be wondering how the governmentis getting away with it's criminal
+act.
diff --git a/security/p5-PGP/pkg-plist b/security/p5-PGP/pkg-plist
new file mode 100644
index 000000000000..5134b8dc6a86
--- /dev/null
+++ b/security/p5-PGP/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/man/man3/PGP.3.gz
+lib/perl5/site_perl/PGP-parse.pl
+lib/perl5/site_perl/PGP.pm
+lib/perl5/site_perl/i386-freebsd/auto/work/.packlist