aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-07-21 09:43:26 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-07-21 09:43:26 +0000
commit9615db4bd42c312b1c6927b3ef67ac7ea0d5fde2 (patch)
treed1757f3014fcbf9358bac79c3ecdafbca300dc86 /security
parent08d4751a466072e40fb2424454190ca81fb506f2 (diff)
downloadports-9615db4bd42c312b1c6927b3ef67ac7ea0d5fde2.tar.gz
ports-9615db4bd42c312b1c6927b3ef67ac7ea0d5fde2.zip
- Fix a bug in SHA256
PR: ports/76289 Reported by: Kenichi Morioka <morioka@openloop.co.jp> Fixed by: Vsevolod Stakhov <vsevolod@highsecure.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=139808
Diffstat (limited to 'security')
-rw-r--r--security/digest/Makefile1
-rw-r--r--security/digest/files/patch-sha2.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/digest/Makefile b/security/digest/Makefile
index 7e0e2284e614..b44e750d4685 100644
--- a/security/digest/Makefile
+++ b/security/digest/Makefile
@@ -8,6 +8,7 @@
PORTNAME?= digest
PORTVERSION?= 20050323
+PORTREVISION= 1
CATEGORIES?= security sysutils
MASTER_SITES?= http://highsecure.ru/
diff --git a/security/digest/files/patch-sha2.c b/security/digest/files/patch-sha2.c
new file mode 100644
index 000000000000..bedf3e5fc22a
--- /dev/null
+++ b/security/digest/files/patch-sha2.c
@@ -0,0 +1,11 @@
+--- sha2.c.orig Thu Jul 21 00:39:56 2005
++++ sha2.c Thu Jul 21 02:30:00 2005
+@@ -588,7 +588,7 @@
+ /* Begin padding with a 1 bit: */
+ context->buffer[usedspace++] = 0x80;
+
+- if (usedspace < SHA256_SHORT_BLOCK_LENGTH) {
++ if (usedspace <= SHA256_SHORT_BLOCK_LENGTH) {
+ /* Set-up for the last transform: */
+ MEMSET_BZERO(&context->buffer[usedspace], SHA256_SHORT_BLOCK_LENGTH - usedspace);
+ } else {