aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-18 16:29:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-18 16:29:47 +0000
commitb22378f7b15a2e74d4d5bb7f0f4f469eaa4d9558 (patch)
tree90c0f4d4a2a49762d1bd6b870f37f4c5a001d301 /security
parentdf13a3f14682efeb3bb229b91f30e08d490f29ea (diff)
downloadports-b22378f7b15a2e74d4d5bb7f0f4f469eaa4d9558.tar.gz
ports-b22378f7b15a2e74d4d5bb7f0f4f469eaa4d9558.zip
This module brings to Python programs the capability of evaluating password
strength. To achieve this noble aim it uses the well known cracklib toolkit, hence the name. PR: ports/83603 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Notes
Notes: svn path=/head/; revision=139515
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-crack/Makefile39
-rw-r--r--security/py-crack/distinfo2
-rw-r--r--security/py-crack/files/patch-_crack.c.in11
-rw-r--r--security/py-crack/pkg-descr5
5 files changed, 58 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f97524a3f119..892aff92b15a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -412,6 +412,7 @@
SUBDIR += pwman
SUBDIR += pxytest
SUBDIR += py-clamav
+ SUBDIR += py-crack
SUBDIR += py-cryptkit
SUBDIR += py-fchksum
SUBDIR += py-gnupg
diff --git a/security/py-crack/Makefile b/security/py-crack/Makefile
new file mode 100644
index 000000000000..1e47f854ee8f
--- /dev/null
+++ b/security/py-crack/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: py-crack
+# Date created: 2005-07-17
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pycrack
+PORTVERSION= 0.5
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= python-crack/Stable.pkg/${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-crack-${PORTVERSION}
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Python bindings to cracklib
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYSETUP= distutil.py
+GNU_CONFIGURE= yes
+
+PLIST_FILES:= ${PYTHONPREFIX_SITELIBDIR:S,${PREFIX}/,,}/_crack.so \
+ ${PYTHONPREFIX_SITELIBDIR:S,${PREFIX}/,,}/crack.py
+
+CONFIGURE_ENV= "CPPFLAGS=-I${LOCALBASE}/include" \
+ "LDFLAGS=-L${LOCALBASE}/lib" \
+ "DEFAULT_DICTPATH=${LOCALBASE}/libdata/cracklib/pw_dict"
+
+MAKE_ENV= "CPPFLAGS=-I${LOCALBASE}/include -fPIC" \
+ "LDFLAGS=-L${LOCALBASE}/lib"
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/crack.py ${PYTHONPREFIX_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/security/py-crack/distinfo b/security/py-crack/distinfo
new file mode 100644
index 000000000000..e595cb7ccb14
--- /dev/null
+++ b/security/py-crack/distinfo
@@ -0,0 +1,2 @@
+MD5 (python-crack-0.5.tar.gz) = ac76cf42e1d2074305141194883bff15
+SIZE (python-crack-0.5.tar.gz) = 120377
diff --git a/security/py-crack/files/patch-_crack.c.in b/security/py-crack/files/patch-_crack.c.in
new file mode 100644
index 000000000000..2ed999f5cfb4
--- /dev/null
+++ b/security/py-crack/files/patch-_crack.c.in
@@ -0,0 +1,11 @@
+--- _crack.c.in.orig Sun Jul 17 16:23:35 2005
++++ _crack.c.in Sun Jul 17 16:23:45 2005
+@@ -19,7 +19,7 @@
+ */
+
+ #include <Python.h>
+-#include <crack.h>
++#include <packer.h>
+ #include <stdio.h>
+
+ #define FILENAME_MAXLEN 512
diff --git a/security/py-crack/pkg-descr b/security/py-crack/pkg-descr
new file mode 100644
index 000000000000..3b9c2b9dae2c
--- /dev/null
+++ b/security/py-crack/pkg-descr
@@ -0,0 +1,5 @@
+This module brings to Python programs the capability of evaluating password
+strength. To achieve this noble aim it uses the well known cracklib toolkit,
+hence the name.
+
+WWW: http://www.nongnu.org/python-crack/