aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-07-10 02:00:43 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-07-10 02:00:43 +0000
commit2ec311a735964df8bcf90d89791848bbcfbf3930 (patch)
tree542150bd411f7cc8033d4caba93fe4ae7296c373 /security
parentf0b037cbcbe049f37b26d40fbe70545b423490c0 (diff)
downloadports-2ec311a735964df8bcf90d89791848bbcfbf3930.tar.gz
ports-2ec311a735964df8bcf90d89791848bbcfbf3930.zip
PR:
Submitted by: Reviewed by: Approved by: Obtained from: MFC after: Add sudoscript, an audited shell using sudo(8) and script(1) PR: 53967 Submitted by: Howard Owen <hbo@egbok.com>
Notes
Notes: svn path=/head/; revision=84555
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/sudoscript/Makefile23
-rw-r--r--security/sudoscript/distinfo1
-rw-r--r--security/sudoscript/pkg-descr14
-rw-r--r--security/sudoscript/pkg-plist33
5 files changed, 72 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d51eda1d594f..2ad117cca22f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -347,6 +347,7 @@
SUBDIR += stunnel
SUBDIR += subweb
SUBDIR += sudo
+ SUBDIR += sudoscript
SUBDIR += super
SUBDIR += swatch
SUBDIR += tea-total
diff --git a/security/sudoscript/Makefile b/security/sudoscript/Makefile
new file mode 100644
index 000000000000..81dfa9a681b8
--- /dev/null
+++ b/security/sudoscript/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: sudoscript
+# Date created: 17 June, 2003
+# Whom: hbo@egbok.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= sudoscript
+PORTVERSION= 2.1.1
+CATEGORIES= security
+MASTER_SITES= http://download.sourceforge.net/sudoscript/ \
+ http://egbok.com/sudoscript/
+
+MAINTAINER= hbo@egbok.com
+COMMENT= Audited shells in Perl with sudo(8) and script(1)
+
+MAN1= sudoshell.1
+MAN3= Sudoscript.3pm
+MAN8= sudoscriptd.8 sudoscript.8
+MANCOMPRESSED= no
+
+USE_GMAKE= yes
+.include <bsd.port.mk>
diff --git a/security/sudoscript/distinfo b/security/sudoscript/distinfo
new file mode 100644
index 000000000000..b7a4aee9e122
--- /dev/null
+++ b/security/sudoscript/distinfo
@@ -0,0 +1 @@
+MD5 (sudoscript-2.1.1.tar.gz) = de1eca15626b3df748bb6df70b793025
diff --git a/security/sudoscript/pkg-descr b/security/sudoscript/pkg-descr
new file mode 100644
index 000000000000..865ca7ccc36d
--- /dev/null
+++ b/security/sudoscript/pkg-descr
@@ -0,0 +1,14 @@
+Sudoscript provides an audited shell using sudo(8) and script(1).
+The front end script, sudoshell(1) contacts the daemon, sudoscriptd(8).
+They agree on the location of a FIFO, which the daemon opens for read.
+Sudoshell then runs script(1) with the FIFO as a typescript. The daemon
+stamps each line of the script(1) output with a session id, then passes
+the data over to another daemon. This daemon timestamps the data and stores
+it in a log file which is /var/log/sudscript. This daemon also keeps an eye
+on the size of log files, and forks a rotator/compressor when it exceeds 2
+MBytes.
+
+WWW: http://www.egbok.com/sudoscript
+
+- Howard Owen
+hbo@egbok.com
diff --git a/security/sudoscript/pkg-plist b/security/sudoscript/pkg-plist
new file mode 100644
index 000000000000..72d4b92f6979
--- /dev/null
+++ b/security/sudoscript/pkg-plist
@@ -0,0 +1,33 @@
+bin/ss
+bin/sudoshell
+etc/rc.d/sudoscriptd.sh
+lib/sudoscript/Sudoscript.pm
+sbin/sudoscriptd
+share/doc/sudoscript-2.1.1/2.0arch.gif
+share/doc/sudoscript-2.1.1/2.0arch.html
+share/doc/sudoscript-2.1.1/2.0arch.xml
+share/doc/sudoscript-2.1.1/CHANGELOG
+share/doc/sudoscript-2.1.1/INSTALL
+share/doc/sudoscript-2.1.1/PORCMOLSULB.html
+share/doc/sudoscript-2.1.1/PORCMOLSULB.pdf
+share/doc/sudoscript-2.1.1/PORCMOLSULB.xml
+share/doc/sudoscript-2.1.1/PORTING
+share/doc/sudoscript-2.1.1/PROBLEMS
+share/doc/sudoscript-2.1.1/README
+share/doc/sudoscript-2.1.1/RELEASENOTES
+share/doc/sudoscript-2.1.1/SECURITY
+share/doc/sudoscript-2.1.1/SUDOCONFIG
+share/doc/sudoscript-2.1.1/Sudoscript.3pm.html
+share/doc/sudoscript-2.1.1/Sudoscript.pm-src.html
+share/doc/sudoscript-2.1.1/dtd/egbokdoc.dtd
+share/doc/sudoscript-2.1.1/sudoscript.pod
+share/doc/sudoscript-2.1.1/sudoscript.8.html
+share/doc/sudoscript-2.1.1/sudoscriptd-src.html
+share/doc/sudoscript-2.1.1/sudoscriptd.8.html
+share/doc/sudoscript-2.1.1/sudoshell-src.html
+share/doc/sudoscript-2.1.1/sudoshell.1.html
+share/doc/sudoscript-2.1.1/xsl/egbokdoc.xsl
+share/doc/sudoscript-2.1.1/xsl/egbokdoc2fop.xsl
+@dirrm share/doc/sudoscript-2.1.1/xsl
+@dirrm share/doc/sudoscript-2.1.1/dtd
+@dirrm share/doc/sudoscript-2.1.1