aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-11 20:11:11 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-11 20:11:11 +0000
commit7a527e3179b4e8ad07255d23fd1bc1f9393a8831 (patch)
tree2b9b9f1413843d74513c0f942418ebe82f85e138 /security
parentc3cd01bd6e2ec5f81c7c01b896c7a50699fab334 (diff)
downloadports-7a527e3179b4e8ad07255d23fd1bc1f9393a8831.tar.gz
ports-7a527e3179b4e8ad07255d23fd1bc1f9393a8831.zip
Add osiris 1.5.2,
file integrity checking, with GDBM and MySQL support. PR: 50026 Submitted by: Nicolas Jombart <ecu@ipv42.net>
Notes
Notes: svn path=/head/; revision=84714
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/osiris/Makefile51
-rw-r--r--security/osiris/distinfo1
-rw-r--r--security/osiris/pkg-descr5
-rw-r--r--security/osiris/pkg-plist7
5 files changed, 65 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2ad117cca22f..e6a6ce37de53 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -176,6 +176,7 @@
SUBDIR += openssl
SUBDIR += openssl-beta
SUBDIR += openvpn
+ SUBDIR += osiris
SUBDIR += outguess
SUBDIR += p5-Authen-Krb4
SUBDIR += p5-Authen-Krb5
diff --git a/security/osiris/Makefile b/security/osiris/Makefile
new file mode 100644
index 000000000000..3df095ce13db
--- /dev/null
+++ b/security/osiris/Makefile
@@ -0,0 +1,51 @@
+# New ports collection Makefile for: osiris
+# Date created: 10, February 2003
+# Whom: Nicolas Jombart <ecu@ipv42.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= osiris
+PORTVERSION= 1.5.2
+CATEGORIES= security
+MASTER_SITES= http://osiris.shmoo.com/data/
+
+MAINTAINER= ecu@ipv42.net
+COMMENT= File integrity checking, with GDBM and MySQL support
+
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+= --with-mysql=${LOCALBASE} \
+ --enable-module=mysql
+.else
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+CONFIGURE_ARGS+= --with-gdbm=${LOCALBASE} \
+ --with-module-lib=${LOCALBASE}/lib \
+ --with-module-includes=${LOCALBASE}/include
+.endif
+
+NO_CDROM= This software can not be sold.
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= osiris.1 scale.1
+
+pre-configure:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Set WITH_MYSQL to get MySQL support."
+ @${ECHO_MSG} ""
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/configs/osiris-freebsd-4.4.conf \
+ ${PREFIX}/etc/osiris.conf-sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in docs/manual.html docs/manual.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/osiris/distinfo b/security/osiris/distinfo
new file mode 100644
index 000000000000..1546a7839623
--- /dev/null
+++ b/security/osiris/distinfo
@@ -0,0 +1 @@
+MD5 (osiris-1.5.2.tar.gz) = c340c0ef555cc339a8d4d8f81e0d325c
diff --git a/security/osiris/pkg-descr b/security/osiris/pkg-descr
new file mode 100644
index 000000000000..72ccc28662ed
--- /dev/null
+++ b/security/osiris/pkg-descr
@@ -0,0 +1,5 @@
+Osiris is another file integrity checking tool.
+It creates file information databases and diff them.
+It uses GDBM database by default and optionally MySQL.
+
+WWW: http://osiris.shmoo.com/
diff --git a/security/osiris/pkg-plist b/security/osiris/pkg-plist
new file mode 100644
index 000000000000..2aebf3754ab0
--- /dev/null
+++ b/security/osiris/pkg-plist
@@ -0,0 +1,7 @@
+bin/osiris
+bin/scale
+@unexec if [ -f %D/etc/osiris.conf ] && cmp -s %D/etc/osiris.conf %D/etc/osiris.conf-sample; then rm -f %D/etc/osiris.conf; fi
+etc/osiris.conf-sample
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%%%DOCSDIR%%/manual.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%