aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-07 07:37:08 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-07 07:37:08 +0000
commit81da6d97d210f747e3e61fcb6a39ef0f82ed3ff5 (patch)
treec992f1910e5e5c34f049876bbc337bcf16937342 /security
parentaf74ba5d884cc7cb5b94fc1ea1a529232c5d68cd (diff)
downloadports-81da6d97d210f747e3e61fcb6a39ef0f82ed3ff5.tar.gz
ports-81da6d97d210f747e3e61fcb6a39ef0f82ed3ff5.zip
Use clamav-milter, but support only gcc30 or higher.
PR: ports/53699 Submitted by: Rob Evers <rob@debank.tv> Approved by: TERAMOTO Masahiro <markun@onohara.to> (maintainer)
Notes
Notes: svn path=/head/; revision=84359
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile8
-rw-r--r--security/clamav/pkg-descr2
-rw-r--r--security/clamav/pkg-plist1
3 files changed, 11 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 9f1a412b6d62..9410673f3962 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.60
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://clamav.elektrapro.com/stable/ \
http://clamav.essentkabel.com/stable/
@@ -37,6 +38,13 @@ MAN8= clamd.8
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 500000
+CONFIGURE_ARGS+=--enable-milter
+PLIST_SUB+= CLAMAV-MILTER:=""
+.else
+PLIST_SUB+= CLAMAV-MILTER:="@comment "
+.endif
+
pre-install:
@${ECHO} "===> Creating custom user to run clamav..."
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
diff --git a/security/clamav/pkg-descr b/security/clamav/pkg-descr
index 468643344766..af63f4e19c00 100644
--- a/security/clamav/pkg-descr
+++ b/security/clamav/pkg-descr
@@ -1,3 +1,5 @@
Clam Antivirus is command line virus scanner written entirely in C
and its database is kept up to date. It also detects polymorphic
viruses, scans compressed files and supported by AMaViS.
+On FreeBSD 4.X the milter interface isn't built by default because
+it needs gcc30 or higher.
diff --git a/security/clamav/pkg-plist b/security/clamav/pkg-plist
index 4cc7f7d00c9b..cac5ce5be29f 100644
--- a/security/clamav/pkg-plist
+++ b/security/clamav/pkg-plist
@@ -2,6 +2,7 @@ bin/clamscan
bin/clamdscan
bin/freshclam
bin/sigtool
+%%CLAMAV-MILTER:%%sbin/clamav-milter
sbin/clamd
include/clamav.h
lib/libclamav.so.1