aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-04-17 12:13:08 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-04-17 12:13:08 +0000
commita8315b546068b616aa60c4d2dcc60ff1f9f18ed5 (patch)
tree384d5c59b04c49b64ec5c39aa477b0501715dd55 /security
parentc7aa8c54da7f49d8be0eb238c6b2c4408f61097e (diff)
downloadports-a8315b546068b616aa60c4d2dcc60ff1f9f18ed5.tar.gz
ports-a8315b546068b616aa60c4d2dcc60ff1f9f18ed5.zip
Update to 0.31, lots of cleanup, add NOPORTDOCS handling.
PR: 26643 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=41545
Diffstat (limited to 'security')
-rw-r--r--security/chkrootkit/Makefile23
-rw-r--r--security/chkrootkit/pkg-plist8
2 files changed, 16 insertions, 15 deletions
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 699c3256d9ec..dda12250b9ec 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -12,25 +12,26 @@ MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/
MAINTAINER= cordeiro@iqm.unicamp.br
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= chkrootkit chklastlog chkwtmp ifpromisc
+DOCFILES= COPYRIGHT README.chklastlog README.chkwtmp
+
pre-patch:
- @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.orig
- @${SED} -e "s/^CC/#CC/g" -e "s/^CFLAGS/#CFLAGS/g" \
- ${WRKSRC}/Makefile.orig > ${WRKSRC}/Makefile
- @${MV} ${WRKSRC}/chkrootkit ${WRKSRC}/chkrootkit.orig
- @${SED} -e 's#\./chklastlog#${PREFIX}/sbin/chklastlog#' \
- -e 's#\./chkwtmp#${PREFIX}/sbin/chkwtmp#' \
- -e 's#\./ifpromisc#${PREFIX}/sbin/ifpromisc#' \
- ${WRKSRC}/chkrootkit.orig > ${WRKSRC}/chkrootkit
+ ${PERL} -pi -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
+ ${PERL} -pi -e \
+ 's#\./chklastlog#${PREFIX}/sbin/chklastlog#g; \
+ s#\./chkwtmp#${PREFIX}/sbin/chkwtmp#g; \
+ s#\./ifpromisc#${PREFIX}/sbin/ifpromisc#g; ' \
+ ${WRKSRC}/chkrootkit
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/chkrootkit ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chklastlog ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chkwtmp ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/ifpromisc ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/chkrootkit
- ${CP} -R ${WRKSRC}/COPY* ${PREFIX}/share/doc/chkrootkit
- ${CP} -R ${WRKSRC}/README* ${PREFIX}/share/doc/chkrootkit
+ ${INSTALL_DATA} ${DOCFILES:C,^,${WRKSRC}/,} ${PREFIX}/share/doc/chkrootkit
+.endif
.include <bsd.port.mk>
diff --git a/security/chkrootkit/pkg-plist b/security/chkrootkit/pkg-plist
index 43595e10b4fe..2bf22cf69b5a 100644
--- a/security/chkrootkit/pkg-plist
+++ b/security/chkrootkit/pkg-plist
@@ -2,7 +2,7 @@ sbin/chkrootkit
sbin/chklastlog
sbin/chkwtmp
sbin/ifpromisc
-share/doc/chkrootkit/COPYRIGHT
-share/doc/chkrootkit/README.chklastlog
-share/doc/chkrootkit/README.chkwtmp
-@dirrm share/doc/chkrootkit
+%%PORTDOCS%%share/doc/chkrootkit/COPYRIGHT
+%%PORTDOCS%%share/doc/chkrootkit/README.chklastlog
+%%PORTDOCS%%share/doc/chkrootkit/README.chkwtmp
+%%PORTDOCS%%@dirrm share/doc/chkrootkit