aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-03-01 06:39:18 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-03-01 06:39:18 +0000
commit68c2f99c6300bc38a37eb3a8292b562cc2d8952b (patch)
tree0898749bb767b388765958548da12c5b50b3825d /security
parent031bd55ed2b892d722ffdba72b339be33879e047 (diff)
downloadports-68c2f99c6300bc38a37eb3a8292b562cc2d8952b.tar.gz
ports-68c2f99c6300bc38a37eb3a8292b562cc2d8952b.zip
Remove do-configure section, use PERL_CONFIGURE now.
Notes
Notes: svn path=/head/; revision=38917
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-PAM/Makefile6
-rw-r--r--security/p5-Authen-Radius/Makefile5
-rw-r--r--security/p5-Authen-TacacsPlus/Makefile1
-rw-r--r--security/p5-Authen-Ticket/Makefile1
-rw-r--r--security/p5-Crypt-Blowfish/Makefile6
-rw-r--r--security/p5-Crypt-CBC/Makefile5
-rw-r--r--security/p5-Crypt-CipherSaber/Makefile1
-rw-r--r--security/p5-Crypt-Cracklib/Makefile1
-rw-r--r--security/p5-Crypt-ECB/Makefile1
-rw-r--r--security/p5-Crypt-Rijndael/Makefile1
-rw-r--r--security/p5-Crypt-SSLeay/Makefile6
-rw-r--r--security/p5-Crypt-SSLeay/pkg-plist1
-rw-r--r--security/p5-Crypt-TripleDES/Makefile1
-rw-r--r--security/p5-Crypt-Twofish/Makefile1
-rw-r--r--security/p5-Crypt-UnixCrypt/Makefile1
-rw-r--r--security/p5-Digest-MD5/Makefile6
-rw-r--r--security/p5-GnuPG-Interface/Makefile11
-rw-r--r--security/p5-IO-Socket-SSL/Makefile5
-rw-r--r--security/p5-MD5/Makefile6
-rw-r--r--security/p5-Net-SSLeay/Makefile6
-rw-r--r--security/p5-PGP-Sign/Makefile9
-rw-r--r--security/p5-PGP/Makefile5
22 files changed, 14 insertions, 72 deletions
diff --git a/security/p5-Authen-PAM/Makefile b/security/p5-Authen-PAM/Makefile
index fcdf6344785f..f850f52419ea 100644
--- a/security/p5-Authen-PAM/Makefile
+++ b/security/p5-Authen-PAM/Makefile
@@ -14,13 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= matt@zigg.com
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= Authen::PAM.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/security/p5-Authen-Radius/Makefile b/security/p5-Authen-Radius/Makefile
index bb01c4c9c469..38e7f396f4d0 100644
--- a/security/p5-Authen-Radius/Makefile
+++ b/security/p5-Authen-Radius/Makefile
@@ -17,14 +17,11 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MD5.pm:${PORTSDIR}/security/p5-MD5
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= Authen::Radius.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
pre-configure:
@${CP} ${WRKSRC}/Authen/Radius.pm ${WRKSRC}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/security/p5-Authen-TacacsPlus/Makefile b/security/p5-Authen-TacacsPlus/Makefile
index 1ac123c6368d..a94faaca0702 100644
--- a/security/p5-Authen-TacacsPlus/Makefile
+++ b/security/p5-Authen-TacacsPlus/Makefile
@@ -14,7 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAKE_ENV+= CCFLAGS="${CFLAGS}"
diff --git a/security/p5-Authen-Ticket/Makefile b/security/p5-Authen-Ticket/Makefile
index 124fda8d3244..4474fa5c0eae 100644
--- a/security/p5-Authen-Ticket/Makefile
+++ b/security/p5-Authen-Ticket/Makefile
@@ -14,7 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Crypt-Blowfish/Makefile b/security/p5-Crypt-Blowfish/Makefile
index 938dc98662ad..fd98498b7879 100644
--- a/security/p5-Crypt-Blowfish/Makefile
+++ b/security/p5-Crypt-Blowfish/Makefile
@@ -14,14 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= patrick@mindstep.com
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= Crypt::Blowfish.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-CBC/Makefile b/security/p5-Crypt-CBC/Makefile
index 03187c8eeabb..517df82f4764 100644
--- a/security/p5-Crypt-CBC/Makefile
+++ b/security/p5-Crypt-CBC/Makefile
@@ -18,12 +18,9 @@ RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MD5.pm:${
RESTRICTED= "Crypto; export-controlled"
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::CBC.3
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-CipherSaber/Makefile b/security/p5-Crypt-CipherSaber/Makefile
index 2f6b50899921..2befa7b07540 100644
--- a/security/p5-Crypt-CipherSaber/Makefile
+++ b/security/p5-Crypt-CipherSaber/Makefile
@@ -14,7 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Crypt-Cracklib/Makefile b/security/p5-Crypt-Cracklib/Makefile
index cce391aefc44..a1af69dc1d25 100644
--- a/security/p5-Crypt-Cracklib/Makefile
+++ b/security/p5-Crypt-Cracklib/Makefile
@@ -18,7 +18,6 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libcrack.a:${PORTSDIR}/security/cracklib
RUN_DEPENDS= ${BUILD_DEPENDS}
SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-USE_PERL5= yes
PERL_CONFIGURE= yes
CONFIGURE_ARGS+=INC="-I${LOCALBASE}/include"
diff --git a/security/p5-Crypt-ECB/Makefile b/security/p5-Crypt-ECB/Makefile
index 09bce82fe095..cbe80de99409 100644
--- a/security/p5-Crypt-ECB/Makefile
+++ b/security/p5-Crypt-ECB/Makefile
@@ -14,7 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Crypt-Rijndael/Makefile b/security/p5-Crypt-Rijndael/Makefile
index f5b8cd6d9321..851d59cdb614 100644
--- a/security/p5-Crypt-Rijndael/Makefile
+++ b/security/p5-Crypt-Rijndael/Makefile
@@ -14,7 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Crypt-SSLeay/Makefile b/security/p5-Crypt-SSLeay/Makefile
index 9055e181b20a..361cb07bddac 100644
--- a/security/p5-Crypt-SSLeay/Makefile
+++ b/security/p5-Crypt-SSLeay/Makefile
@@ -18,13 +18,9 @@ RESTRICTED= "Crypto; export-controlled"
IS_INTERACTIVE= "asks about openssl"
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::SSLeay.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/security/p5-Crypt-SSLeay/pkg-plist b/security/p5-Crypt-SSLeay/pkg-plist
index f8e076d62b52..7bf4fc4a1607 100644
--- a/security/p5-Crypt-SSLeay/pkg-plist
+++ b/security/p5-Crypt-SSLeay/pkg-plist
@@ -8,5 +8,4 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/SSLeay/MainContext.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Crypt/SSLeay.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/SSL.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/SSLeay/.packlist
-lib/perl5/%%PERL_VER%%/man/man3/Crypt::SSLeay.3
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/SSLeay
diff --git a/security/p5-Crypt-TripleDES/Makefile b/security/p5-Crypt-TripleDES/Makefile
index 1fe1d23a597d..63bc672e7218 100644
--- a/security/p5-Crypt-TripleDES/Makefile
+++ b/security/p5-Crypt-TripleDES/Makefile
@@ -14,7 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Crypt-Twofish/Makefile b/security/p5-Crypt-Twofish/Makefile
index 9a3097710261..075aa8ed6b4d 100644
--- a/security/p5-Crypt-Twofish/Makefile
+++ b/security/p5-Crypt-Twofish/Makefile
@@ -15,7 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/Crypt/Twofish
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Crypt-UnixCrypt/Makefile b/security/p5-Crypt-UnixCrypt/Makefile
index d0f4dc9e7bc4..dfa264bf8e96 100644
--- a/security/p5-Crypt-UnixCrypt/Makefile
+++ b/security/p5-Crypt-UnixCrypt/Makefile
@@ -15,7 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
-USE_PERL5= yes
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/security/p5-Digest-MD5/Makefile b/security/p5-Digest-MD5/Makefile
index 7d598ad81c2e..24bd2a4526ad 100644
--- a/security/p5-Digest-MD5/Makefile
+++ b/security/p5-Digest-MD5/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ache@FreeBSD.org
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= Digest::MD2.3 \
Digest::SHA1.3 \
@@ -28,8 +28,4 @@ MAN3= Digest::MD2.3 \
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/security/p5-GnuPG-Interface/Makefile b/security/p5-GnuPG-Interface/Makefile
index 714d8968493f..6c9dc6813031 100644
--- a/security/p5-GnuPG-Interface/Makefile
+++ b/security/p5-GnuPG-Interface/Makefile
@@ -8,10 +8,7 @@
PORTNAME= GnuPG-Interface
PORTVERSION= 0.11
CATEGORIES= security perl5
-MASTER_SITES= http://download.sourceforge.net/${PORTNAME}/ \
- ftp://download.sourceforge.net/pub/sourceforge/${PORTNAME}/ \
- ftp://ftp.kddlabs.co.jp/sourceforge/${PORTNAME}/ \
- ${MASTER_SITE_PERL_CPAN}
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= GnuPG
PKGNAMEPREFIX= p5-
@@ -20,7 +17,7 @@ MAINTAINER= trevor@FreeBSD.org
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= GnuPG::Handles.3 \
GnuPG::SecretKey.3 \
@@ -32,10 +29,6 @@ MAN3= GnuPG::Handles.3 \
GnuPG::Key.3 \
GnuPG::UserId.3 \
GnuPG::Options.3
-
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
index f49c2ba3e10f..c1a321f3b903 100644
--- a/security/p5-IO-Socket-SSL/Makefile
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -18,12 +18,9 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSL
RESTRICTED= "Crypto; export-controlled"
-USE_PERL5= yes
+PERL_CONFIGURE= yes
$MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
$MAN3= IO::Socket::SSL.3
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/security/p5-MD5/Makefile b/security/p5-MD5/Makefile
index bb9c13ac1f45..d2677689e7be 100644
--- a/security/p5-MD5/Makefile
+++ b/security/p5-MD5/Makefile
@@ -14,13 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= MD5.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/security/p5-Net-SSLeay/Makefile b/security/p5-Net-SSLeay/Makefile
index 7988e6b1d181..e64118fb3368 100644
--- a/security/p5-Net-SSLeay/Makefile
+++ b/security/p5-Net-SSLeay/Makefile
@@ -16,14 +16,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.ORG
RESTRICTED= "Cryptography"
-USE_PERL5= yes
+PERL_CONFIGURE= yes
USE_OPENSSL= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::SSLeay.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- ${OPENSSLBASE} CC="${CC}" CCFLAGS="${CFLAGS}"
-
.include <bsd.port.mk>
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index 6b482469607a..cf6668f2037b 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= croyle@gelemna.org
-USE_PERL5= yes
+PERL_CONFIGURE= yes
+CONFIG_ARGS= PGPS=${PGPS} PGPV=${PGPV} PGPSTYLE=${PGPSTYLE}
MAN3= PGP::Sign.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -69,10 +70,4 @@ PGPS?= ${PGP}
PGPV?= ${PGP}
.endif
-CONFIG_ARGS= PGPS=${PGPS} PGPV=${PGPV} PGPSTYLE=${PGPSTYLE}
-
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- ${CONFIG_ARGS}
-
.include <bsd.port.mk>
diff --git a/security/p5-PGP/Makefile b/security/p5-PGP/Makefile
index 7ef02f5559c2..9dc6b7dacbaf 100644
--- a/security/p5-PGP/Makefile
+++ b/security/p5-PGP/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= pgp:${PORTSDIR}/security/pgp
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= PGP::Pipe.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -24,7 +24,4 @@ MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
pre-configure:
@${CP} ${WRKSRC}/PGP/Pipe.pm ${WRKSRC}
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>