aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2016-06-27 10:07:14 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2016-06-27 10:07:14 +0000
commit5be1ac2b13621b8efd1cee4b264934e909285574 (patch)
treebf73d60d92ff43d9ea48c7bf53a8d2fc5108e983 /security
parent2cca15ad4f2732d1a7d3a7c2ac9b5521a2a9d3dd (diff)
downloadports-5be1ac2b13621b8efd1cee4b264934e909285574.tar.gz
ports-5be1ac2b13621b8efd1cee4b264934e909285574.zip
Add new port -- YubiKey PIV Manager
Tool for configuring your PIV-enabled YubiKey.
Notes
Notes: svn path=/head/; revision=417646
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/yubikey-piv-manager/Makefile33
-rw-r--r--security/yubikey-piv-manager/distinfo3
-rw-r--r--security/yubikey-piv-manager/files/patch-pivman_yubicommon_setup_qt.py10
-rw-r--r--security/yubikey-piv-manager/files/patch-resources_pivman.desktop11
-rw-r--r--security/yubikey-piv-manager/files/patch-setup.py11
-rw-r--r--security/yubikey-piv-manager/pkg-descr5
7 files changed, 74 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c38949f20c77..88f1b1890183 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1156,6 +1156,7 @@
SUBDIR += ykpers
SUBDIR += yubico-piv-tool
SUBDIR += yubikey-personalization-gui
+ SUBDIR += yubikey-piv-manager
SUBDIR += zebedee
SUBDIR += zenmap
SUBDIR += zeronet
diff --git a/security/yubikey-piv-manager/Makefile b/security/yubikey-piv-manager/Makefile
new file mode 100644
index 000000000000..1b0c24779b35
--- /dev/null
+++ b/security/yubikey-piv-manager/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= yubikey-piv-manager
+PORTVERSION= 1.2.1
+#PORTREVISION= 0
+CATEGORIES= security
+MASTER_SITES= https://developers.yubico.com/yubikey-piv-manager/Releases/
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= YubiKey PIV Manager
+
+LICENSE= GPLv3+
+
+RUN_DEPENDS= pyside${PYTHON_PKGNAMESUFFIX}>=1.0.9:devel/pyside \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
+ yubico-piv-tool:security/yubico-piv-tool
+
+NO_ARCH= yes
+USES= python:2
+USE_PYTHON= autoplist distutils
+
+PLIST_FILES+= man/man1/pivman.1.gz \
+ share/applications/pivman.desktop \
+ share/pixmaps/yubikey-piv-manager.png
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/man/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/resources/pivman.desktop \
+ ${STAGEDIR}${DESKTOPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/resources/yubikey-piv-manager.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/security/yubikey-piv-manager/distinfo b/security/yubikey-piv-manager/distinfo
new file mode 100644
index 000000000000..09cf0a63e03c
--- /dev/null
+++ b/security/yubikey-piv-manager/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466902480
+SHA256 (yubikey-piv-manager-1.2.1.tar.gz) = a74f1f5e0e87a422a37fd4efacba13ccb9afc8d12c245d549e967e4ef6e99710
+SIZE (yubikey-piv-manager-1.2.1.tar.gz) = 156691
diff --git a/security/yubikey-piv-manager/files/patch-pivman_yubicommon_setup_qt.py b/security/yubikey-piv-manager/files/patch-pivman_yubicommon_setup_qt.py
new file mode 100644
index 000000000000..83c096447b7c
--- /dev/null
+++ b/security/yubikey-piv-manager/files/patch-pivman_yubicommon_setup_qt.py
@@ -0,0 +1,10 @@
+--- pivman/yubicommon/setup/qt.py.orig 2015-11-10 13:48:09 UTC
++++ pivman/yubicommon/setup/qt.py
+@@ -32,7 +32,6 @@ from distutils.errors import DistutilsSe
+ import os
+
+
+-__dependencies__ = ['PySide']
+ __all__ = ['qt_resources']
+
+
diff --git a/security/yubikey-piv-manager/files/patch-resources_pivman.desktop b/security/yubikey-piv-manager/files/patch-resources_pivman.desktop
new file mode 100644
index 000000000000..9beb73cd6a5b
--- /dev/null
+++ b/security/yubikey-piv-manager/files/patch-resources_pivman.desktop
@@ -0,0 +1,11 @@
+--- resources/pivman.desktop.orig 2015-04-09 13:51:12 UTC
++++ resources/pivman.desktop
+@@ -3,7 +3,7 @@ Name=YubiKey PIV Manager
+ GenericName=YubiKey PIV Manager
+ Comment=Tool for configuring your PIV-enabled YubiKey
+ Exec=pivman
+-Icon=pivman
++Icon=yubikey-piv-manager
+ StartupNotify=false
+ Terminal=false
+ Type=Application
diff --git a/security/yubikey-piv-manager/files/patch-setup.py b/security/yubikey-piv-manager/files/patch-setup.py
new file mode 100644
index 000000000000..65a9666e2771
--- /dev/null
+++ b/security/yubikey-piv-manager/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2015-11-10 15:05:16 UTC
++++ setup.py
+@@ -42,7 +42,7 @@ setup(
+ entry_points={
+ 'gui_scripts': ['pivman=pivman.__main__:main']
+ },
+- install_requires=['PySide', 'pycrypto'],
++ install_requires=['pycrypto'],
+ yc_requires=['ctypes', 'qt'],
+ test_suite='nose.collector',
+ tests_require=[''],
diff --git a/security/yubikey-piv-manager/pkg-descr b/security/yubikey-piv-manager/pkg-descr
new file mode 100644
index 000000000000..d4ae3ffc7764
--- /dev/null
+++ b/security/yubikey-piv-manager/pkg-descr
@@ -0,0 +1,5 @@
+YubiKey PIV Manager
+
+Tool for configuring your PIV-enabled YubiKey.
+
+WWW: https://developers.yubico.com/yubikey-piv-manager/