aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-02 04:20:46 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-02 04:20:46 +0000
commit3ddf7642fab5d264711b58dc1038c965e225d866 (patch)
tree00e8827f4e12e2f9285abc1faded630b781854b4 /security
parent2c6f2fc033f3dd807b8737d8919a8b498f9045b8 (diff)
downloadports-3ddf7642fab5d264711b58dc1038c965e225d866.tar.gz
ports-3ddf7642fab5d264711b58dc1038c965e225d866.zip
Add oidentd to ports tree; it is an identd server which, properly
configured, can allow users to specify an arbitrary ident string. Unfortunately, due to <sys/file.h> being outdated, this port is marked BROKEN for all ${OSVERSION} prior to 400010, which is the closest to src/sys/sys/file.h rev 1.16.2.2. PR: 17660 Submitted by: Trevor Johnson <trevor@jpj.net> Reviewed by: mharo (confirmation of BROKEN for < 400010)
Notes
Notes: svn path=/head/; revision=27269
Diffstat (limited to 'security')
-rw-r--r--security/oidentd/Makefile25
-rw-r--r--security/oidentd/distinfo1
-rw-r--r--security/oidentd/files/patch-aa14
-rw-r--r--security/oidentd/pkg-comment1
-rw-r--r--security/oidentd/pkg-descr23
-rw-r--r--security/oidentd/pkg-plist1
6 files changed, 65 insertions, 0 deletions
diff --git a/security/oidentd/Makefile b/security/oidentd/Makefile
new file mode 100644
index 000000000000..14988fa46015
--- /dev/null
+++ b/security/oidentd/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: oidentd
+# Version required: 1.6.4
+# Date created: 29 Mar 2000
+# Whom: trevor@jpj.net
+#
+# $FreeBSD$
+#
+
+DISTNAME= oidentd-1.6.4
+CATEGORIES= security net
+MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/ojnk/ \
+ http://www.numb.org/~odin/stuff/
+
+MAINTAINER= trevor@jpj.net
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400010
+BROKEN= "outdated sys/file.h"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/oidentd/distinfo b/security/oidentd/distinfo
new file mode 100644
index 000000000000..0955808c472f
--- /dev/null
+++ b/security/oidentd/distinfo
@@ -0,0 +1 @@
+MD5 (oidentd-1.6.4.tar.gz) = a70c40ae57b71e873152ea3c01aef81a
diff --git a/security/oidentd/files/patch-aa b/security/oidentd/files/patch-aa
new file mode 100644
index 000000000000..2453c871feac
--- /dev/null
+++ b/security/oidentd/files/patch-aa
@@ -0,0 +1,14 @@
+--- src/freebsd.c.orig Tue Jan 18 02:37:19 2000
++++ src/freebsd.c Wed Mar 29 09:39:27 2000
+@@ -22,9 +22,9 @@
+ #include <sys/queue.h>
+ #include <sys/uio.h>
+ #include <sys/socketvar.h>
+-#define KERNEL
++#define _KERNEL
+ #include <sys/file.h>
+-#undef KERNEL
++#undef _KERNEL
+ #include <sys/user.h>
+ #include <sys/filedesc.h>
+ #include <sys/proc.h>
diff --git a/security/oidentd/pkg-comment b/security/oidentd/pkg-comment
new file mode 100644
index 000000000000..50426f199ebe
--- /dev/null
+++ b/security/oidentd/pkg-comment
@@ -0,0 +1 @@
+Ident server that supports user-defined ident strings
diff --git a/security/oidentd/pkg-descr b/security/oidentd/pkg-descr
new file mode 100644
index 000000000000..365b82ab5e7c
--- /dev/null
+++ b/security/oidentd/pkg-descr
@@ -0,0 +1,23 @@
+from the README:
+
+Oidentd is an ident (RFC 1413-compliant) daemon which runs on
+GNU/Linux, FreeBSD and OpenBSD. Oidentd supports most features of
+pidentd as well as a number of features absent in pidentd. Most
+notably, oidentd allows users, given the proper permission, to
+specify the identd response that the server will output when a
+successful lookup is completed. Oidentd also allows for pseudo-random
+strings (either a prefix, such as "user," followed by a number
+between 0 and 99999, or 10 pseudo-random characters of the set
+0-9A-Za-z) to be returned upon the completion of a successful lookup
+instead of a username or a UID. Oidentd supports IP masqueraded
+connections and supports fowarding ident requests for IP masqeraded
+connections to the machines from which the connections originate.
+For information on how to setup support for masqueraded connections,
+see the "INSTALL" file. NOTE: Currently, only Linux supports the
+-P -f and -m options. In other words, the IP masquerading support
+only exists on Linux right now.
+
+WWW: http://ojnk.sourceforge.net/
+
+Trevor Johnson
+trevor@jpj.net
diff --git a/security/oidentd/pkg-plist b/security/oidentd/pkg-plist
new file mode 100644
index 000000000000..193ec3715ac2
--- /dev/null
+++ b/security/oidentd/pkg-plist
@@ -0,0 +1 @@
+sbin/oidentd