aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-12-20 20:00:54 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-12-20 20:00:54 +0000
commita79001505ede9ffc6570ad026a615ab75ede78c8 (patch)
tree0cbc8a6897a236501851ac3ab6ccb150c7626a04 /shells/bash-completion
parente1bf909131e66359c6a7ee5c274df965298f2fee (diff)
downloadports-a79001505ede9ffc6570ad026a615ab75ede78c8.tar.gz
ports-a79001505ede9ffc6570ad026a615ab75ede78c8.zip
Fix staging as non-root.
Submitted by: Anton Yuzhaninov <citrin@citrin.ru> While I'm here, convert bash selection to OPTIONS.
Notes
Notes: svn path=/head/; revision=337087
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile18
-rw-r--r--shells/bash-completion/files/patch-Makefile.am13
2 files changed, 25 insertions, 6 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 565bcbe7b166..ed40ff6ec688 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -10,14 +10,12 @@ MASTER_SITES= http://bash-completion.alioth.debian.org/files/
MAINTAINER= adamw@FreeBSD.org
COMMENT= Programmable completion library for Bash
-.if defined(WITH_BASH_DEVEL)
-RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
-.else
-RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
-.endif
+OPTIONS_DEFINE= BASH_DEVEL
+BASH_DEVEL_DESC= Use shells/bash-devel instead of shells/bash
CONFLICTS= bash-completion-classic-[0-9]*
+USE_AUTOTOOLS= aclocal automake
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -26,7 +24,15 @@ USE_BZIP2= yes
SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
-post-patch:
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MBASH_DEVEL}
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash-devel
+.else
+RUN_DEPENDS=bash:${PORTSDIR}/shells/bash
+.endif
+
+post-configure:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g; \
s|/etc/bash_completion|${PREFIX}&|g; \
s|/usr\(/sbin/postconf\)|${PREFIX}\1|g; \
diff --git a/shells/bash-completion/files/patch-Makefile.am b/shells/bash-completion/files/patch-Makefile.am
new file mode 100644
index 000000000000..007eb00a36f5
--- /dev/null
+++ b/shells/bash-completion/files/patch-Makefile.am
@@ -0,0 +1,13 @@
+--- Makefile.am.orig 2013-12-20 13:44:12.000000000 -0500
++++ Makefile.am 2013-12-20 13:44:17.000000000 -0500
+@@ -20,8 +20,10 @@
+ .dir-locals.el
+
+ install-data-hook:
++ chmod 644 $(DESTDIR)$(pkgdatadir)/bash_completion
+ tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \
+ sed -e 's|=/etc/bash_completion\.d|=$(compatdir)|' \
+ $(DESTDIR)$(pkgdatadir)/bash_completion > $$tmpfile && \
+ cat $$tmpfile > $(DESTDIR)$(pkgdatadir)/bash_completion && \
+ rm $$tmpfile
++ chmod 444 $(DESTDIR)$(pkgdatadir)/bash_completion