aboutsummaryrefslogtreecommitdiff
path: root/shells/bash-completion
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-19 18:30:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-19 18:30:35 +0000
commite7290cb82c380db0c9aef42c6eab7d638d41984d (patch)
tree658ebeb8b5f0c383383184f345b1021065545a86 /shells/bash-completion
parent42d76161936c7fce1f1cd364bb50de5170133376 (diff)
downloadports-e7290cb82c380db0c9aef42c6eab7d638d41984d.tar.gz
ports-e7290cb82c380db0c9aef42c6eab7d638d41984d.zip
- Use @dirrmtry for PREFIX/etc/bash_completion.d
Other ports (e.g. devel/glib20) install files to this directory. - Costmetic change: put build-related knobs together - Sort PLIST - Space/tab twiddle PR: ports/160202 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 24 days)
Notes
Notes: svn path=/head/; revision=282011
Diffstat (limited to 'shells/bash-completion')
-rw-r--r--shells/bash-completion/Makefile25
-rw-r--r--shells/bash-completion/pkg-plist4
2 files changed, 14 insertions, 15 deletions
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 2efd03de6858..c3facc12485f 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -5,25 +5,24 @@
# $FreeBSD$
#
-PORTNAME= bash-completion
+PORTNAME= bash-completion
PORTVERSION= 1.3
-PORTREVISION= 1
-PORTEPOCH= 1
-CATEGORIES= shells
+PORTREVISION= 2
+PORTEPOCH= 1
+CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
-MAINTAINER= adamw@FreeBSD.org
-COMMENT= Programmable completion library for Bash
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Programmable completion library for Bash
-USE_BZIP2= yes
-SUB_FILES= pkg-message
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
-CONFLICTS+= bash-completion-classic-[0-9]*
+CONFLICTS= bash-completion-classic-[0-9]*
GNU_CONFIGURE= yes
+USE_BZIP2= yes
-.include <bsd.port.pre.mk>
+SUB_FILES= pkg-message
post-patch:
@${ECHO_CMD} You can safely ignore this next error...
@@ -36,11 +35,11 @@ post-patch:
s|/usr/lib\(/aspell\)|${PREFIX}/share\1|g; \
s|/usr/share/info|&:${PREFIX}/info|g; \
s|\$$(sysconfdir)/profile.d|${PREFIX}/bin|g; \
- s|\(FLAC\)|\1\|flv\|FLV|' \
+ s|FLAC|&\|flv\|FLV|' \
${WRKSRC}/bash_completion ${WRKSRC}/Makefile.in \
${WRKSRC}/completions/* ${WRKSRC}/completions/helpers/*
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/bash-completion/pkg-plist b/shells/bash-completion/pkg-plist
index 16a1b985b764..d7faf9afc7e5 100644
--- a/shells/bash-completion/pkg-plist
+++ b/shells/bash-completion/pkg-plist
@@ -107,8 +107,8 @@ etc/bash_completion.d/ncftp
etc/bash_completion.d/net-tools
etc/bash_completion.d/nmap
etc/bash_completion.d/ntpdate
-etc/bash_completion.d/openldap
etc/bash_completion.d/open-iscsi
+etc/bash_completion.d/openldap
etc/bash_completion.d/openssl
etc/bash_completion.d/p4
etc/bash_completion.d/perl
@@ -181,4 +181,4 @@ etc/bash_completion.d/xz
etc/bash_completion.d/yp-tools
etc/bash_completion.d/yum-arch
@dirrm etc/bash_completion.d/helpers
-@dirrm etc/bash_completion.d
+@dirrmtry etc/bash_completion.d