aboutsummaryrefslogtreecommitdiff
path: root/shells/bash2
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-10-20 07:55:54 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-10-20 07:55:54 +0000
commitaea1bd23349474ce3cd447fbc8ac6961e16e8bc1 (patch)
tree66c2e2c50e6c12adba89cb56f82be69a9dcb6c2c /shells/bash2
parent0546f23a3c4622efb63111c3f998a3bf46d00d92 (diff)
downloadports-aea1bd23349474ce3cd447fbc8ac6961e16e8bc1.tar.gz
ports-aea1bd23349474ce3cd447fbc8ac6961e16e8bc1.zip
bash2 links against the system readline, so patch it to build with the
system readline headers too. This prevents segfaults due to certain key sequences. PR: ports/75315 Submitted by: Michiel Boland Approved by: portmgr (marcus) Approved by: obrien (maintainer, timeout 22 months)
Notes
Notes: svn path=/head/; revision=175427
Diffstat (limited to 'shells/bash2')
-rw-r--r--shells/bash2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 5fd086eb9aa6..a857c7e04cf2 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -8,7 +8,7 @@
PORTNAME= bash
PORTVERSION= 2.05b.007
-PORTREVISION?= 5
+PORTREVISION?= 6
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.cwru.edu/pub/bash/
@@ -51,6 +51,9 @@ INFO= bash
post-patch:
@${REINPLACE_CMD} -e "s,.FN /bin/bash,.FN ${PREFIX}/bin/bash," \
${WRKDIR}/${PORTNAME}-${PORTVERSION:R}/doc/bash.1
+ @${RM} -rf ${WRKSRC}/lib/readline/*
+ @${TOUCH} ${WRKSRC}/lib/readline/Makefile.in
+ @${REINPLACE_CMD} -E "s,^((RL|HIST)_LIBSRC = ).*,\1/usr/include/readline," ${WRKSRC}/Makefile.in
update-etc-shells:
@${ECHO_MSG} "updating /etc/shells"