aboutsummaryrefslogtreecommitdiff
path: root/shells/fd
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-02-10 17:12:36 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-02-10 17:12:36 +0000
commit6648b0f821c7b6e2184c730a842e4ab8b61f3829 (patch)
tree0d369d9a391cbb5e5e98bc456827428d21a01b86 /shells/fd
parent5fed14289df6795ab636267606abcf28b9624fca (diff)
downloadports-6648b0f821c7b6e2184c730a842e4ab8b61f3829.tar.gz
ports-6648b0f821c7b6e2184c730a842e4ab8b61f3829.zip
Update FD, a GUI-based file and directory management tool for text
terminal to version 2.00a. Put MAINTAINER's suggestions into the default configuration file. Transfer the maintainership over to knu@FreeBSD.org. Approved by: Nobuhiro Yasutomi <nobu@psrc.isac.co.jp> (ex-MAINTAINER)
Notes
Notes: svn path=/head/; revision=54487
Diffstat (limited to 'shells/fd')
-rw-r--r--shells/fd/Makefile48
-rw-r--r--shells/fd/distinfo2
-rw-r--r--shells/fd/files/patch-Makefile.in8
-rw-r--r--shells/fd/files/patch-_fdrc96
-rw-r--r--shells/fd/files/patch-aa11
-rw-r--r--shells/fd/files/patch-libc.c13
-rw-r--r--shells/fd/files/patch-parse.c48
-rw-r--r--shells/fd/pkg-comment2
-rw-r--r--shells/fd/pkg-descr17
-rw-r--r--shells/fd/pkg-message3
-rw-r--r--shells/fd/pkg-plist25
11 files changed, 169 insertions, 104 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index caf5025a7116..33ef514bb589 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -6,33 +6,51 @@
#
PORTNAME= fd
-PORTVERSION= 1.03u
-PORTREVISION= 2
+PORTVERSION= 2.00a
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.vector.co.jp/pack/unix/util/file/filer/fd/
DISTNAME= FD-${PORTVERSION}
-MAINTAINER= nobu@psrc.isac.co.jp
+MAINTAINER= knu@FreeBSD.org
-MANLANG= ja
+MANLANG= "" ja
MAN1= fd.1
-MAKE_ENV= LANG=${MANLANG}
-DOCS= README FAQ HISTORY ToAdmin
-SIGNATURE= Nobuhiro Yasutomi <${MAINTAINER}>
+MAKE_ENV= LANG=ja
-# require maintainer signature for binary package distributions
-do-configure:
- @cd ${WRKSRC}; v=version.h; ${MV} $$v $$v.orig; \
- ${SED} 's/\(distributor = \)NULL/\1"${SIGNATURE}"/' $$v.orig > $$v
+DOCS_EN= FAQ.eng \
+ LICENSES.eng \
+ README.eng \
+ TECHKNOW.eng \
+ ToAdmin.eng
+DOCS_JA= FAQ \
+ HISTORY \
+ LICENSES \
+ README \
+ TECHKNOW \
+ ToAdmin
post-install:
+ @${ECHO} "Updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/fdsh /etc/shells.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/fdsh) > /etc/shells
+ @${RM} /etc/shells.bak
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/fd
- @for i in $(DOCS); do \
- ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/fd; \
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ @${MKDIR} ${PREFIX}/share/doc/ja/${PORTNAME}
+ @for i in ${DOCS_EN}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/${PORTNAME}; \
done
-.endif
+ @for i in ${DOCS_JA}; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/share/doc/ja/${PORTNAME}; \
+ done
+ @${INSTALL_DATA} ${WRKSRC}/_fdrc.orig ${PREFIX}/etc/fd2rc.dist
+ @${INSTALL_DATA} ${WRKSRC}/_fdrc ${PREFIX}/etc/fd2rc.sample
+ if [ ! -f ${PREFIX}/etc/fd2rc ]; then \
+ ${CP} -p ${PREFIX}/etc/fd2rc.sample ${PREFIX}/etc/fd2rc; \
+ fi
@${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>
diff --git a/shells/fd/distinfo b/shells/fd/distinfo
index dc23017b3852..adfe7157ff7f 100644
--- a/shells/fd/distinfo
+++ b/shells/fd/distinfo
@@ -1 +1 @@
-MD5 (FD-1.03u.tar.gz) = 1b0629a201c89b54e9e2517caa7242c8
+MD5 (FD-2.00a.tar.gz) = d5b6245117c9292ac8b3ae6107e72069
diff --git a/shells/fd/files/patch-Makefile.in b/shells/fd/files/patch-Makefile.in
new file mode 100644
index 000000000000..9547dce545ad
--- /dev/null
+++ b/shells/fd/files/patch-Makefile.in
@@ -0,0 +1,8 @@
+--- Makefile.in.orig Fri Jan 11 00:00:00 2002
++++ Makefile.in Thu Jan 31 22:33:39 2002
+@@ -7 +7 @@
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+@@ -15 +15 @@
+-DEFRC = /etc/fd__RCVERSION__rc
++DEFRC = $(TOPDIR)/etc/fd__RCVERSION__rc
diff --git a/shells/fd/files/patch-_fdrc b/shells/fd/files/patch-_fdrc
new file mode 100644
index 000000000000..79d467965444
--- /dev/null
+++ b/shells/fd/files/patch-_fdrc
@@ -0,0 +1,96 @@
+--- _fdrc.orig Wed Feb 6 00:00:00 2002
++++ _fdrc Mon Feb 11 01:28:06 2002
+@@ -13,2 +13,3 @@
+ #SORTTYPE=0
++FD_SORTTYPE=101
+
+@@ -29,2 +30,3 @@
+ #SORTTREE=0
++FD_SORTTREE=1
+
+@@ -50,2 +52,3 @@
+ #ADJTTY=0
++FD_ADJTTY=1
+
+@@ -104,2 +107,3 @@
+ #ANSICOLOR=0
++FD_ANSICOLOR=1
+
+@@ -144,2 +148,3 @@
+ #LANGUAGE=$LANG
++FD_LANGUAGE=$LANG
+
+@@ -215,2 +220,3 @@
+ #PAGER=more%K
++FD_PAGER=${PAGER:-more}%K
+ #EDITOR=vi
+@@ -222,2 +228,35 @@
+ # launcher definition
++tar="tar"
++
++case `$tar --version 2>&1` in
++*GNU*\ 1.1[01]*)
++ tar_format="%a %u/%g %s %m %d %t %y %f"
++ ;;
++*)
++ tar_format="%a %u/%g %s %y-%m-%d %t %f"
++ ;;
++esac
++
++launch ".tar" "$tar tvf" "$tar_format"
++
++for ext in .tar.Z .taZ .tar.gz .tgz .taz; do
++ launch "$ext" "$tar ztvf %C" "$tar_format"
++done
++
++for ext in .tar.bz2 .tbz2; do
++ launch "$ext" "$tar jtvf %C" "$tar_format"
++done
++
++launch "/.lzh" "lha -lq" "%a %u/%g %s %x %m %d %{yt} %f"
++
++for ext in /.zip /.jar; do
++ launch "$ext" "unzip -lqq" "%s %m-%d-%y %t %f"
++done
++
++for ext in .Z .gz; do
++ launch "$ext" "zcat %C | $PAGER"
++done
++
++launch ".bz2" "bzip2 -cd %C | $PAGER"
++
+ #(Default)
+@@ -325,2 +364,33 @@
+ # archiver definition
++
++arch ".tar" "$tar cf %C %T" "$tar xf %C %TA"
++
++for ext in .tar.Z .taZ; do
++ arch "$ext" "$tar Zcf %C %T" "$tar Zxf %C %TA"
++done
++
++for ext in .tar.gz .tgz .taz; do
++ arch "$ext" "$tar cf - %T | gzip -9c > %C" "$tar zxf %C %TA"
++done
++
++for ext in .tar.bz2 .tbz2; do
++ arch "$ext" "$tar cf - %T | bzip2 -9c > %C" "$tar jxf %C %TA"
++done
++
++arch "/.lzh" "lha aq %C %TA" "lha xq %C %TA"
++
++for ext in /.zip /.jar; do
++ arch "$ext" "zip -q %C %TA" "unzip -q %C %TA"
++done
++
++_uuencode() {
++ uu=$1
++ shift
++ for file; do
++ uuencode $file $file >> $uu
++ done
++}
++
++arch ".uu" "_uuencode %C %TA" "uudecode -ic < %C"
++
+ #(Default)
diff --git a/shells/fd/files/patch-aa b/shells/fd/files/patch-aa
deleted file mode 100644
index f8ac5e212644..000000000000
--- a/shells/fd/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Tue Dec 18 00:00:00 2001
-+++ Makefile.in Wed Dec 19 13:02:55 2001
-@@ -4,7 +4,7 @@
-
- TITLE = FD-
- VERSION = __VERSION__
--PREFIX = /usr/local
-+PREFIX ?= /usr/local
- MANSEC = 1
- TOPDIR = $(PREFIX)
- BINDIR = $(TOPDIR)/bin
diff --git a/shells/fd/files/patch-libc.c b/shells/fd/files/patch-libc.c
deleted file mode 100644
index 79c7e0ac01b2..000000000000
--- a/shells/fd/files/patch-libc.c
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -u ../old/FD-1.03u/libc.c ./libc.c
---- ../old/FD-1.03u/libc.c Tue Dec 18 00:00:00 2001
-+++ ./libc.c Tue Jan 8 12:06:14 2002
-@@ -165,7 +165,8 @@
- buf[i] = '\0';
- if (*buf == _SC_) strcpy(resolved, buf);
- else {
-- *(cp - 1) = '\0';
-+ if (cp - 1 > resolved) cp--;
-+ *cp = '\0';
- _realpath2(buf, resolved, rdlink);
- }
- }
diff --git a/shells/fd/files/patch-parse.c b/shells/fd/files/patch-parse.c
deleted file mode 100644
index 4e809b6e64d6..000000000000
--- a/shells/fd/files/patch-parse.c
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -u ../old/FD-1.03u/parse.c ./parse.c
---- ../old/FD-1.03u/parse.c Tue Dec 18 00:00:00 2001
-+++ ./parse.c Mon Jan 21 10:15:02 2002
-@@ -322,11 +322,16 @@
- epath = next = NULL;
- size = 0;
- for (cp = path; cp && *cp; cp = next) {
-- next = strtkbrk(cp, delim, 0);
-- len = (next) ? (next++) - cp : strlen(cp);
-- if (!len) next = cp;
-+ if ((next = strtkbrk(cp, delim, 0))) {
-+ len = next - cp;
-+ for (i = 1; next[i] && strchr(delim, next[i]); i++);
-+ }
- else {
-- next = cp + len;
-+ len = strlen(cp);
-+ i = 0;
-+ }
-+ next = cp + len;
-+ if (len) {
- tmp = _evalpath(cp, next, 0, 0);
- # if !MSDOS && !defined (_NOKANJIFCONV)
- cp = kanjiconv2(buf, tmp,
-@@ -336,17 +341,18 @@
- # endif
- len = strlen(cp);
- }
-- for (i = 1; next[i] && strchr(delim, next[i]); i++);
-
- epath = (char *)realloc2(epath, size + len + i + 1);
- if (len) {
- strcpy(epath + size, cp);
- free(tmp);
-+ size += len;
-+ }
-+ if (i) {
-+ strncpy(epath + size, next, i);
-+ size += i;
-+ next += i;
- }
-- size += len;
-- strncpy(epath + size, next, i);
-- size += i;
-- next += i;
- }
-
- if (!epath) return(strdup2(""));
diff --git a/shells/fd/pkg-comment b/shells/fd/pkg-comment
index 2a1c33f6ef57..bc0c7a71d641 100644
--- a/shells/fd/pkg-comment
+++ b/shells/fd/pkg-comment
@@ -1 +1 @@
-A file and directory management tool
+A GUI-based file and directory management tool for text terminal
diff --git a/shells/fd/pkg-descr b/shells/fd/pkg-descr
index a078751d2411..c56080106e0e 100644
--- a/shells/fd/pkg-descr
+++ b/shells/fd/pkg-descr
@@ -1,11 +1,10 @@
-`FD' is a file and directory management tool for text terminal.
-Browsing file list, viewing, editing, archiving/extracting management
-with a few touch.
+`FD' (FDclone) is a GUI-based file and directory management tool for
+text terminal which allows you to browse and manipulate directories
+and files with an easy and intuitive user interface. It also has a
+built-in Bourne-shell compatible shell which can be run stand-alone by
+the name of `fdsh'.
-FD for unix by shirai@nintendo.co.jp, and it is a clone of
-FD for DOS (AT and PC9801) designed by A. Idei (SDI00544@niftyserve.or.jp).
+This version is a clone of FD for DOS (AT and PC9801) designed &
+written by A. Idei (SDI00544@niftyserve.or.jp).
- Currently, the man page is available only in Japanese, but it's
- easy to use. Setting `FD_LANGUAGE' environment to 'english' you can
- use English help.
- -- nobu@psrc.isac.co.jp
+Author: Takashi SHIRAI <shirai@nintendo.co.jp>
diff --git a/shells/fd/pkg-message b/shells/fd/pkg-message
index 8fe25b4fd54f..6bf477081987 100644
--- a/shells/fd/pkg-message
+++ b/shells/fd/pkg-message
@@ -1 +1,2 @@
-see additional documents at /usr/local/share/doc/fd/* on your disk.
+Read the document files in /usr/local/share/doc/fd, and use the
+example fd2rc files in /usr/local/etc.
diff --git a/shells/fd/pkg-plist b/shells/fd/pkg-plist
index c14d2454823e..8f421cd15ea2 100644
--- a/shells/fd/pkg-plist
+++ b/shells/fd/pkg-plist
@@ -1,7 +1,22 @@
bin/fd
+bin/fdsh
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
bin/fd-unicd.tbl
-share/doc/fd/FAQ
-share/doc/fd/HISTORY
-share/doc/fd/README
-share/doc/fd/ToAdmin
-@dirrm share/doc/fd
+etc/fd2rc.dist
+@unexec if cmp -s %D/etc/fd2rc %D/etc/fd2rc.sample; then rm -f %D/etc/fd2rc; fi
+etc/fd2rc.sample
+@exec [ ! -f %B/fd2rc ] && cp %B/%f %B/fd2rc
+%%PORTDOCS%%share/doc/ja/fd/FAQ
+%%PORTDOCS%%share/doc/ja/fd/HISTORY
+%%PORTDOCS%%share/doc/ja/fd/LICENSES
+%%PORTDOCS%%share/doc/ja/fd/README
+%%PORTDOCS%%share/doc/ja/fd/TECHKNOW
+%%PORTDOCS%%share/doc/ja/fd/ToAdmin
+%%PORTDOCS%%@dirrm share/doc/ja/fd
+%%PORTDOCS%%share/doc/fd/FAQ.eng
+%%PORTDOCS%%share/doc/fd/LICENSES.eng
+%%PORTDOCS%%share/doc/fd/README.eng
+%%PORTDOCS%%share/doc/fd/TECHKNOW.eng
+%%PORTDOCS%%share/doc/fd/ToAdmin.eng
+%%PORTDOCS%%@dirrm share/doc/fd