aboutsummaryrefslogtreecommitdiff
path: root/shells/p5-Term-ShellUI
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2007-01-29 12:13:01 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2007-01-29 12:13:01 +0000
commit98edc829d203a88be4163644314081caeee9d3a2 (patch)
treefc792ec7612c8557ef9d684a69643777ecc0dac2 /shells/p5-Term-ShellUI
parent3b9a53370357131f3152d95b2378d56d2c23a70b (diff)
downloadports-98edc829d203a88be4163644314081caeee9d3a2.tar.gz
ports-98edc829d203a88be4163644314081caeee9d3a2.zip
- Install examples. [1]
- Add dependancy on devel/p5-ReadLine-Perl. It enables autocompletion feature. [2] - Butify COMMENT. - Pass to perl@ Submitted by: az [1], [2]
Notes
Notes: svn path=/head/; revision=183617
Diffstat (limited to 'shells/p5-Term-ShellUI')
-rw-r--r--shells/p5-Term-ShellUI/Makefile24
-rw-r--r--shells/p5-Term-ShellUI/pkg-plist12
2 files changed, 34 insertions, 2 deletions
diff --git a/shells/p5-Term-ShellUI/Makefile b/shells/p5-Term-ShellUI/Makefile
index 68b8b5f33c18..1d0fc8086b88 100644
--- a/shells/p5-Term-ShellUI/Makefile
+++ b/shells/p5-Term-ShellUI/Makefile
@@ -7,17 +7,37 @@
PORTNAME= Term-ShellUI
PORTVERSION= 0.85
+PORTREVISION= 1
CATEGORIES= shells perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Term/BRONSON
PKGNAMEPREFIX= p5-
-MAINTAINER= sem@FreeBSD.org
-COMMENT= Term::ShellUI - A fully-featured shell-like command line environment
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A fully-featured shell-like command line environment
+
+RUN_DEPENDS= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
PERL_CONFIGURE= yes
+SAMPLESDIR= ${WRKSRC}/examples
+
MAN3= Term::ShellUI.3 \
Text::Shellwords::Cursor.3
+post-install:
+
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}/RPC
+ @${MKDIR} ${EXAMPLESDIR}/Term
+ @${INSTALL_DATA} ${SAMPLESDIR}/RPC/Connection.pm ${EXAMPLESDIR}/RPC
+ @${INSTALL_DATA} ${SAMPLESDIR}/Term/ExprUI.pm ${EXAMPLESDIR}/Term
+ @${INSTALL_DATA} ${SAMPLESDIR}/README ${EXAMPLESDIR}
+.for file in fileman-example psh synopsys synopsys-old tui-sample xmlexer
+ @${INSTALL_SCRIPT} ${SAMPLESDIR}/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/shells/p5-Term-ShellUI/pkg-plist b/shells/p5-Term-ShellUI/pkg-plist
index 8062c05c94a8..a869f69306f4 100644
--- a/shells/p5-Term-ShellUI/pkg-plist
+++ b/shells/p5-Term-ShellUI/pkg-plist
@@ -1,6 +1,18 @@
%%SITE_PERL%%/Term/ShellUI.pm
%%SITE_PERL%%/Text/Shellwords/Cursor.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/RPC/Connection.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Term/ExprUI.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/fileman-example
+%%PORTDOCS%%%%EXAMPLESDIR%%/psh
+%%PORTDOCS%%%%EXAMPLESDIR%%/synopsys
+%%PORTDOCS%%%%EXAMPLESDIR%%/synopsys-old
+%%PORTDOCS%%%%EXAMPLESDIR%%/tui-sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/xmlexer
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/RPC
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Term
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ShellUI
@dirrmtry %%SITE_PERL%%/Text/Shellwords
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term