aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-06-20 00:09:20 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-06-20 00:09:20 +0000
commit9b68f5d5fa78dd71ae014e7798e83a97fd19a7ba (patch)
tree5fa3d1df99a468cad1e540cb1fdf173f34671bfe /shells
parenta846087921f527c6362ef28182d346ccd4b67c59 (diff)
downloadports-9b68f5d5fa78dd71ae014e7798e83a97fd19a7ba.tar.gz
ports-9b68f5d5fa78dd71ae014e7798e83a97fd19a7ba.zip
Use the USES=tar:... variants.
Notes
Notes: svn path=/head/; revision=358479
Diffstat (limited to 'shells')
-rw-r--r--shells/44bsd-csh/Makefile3
-rw-r--r--shells/ambit/Makefile2
-rw-r--r--shells/bash-completion/Makefile9
-rw-r--r--shells/bashc/Makefile2
-rw-r--r--shells/heirloom-sh/Makefile2
-rw-r--r--shells/scponly/Makefile2
-rw-r--r--shells/shell-include/Makefile3
-rw-r--r--shells/vshnu/Makefile3
8 files changed, 11 insertions, 15 deletions
diff --git a/shells/44bsd-csh/Makefile b/shells/44bsd-csh/Makefile
index 27001a70da6e..fa10409c3b7c 100644
--- a/shells/44bsd-csh/Makefile
+++ b/shells/44bsd-csh/Makefile
@@ -10,10 +10,9 @@ MASTER_SITE_SUBDIR= cy
MAINTAINER= cy@FreeBSD.org
COMMENT= The traditional 4.4BSD /bin/csh C-shell
-USE_BZIP2= yes
-
BUILD_DEPENDS= rcs:${PORTSDIR}/devel/rcs57
+USES= tar:bz2
NO_WRKSUBDIR= yes
PORTDOCS= paper.ascii.gz
diff --git a/shells/ambit/Makefile b/shells/ambit/Makefile
index d3e79632f5e5..8d3adef1fbd7 100644
--- a/shells/ambit/Makefile
+++ b/shells/ambit/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 2.0.39
CATEGORIES= shells
MASTER_SITES= http://m.a.tt/er/
DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .tgz
MAINTAINER= sklauder@trimind.de
COMMENT= Extended bash brace expansion to expand hostnames or commands
@@ -15,6 +14,7 @@ LICENSE= GPLv3
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+USES= tar:tgz
AMBITDIR?= /var/spool/${PORTNAME}
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/shells/bash-completion/Makefile b/shells/bash-completion/Makefile
index 290143ad8bb6..0378e8665612 100644
--- a/shells/bash-completion/Makefile
+++ b/shells/bash-completion/Makefile
@@ -1,11 +1,11 @@
# Created by: kirk@strauser.com
# $FreeBSD$
-PORTNAME= bash-completion
+PORTNAME= bash-completion
PORTVERSION= 2.1
PORTREVISION= 3
-PORTEPOCH= 1
-CATEGORIES= shells
+PORTEPOCH= 1
+CATEGORIES= shells
MASTER_SITES= http://bash-completion.alioth.debian.org/files/
MAINTAINER= adamw@FreeBSD.org
@@ -13,10 +13,9 @@ COMMENT= Programmable completion library for Bash
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-USE_BZIP2= yes
USE_AUTOTOOLS= aclocal automake
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake tar:bz2
SUB_FILES= pkg-message
SUB_LIST+= RUNFILE=${DATADIR}/bash_completion.sh
diff --git a/shells/bashc/Makefile b/shells/bashc/Makefile
index 0ddf8217b296..6bf5a2b8f862 100644
--- a/shells/bashc/Makefile
+++ b/shells/bashc/Makefile
@@ -5,13 +5,13 @@ PORTNAME= bashc
PORTVERSION= 3.2.33.0
CATEGORIES= shells
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU bash shell extended with visual two-panel file browser
MAKE_JOBS_UNSAFE= yes
+USES= tar:tgz
GNU_CONFIGURE= yes
PLIST_FILES= bin/bashc \
diff --git a/shells/heirloom-sh/Makefile b/shells/heirloom-sh/Makefile
index 16875bac399a..311e00a6fb5c 100644
--- a/shells/heirloom-sh/Makefile
+++ b/shells/heirloom-sh/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= SF/heirloom/${PORTNAME}/${PORTVERSION}
MAINTAINER= danielt@pilgerer.org
COMMENT= Portable version of OpenSolaris' Bourne Shell
+USES= tar:bz2
MAKEFILE= makefile
-USE_BZIP2= yes
PLIST_FILES= bin/jsh \
man/man1/jsh.1.gz
PORTDOCS= CALDERA.LICENSE OPENSOLARIS.LICENSE CHANGES README
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 5b420a414c28..c976656a1712 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -8,13 +8,13 @@ CATEGORIES= shells security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}-snapshots
DISTNAME= ${PORTNAME}-20110526
-EXTRACT_SUFX= .tgz
MAINTAINER= gjb@FreeBSD.org
COMMENT= Tiny shell that only permits scp and sftp
PORTDOCS= BUILDING-JAILS.TXT INSTALL README SECURITY
+USES= tar:tgz
GNU_CONFIGURE= yes
OPTIONS_DEFINE= WILDCARDS GFTP CHROOT RSYNC SCP SVN SVNSERVE UNISON WINSCP \
diff --git a/shells/shell-include/Makefile b/shells/shell-include/Makefile
index f473473f5905..b460c48bbed1 100644
--- a/shells/shell-include/Makefile
+++ b/shells/shell-include/Makefile
@@ -5,7 +5,6 @@ PORTNAME= shell-include
PORTVERSION= 0.1.2
CATEGORIES= shells devel
MASTER_SITES= http://vvelox.net/src/shell-include/
-EXTRACT_SUFX= .tgz
MAINTAINER= vvelox@vvelox.net
COMMENT= Include system for shell scripts
@@ -14,7 +13,7 @@ USES= perl5
WRKSRC= ${WRKDIR}/${DISTNAME}
-NO_CONFIGURE= yes
+USES= tar:tgz
NO_BUILD= yes
do-install:
diff --git a/shells/vshnu/Makefile b/shells/vshnu/Makefile
index 2f3fb1046fe5..ef1aca275628 100644
--- a/shells/vshnu/Makefile
+++ b/shells/vshnu/Makefile
@@ -5,7 +5,6 @@ PORTNAME= vshnu
PORTVERSION= 1.0305
CATEGORIES= shells perl5
MASTER_SITES= http://www.cs.indiana.edu/~kinzler/${PORTNAME}/
-EXTRACT_SUFX= .tgz
MAINTAINER= miwi@FreeBSD.org
COMMENT= New Visual Shell
@@ -13,7 +12,7 @@ COMMENT= New Visual Shell
BUILD_DEPENDS= p5-Term-Screen>=0:${PORTSDIR}/devel/p5-Term-Screen
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5 shebangfix
+USES= perl5 shebangfix tar:tgz
USE_PERL5= configure
SHEBANG_FILES= *.pl