aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-18 12:06:59 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-18 12:06:59 +0000
commitb32681a60bff838e28459e5e6c6fc79839834395 (patch)
tree0e20a7365cab0c7a2e3b923aba3a597b7cda4b0f /shells
parentf469dea453a4f94794826659f8c0bc67654b38ef (diff)
downloadports-b32681a60bff838e28459e5e6c6fc79839834395.tar.gz
ports-b32681a60bff838e28459e5e6c6fc79839834395.zip
Fix build on amd64, and make this port actually run on 5.x.
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=104433
Diffstat (limited to 'shells')
-rw-r--r--shells/es/Makefile10
-rw-r--r--shells/es/files/patch-mksignal15
-rw-r--r--shells/es/files/patch-print.c16
3 files changed, 33 insertions, 8 deletions
diff --git a/shells/es/Makefile b/shells/es/Makefile
index 63153c63f0e4..2ca1e3a0ef2b 100644
--- a/shells/es/Makefile
+++ b/shells/es/Makefile
@@ -7,7 +7,7 @@
PORTNAME= es
PORTVERSION= 0.9.b1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= shells
MASTER_SITES= ftp://ftp.sys.toronto.edu/pub/es/
DISTNAME= es-0.9-beta1
@@ -22,10 +22,4 @@ ALL_TARGET= es
MAN1= es.1
PLIST_FILES= bin/es
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/shells/es/files/patch-mksignal b/shells/es/files/patch-mksignal
new file mode 100644
index 000000000000..17a4051c678b
--- /dev/null
+++ b/shells/es/files/patch-mksignal
@@ -0,0 +1,15 @@
+*** mksignal.orig Wed Dec 3 20:59:12 2003
+--- mksignal Wed Dec 3 21:00:50 2003
+***************
+*** 106,111 ****
+--- 106,115 ----
+ ignore["SIGRTMIN"] = 1
+ ignore["SIGSETS"] = 1
+ ignore["SIGSTKSZ"] = 1
++
++ # FreeBSD 5 added a signal beyond NSIG; es makes too many
++ # assumptions to make this worth fixing.
++ ignore["SIGTHR"] = 1
+
+ # upper to lowercase translation table: can someone give me an easier
+ # way to do this that works in ancient versions of awk?
diff --git a/shells/es/files/patch-print.c b/shells/es/files/patch-print.c
new file mode 100644
index 000000000000..eef906116206
--- /dev/null
+++ b/shells/es/files/patch-print.c
@@ -0,0 +1,16 @@
+*** print.c.orig Fri Apr 11 15:54:36 1997
+--- print.c Mon Mar 15 18:55:13 2004
+***************
+*** 279,285 ****
+--- 279,289 ----
+ VA_START(format->args, fmt);
+ n += printfmt(format, fmt);
+ va_end(format->args);
++ #if NO_VA_LIST_ASSIGN
++ memcpy(format->args, saveargs, sizeof(va_list));
++ #else
+ format->args = saveargs;
++ #endif
+
+ return n + format->flushed;
+ }