aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 13:13:03 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 13:13:03 +0000
commit8750d5977c299976eb553c6508c51cbd8b22b81b (patch)
treec164b717d58f0014e785fc5aa81290a10c1607ed /shells
parent493c742ea29f92e89e076afc6f10a99eb4f724f2 (diff)
downloadports-8750d5977c299976eb553c6508c51cbd8b22b81b.tar.gz
ports-8750d5977c299976eb553c6508c51cbd8b22b81b.zip
Use SUB_FILES for pkg-message
Notes
Notes: svn path=/head/; revision=158552
Diffstat (limited to 'shells')
-rw-r--r--shells/flash/Makefile4
-rw-r--r--shells/flash/files/pkg-message.in (renamed from shells/flash/pkg-message)2
-rw-r--r--shells/wapsh/Makefile4
-rw-r--r--shells/wapsh/files/pkg-message.in (renamed from shells/wapsh/pkg-message)0
4 files changed, 7 insertions, 3 deletions
diff --git a/shells/flash/Makefile b/shells/flash/Makefile
index 6f12de9dd81d..39e0b78722a7 100644
--- a/shells/flash/Makefile
+++ b/shells/flash/Makefile
@@ -26,6 +26,8 @@ GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -rdynamic" \
LDFLAGS="${LDFLAGS} -rdynamic"
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
MAN1= flash.1
@@ -69,6 +71,6 @@ post-install:
@(${GREP} -v ${PREFIX}/bin/flash /etc/shells.bak; \
${ECHO_CMD} ${PREFIX}/bin/flash) > /etc/shells
@${RM} /etc/shells.bak
- @${SED} -e "s:/usr/local:${PREFIX}:g" ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/shells/flash/pkg-message b/shells/flash/files/pkg-message.in
index 854dd2a6b7c4..a5f713b325ce 100644
--- a/shells/flash/pkg-message
+++ b/shells/flash/files/pkg-message.in
@@ -1,5 +1,5 @@
------------------------ WARNING ------------------------
This software is not yet ready-to-go on your system. You need
-to configure flash in /usr/local/lib/flash in order for it to
+to configure flash in %%PREFIX%%/lib/flash in order for it to
work properly.
---------------------------------------------------------
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index 5e1c6537d809..44bbaa3bf91e 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A system to allow remote shell logins via a WAP phone or web browser
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
USERGUIDEDOCS= Image10.jpg Image11.jpg Image12.jpg Image13.jpg \
Image14.jpg Image15.jpg Image16.jpg Image17.jpg \
@@ -91,6 +93,6 @@ post-install:
${ECHO} "===> Installing ${PREFIX}/etc/rc.d/htshd.sh startup file."; \
${INSTALL_SCRIPT} ${FILESDIR}/htshd.sh ${PREFIX}/etc/rc.d/htshd.sh; \
fi
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/shells/wapsh/pkg-message b/shells/wapsh/files/pkg-message.in
index 6228883b3740..6228883b3740 100644
--- a/shells/wapsh/pkg-message
+++ b/shells/wapsh/files/pkg-message.in