aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2009-03-13 15:54:23 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2009-03-13 15:54:23 +0000
commit80321f0d0e7eb6a6fb821b894908b93637ee65d2 (patch)
treedf2815faf2b395ce02cff55f647365b522f10466 /shells
parent403f254ba862ca9214d30a1c7afdce4c31eae29c (diff)
downloadports-80321f0d0e7eb6a6fb821b894908b93637ee65d2.tar.gz
ports-80321f0d0e7eb6a6fb821b894908b93637ee65d2.zip
Use Bison in the build instead of byacc.
This fixes the issue of '$()' (for ``) not being parsed correctly. PR: 101230 Submitted by: bf2006a@yahoo.com
Notes
Notes: svn path=/head/; revision=229998
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index e556f567fc76..8efdae7eb3d0 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -9,7 +9,7 @@
PORTNAME= bash
PATCHLEVEL= 10
PORTVERSION= 4.0.${PATCHLEVEL:S/^0//g}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:bash/} \
ftp://ftp.cwru.edu/pub/%SUBDIR%/:faq
@@ -44,6 +44,7 @@ MAN1= bash.1 bashbug.1
INFO= bash
GNU_CONFIGURE= yes
+USE_BISON= build
.if !defined(NOPORTDOCS)
.if !defined(WITH_INCLUDED_FAQ)
@@ -92,7 +93,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
- YACC="${YACC}"
+ YACC="bison"
.include <bsd.port.pre.mk>
@@ -128,6 +129,9 @@ post-install:
@${SETENV} PKG_PREFIX="${PREFIX}" PKG_DESTDIR="${DESTDIR}" \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+regress: build
+ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
+
cklatest:
-ncftpls \
ftp://ftp.cwru.edu/pub/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/\.[0-9a-z]*$//}-patches/ \