aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-12-04 23:27:23 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-12-04 23:27:23 +0000
commit8642c28c934cd90a4146d417a8e720546f3f21ce (patch)
tree55f83918725125f559a94bc8fb102d2879f5c99f /shells
parentbaf3ba05d0f9d697fb380b96fb593cbeee1d00d5 (diff)
downloadports-8642c28c934cd90a4146d417a8e720546f3f21ce.tar.gz
ports-8642c28c934cd90a4146d417a8e720546f3f21ce.zip
Update to zsh 5.2
While here: - ensure zsh looks ${PREFIX}/etc for zshrc [1] - hook the testsuite to our test framework PR: 201866 Submitted by: Georgy <delycid@gmail.com>
Notes
Notes: svn path=/head/; revision=403014
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile6
-rw-r--r--shells/zsh/distinfo9
-rw-r--r--shells/zsh/files/patch-Test_C02cond.ztst11
-rw-r--r--shells/zsh/pkg-plist13
4 files changed, 32 insertions, 7 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 1dbe0cd8dba7..f74a1155677c 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zsh
-DISTVERSION= 5.1.1
+DISTVERSION= 5.2
CATEGORIES= shells
MASTER_SITES= \
http://www.zsh.org/pub/:doc \
@@ -35,13 +35,15 @@ SHEBANG_LANG= zsh
zsh_OLD_CMD= /bin/zsh
zsh_CMD= ${PREFIX}/bin/zsh
GNU_CONFIGURE= yes
+TEST_TARGET= test
CPPFLAGS+= -I${LOCALBASE}/include -DBOOL_DEFINED
LDFLAGS+= -L${LOCALBASE}/lib -Wl,--as-needed
CONFIGURE_ENV+= zsh_cv_sys_path_dev_fd=no
CONFIGURE_ARGS= --with-term-lib="ncursesw ncurses" --with-tcsetpgrp \
--enable-function-subdirs --enable-multibyte \
- --sysconfdir=${PREFIX}/etc
+ --sysconfdir=${PREFIX}/etc \
+ --enable-etcdir=${PREFIX}/etc
EXTRA_PATCHES= ${FILESDIR}/extra-patch-bsdtar
#EXTRA_COMPLETION_FILES= _sockstat
diff --git a/shells/zsh/distinfo b/shells/zsh/distinfo
index d71ed3f852ee..1d163cfc8c2f 100644
--- a/shells/zsh/distinfo
+++ b/shells/zsh/distinfo
@@ -1,4 +1,5 @@
-SHA256 (zsh-5.1.1.tar.xz) = 74e9453b5470b3c0970f9f93cfd603d241c3d7b1968adc0e4b3951073e8d3dec
-SIZE (zsh-5.1.1.tar.xz) = 2788676
-SHA256 (zsh-5.1.1-doc.tar.xz) = f5944f29ec77100afdc3634f0bb8ffc4328a2d03147f23d1aa6280b6aa7d622f
-SIZE (zsh-5.1.1-doc.tar.xz) = 3061616
+timestamp=1449268592
+SHA256 (zsh-5.2.tar.xz) = f17916320ffaa844bbd7ce48ceeb5945fc5f3eff64b149b4229bbfbdf3795a9d
+SIZE (zsh-5.2.tar.xz) = 2820108
+SHA256 (zsh-5.2-doc.tar.xz) = 328352cf3d5d0ec4b6e31dcefd25ff5b4c0e6b8077d1fe84448ebb50d6ada52a
+SIZE (zsh-5.2-doc.tar.xz) = 3108600
diff --git a/shells/zsh/files/patch-Test_C02cond.ztst b/shells/zsh/files/patch-Test_C02cond.ztst
new file mode 100644
index 000000000000..78da595b2439
--- /dev/null
+++ b/shells/zsh/files/patch-Test_C02cond.ztst
@@ -0,0 +1,11 @@
+--- Test/C02cond.ztst.orig 2015-11-22 15:17:55 UTC
++++ Test/C02cond.ztst
+@@ -154,7 +154,7 @@
+ ZTST_skip="[[ -N file ]] not supported on Cygwin"
+ elif (( isnfs )); then
+ ZTST_skip="[[ -N file ]] not supported with NFS"
+- elif test -f /etc/mtab && { grep $(df . 2>/dev/null| tail -n1 | awk '{print $1}') /etc/mtab | grep -q noatime; }; then
++ elif { mount | grep $(df . 2>/dev/null| tail -n1 | awk '{print $1}') | grep -q noatime; } ; then
+ ZTST_skip="[[ -N file ]] not supported with noatime file system"
+ else
+ [[ -N $newnewnew && ! -N $unmodified ]]
diff --git a/shells/zsh/pkg-plist b/shells/zsh/pkg-plist
index 866baa45ceab..ba32123d1b70 100644
--- a/shells/zsh/pkg-plist
+++ b/shells/zsh/pkg-plist
@@ -20,6 +20,7 @@ bin/zsh-%%ZSH_VER%%
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/net/tcp.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/newuser.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/parameter.so
+%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/param/private.so
%%PCRE%%%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/pcre.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/regex.so
%%NO_STATIC%%lib/zsh/%%ZSH_VER%%/zsh/rlimits.so
@@ -57,6 +58,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Chpwd/chpwd_recent_dirs
%%DATADIR%%/%%ZSH_VER%%/functions/Chpwd/chpwd_recent_filehandler
%%DATADIR%%/%%ZSH_VER%%/functions/Chpwd/zsh_directory_name_cdr
+%%DATADIR%%/%%ZSH_VER%%/functions/Chpwd/zsh_directory_name_generic
%%DATADIR%%/%%ZSH_VER%%/functions/Completion.zwc
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/AIX.zwc
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/AIX/_floppy
@@ -281,6 +283,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Redhat.zwc
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Redhat/_dnf
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Redhat/_rpm
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Redhat/_scl
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Redhat/_yum
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Solaris.zwc
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Solaris/_be_name
@@ -358,6 +361,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_cpio
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_cplay
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_cssh
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_curl
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_ctags_tags
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_cut
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_cvs
@@ -435,6 +439,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_guilt
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_gzip
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_have_glob_qual
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_head
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_hg
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_hosts
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_iconv
@@ -461,6 +466,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_lha
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_links
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_list_files
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_lldb
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_ln
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_loadkeys
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_locales
@@ -506,6 +512,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_notmuch
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_npm
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_nslookup
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_objdump
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_od
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_other_accounts
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_pack
@@ -591,7 +598,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_sudo
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_surfraw
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_sysctl
-%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_systemd
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tail
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tar
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tar_archive
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tardy
@@ -613,6 +620,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_toilet
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_topgit
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_totd
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tr
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tracepath
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_tree
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_ttys
@@ -660,6 +668,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_zfs_pool
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_zip
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_zpool
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Unix/_zsh
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/X.zwc
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/X/_acroread
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/X/_dcop
@@ -810,6 +819,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Zsh/_zmv
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Zsh/_zpty
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Zsh/_zsh-mime-handler
+%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Zsh/_zsocket
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Zsh/_zstyle
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/Zsh/_ztodo
%%DATADIR%%/%%ZSH_VER%%/functions/Completion/bashcompinit
@@ -985,6 +995,7 @@ bin/zsh-%%ZSH_VER%%
%%DATADIR%%/%%ZSH_VER%%/functions/Zle/backward-kill-word-match
%%DATADIR%%/%%ZSH_VER%%/functions/Zle/backward-word-match
%%DATADIR%%/%%ZSH_VER%%/functions/Zle/bracketed-paste-magic
+%%DATADIR%%/%%ZSH_VER%%/functions/Zle/bracketed-paste-url-magic
%%DATADIR%%/%%ZSH_VER%%/functions/Zle/capitalize-word-match
%%DATADIR%%/%%ZSH_VER%%/functions/Zle/copy-earlier-word
%%DATADIR%%/%%ZSH_VER%%/functions/Zle/cycle-completion-positions