aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2007-03-21 17:36:19 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2007-03-21 17:36:19 +0000
commit8d6718db8f208208fc7fb0ae7e6418c7e986dba5 (patch)
tree59e61c4cd5c1cd11d451924f179b6aaae686588d /shells
parent3c59371e695dd739adf2e30014532fc5e19f1b2c (diff)
downloadports-8d6718db8f208208fc7fb0ae7e6418c7e986dba5.tar.gz
ports-8d6718db8f208208fc7fb0ae7e6418c7e986dba5.zip
- Use proper NO_SHARED knob instead of obsoleted NOSHARED
PR: ports/108327 Submitted by: Josh Carroll (floyd AT pflog DOT net)
Notes
Notes: svn path=/head/; revision=187916
Diffstat (limited to 'shells')
-rw-r--r--shells/zsh/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index 3aa53fd771fb..3b8fcfcda27b 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -6,7 +6,7 @@
#
# The following compile-time options are available:
-# NOSHARED=yes compile a static version of zsh
+# NO_SHARED=yes compile a static version of zsh
# (default: use dynamically loadable modules)
# WITHOUT_ZSH_MEM=yes disable zsh-mem and zsh-secure-free options
# (default: on)
@@ -75,7 +75,7 @@ CONFIGURE_ARGS+= --enable-zsh-mem --enable-zsh-secure-free
CONFIGURE_ARGS+= --enable-maildir-support
.endif
-.if defined(NOSHARED)
+.if defined(NO_SHARED)
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -static"
CONFIGURE_ARGS+= --disable-dynamic
PLIST_SUB+= NO_STATIC="@comment "