aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2006-05-24 11:48:20 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2006-05-24 11:48:20 +0000
commit102e47aa5ccfe325e8f905d188d8c568f1a2ff28 (patch)
treedb9958b1b2a935b3d62a0ab516e54e0a7686a6b7 /shells
parent44cc144748a2dfb4813aeaac05b21030dd3068c2 (diff)
downloadports-102e47aa5ccfe325e8f905d188d8c568f1a2ff28.tar.gz
ports-102e47aa5ccfe325e8f905d188d8c568f1a2ff28.zip
Update to 2.08c.
Notes
Notes: svn path=/head/; revision=163272
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile3
-rw-r--r--shells/fd/distinfo4
-rw-r--r--shells/fd/files/patch-shell.c47
3 files changed, 3 insertions, 51 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index dfba34e4d9a8..885ab9c1a44e 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fd
-PORTVERSION= 2.08b
-PORTREVISION= 1
+PORTVERSION= 2.08c
CATEGORIES= shells
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
diff --git a/shells/fd/distinfo b/shells/fd/distinfo
index 23f70ff37fdd..2e24665849c8 100644
--- a/shells/fd/distinfo
+++ b/shells/fd/distinfo
@@ -1,2 +1,2 @@
-MD5 (FD-2.08b.tar.gz) = c9e33e49e032002a74d18d50bfc2210a
-SIZE (FD-2.08b.tar.gz) = 722831
+MD5 (FD-2.08c.tar.gz) = df5faa820e60caaaa50164eb004ccf95
+SIZE (FD-2.08c.tar.gz) = 723077
diff --git a/shells/fd/files/patch-shell.c b/shells/fd/files/patch-shell.c
deleted file mode 100644
index 8d79078746b3..000000000000
--- a/shells/fd/files/patch-shell.c
+++ /dev/null
@@ -1,47 +0,0 @@
-cf. [FDclone-users:00493]
-
-diff -u ../old/FD-2.08b/shell.c ./shell.c
---- ../old/FD-2.08b/shell.c Thu Mar 30 00:00:00 2006
-+++ ./shell.c Mon Apr 10 22:45:35 2006
-@@ -1630,12 +1630,7 @@
- int i, j, size;
-
- if (!file || !(fp = Xfopen(file, "r"))) return(-1);
--#ifndef NOFLOCK
-- if (lockfile(Xfileno(fp), LCK_READ) < 0) {
-- Xfclose(fp);
-- return(-1);
-- }
--#endif
-+ VOID_C lockfile(Xfileno(fp), LCK_READ);
-
- size = (int)histsize[n];
- history[n] = (char **)malloc2(sizeof(char *) * (size + 1));
-@@ -1650,7 +1645,7 @@
- for (j = i; j > 0; j--) history[n][j] = history[n][j - 1];
- history[n][0] = line;
- }
-- lockfile(Xfileno(fp), LCK_UNLOCK);
-+ VOID_C lockfile(Xfileno(fp), LCK_UNLOCK);
- Xfclose(fp);
-
- for (i++; i <= size; i++) history[n][i] = NULL;
-@@ -1684,16 +1679,11 @@
-
- if (!history[n] || !history[n][0]) return(-1);
- if (!file || !(fp = Xfopen(file, "w"))) return(-1);
--#ifndef NOFLOCK
-- if (lockfile(Xfileno(fp), LCK_WRITE) < 0) {
-- Xfclose(fp);
-- return(-1);
-- }
--#endif
-+ VOID_C lockfile(Xfileno(fp), LCK_WRITE);
-
- size = (savehist > (int)histsize[n]) ? (int)histsize[n] : savehist;
- for (i = size - 1; i >= 0; i--) convhistory(history[n][i], fp);
-- lockfile(Xfileno(fp), LCK_UNLOCK);
-+ VOID_C lockfile(Xfileno(fp), LCK_UNLOCK);
- Xfclose(fp);
-
- return(0);