aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2010-06-07 02:22:59 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2010-06-07 02:22:59 +0000
commit3c13448e3d36df7c9a47a9734272fbfba6b76e7d (patch)
tree8bab194977f91916ebe45b932cfeec889d95d583 /shells
parentd7b2a9b9c52e0756b85ba93a375974e0ca51d450 (diff)
downloadports-3c13448e3d36df7c9a47a9734272fbfba6b76e7d.tar.gz
ports-3c13448e3d36df7c9a47a9734272fbfba6b76e7d.zip
Apply a quick-fix against the problem introduced in 3.00g.
Notes
Notes: svn path=/head/; revision=255970
Diffstat (limited to 'shells')
-rw-r--r--shells/fd/Makefile1
-rw-r--r--shells/fd/files/patch-parse.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index 00d5df933f4d..c77489d0172e 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fd
PORTVERSION= 3.00g
+PORTREVISION= 1
CATEGORIES= shells net
MASTER_SITES= http://hp.vector.co.jp/authors/VA012337/soft/fd/ \
ftp://ftp.unixusers.net/src/fdclone/
diff --git a/shells/fd/files/patch-parse.c b/shells/fd/files/patch-parse.c
new file mode 100644
index 000000000000..f4a15cd2d306
--- /dev/null
+++ b/shells/fd/files/patch-parse.c
@@ -0,0 +1,14 @@
+Patch by Rikito INAKAZU [FDclone-users:00861]
+
+diff -u parse.c.orig parse.c
+--- parse.c.orig 2010-06-04 00:00:00.000000000 +0900
++++ parse.c 2010-06-05 22:16:04.000000000 +0900
+@@ -831,7 +831,7 @@
+ while (*cp) {
+ *bufp = c_realloc(*bufp, j + MAXCHARWID - 1, &size);
+ if (unprint) {
+- (*bufp)[j] = *cp;
++ (*bufp)[j++] = *cp++;
+ continue;
+ }
+