aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-03-29 22:48:09 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-03-29 22:48:09 +0000
commit4ab44e684669f8914664ae84796e924e1eedc79f (patch)
treec52ec410ae2b67cbdb3aabeb893e6bb95b0e1317 /shells
parent6380de6bcbdda27fc0e8cf8771f9dc9af41a15e5 (diff)
downloadports-4ab44e684669f8914664ae84796e924e1eedc79f.tar.gz
ports-4ab44e684669f8914664ae84796e924e1eedc79f.zip
make WRKDIR safe (fix broken on bento)
Notes
Notes: svn path=/head/; revision=40562
Diffstat (limited to 'shells')
-rw-r--r--shells/wapsh/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/shells/wapsh/Makefile b/shells/wapsh/Makefile
index dcee040ca770..12529c5a502d 100644
--- a/shells/wapsh/Makefile
+++ b/shells/wapsh/Makefile
@@ -41,8 +41,8 @@ HTDOCS= command.php command_html.inc command_wml.inc \
shortcuts_wml.php
post-patch:
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/htshd/htshd.c > foo && \
- ${MV} foo ${WRKSRC}/htshd/htshd.c
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/htshd/htshd.c > ${WRKDIR}/foo && \
+ ${MV} ${WRKDIR}/foo ${WRKSRC}/htshd/htshd.c
do-build:
(cd ${WRKSRC}/htshd && ${CC} ${CFLAGS} -o htshd htshd.c -lcrypt \