aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-11 08:55:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-11 08:55:13 +0000
commit217cd99bfef1825e3cab422c699f9b3300c3e7c6 (patch)
tree9f20c10e64cbe6a110f4c2ef68da877fcdb8e558 /shells
parenta1086ae0fceb6bed6fbbdf51af5e300ca0706f2d (diff)
downloadports-217cd99bfef1825e3cab422c699f9b3300c3e7c6.tar.gz
ports-217cd99bfef1825e3cab422c699f9b3300c3e7c6.zip
- Remove BROKEN.
- Comment out WANT_STATIC, which is currently broken. - Fix an mbstate_t syntax error; from Mitch Tishmack <otomo@qwest.net>. - Skip unused floating point tests that prevent building on alpha. - Point out LC_NUMERIC problem in pkg-message. PR: 31197 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=48661
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile7
-rw-r--r--shells/ksh93/files/patch-src_lib_libast_comp_wc.c13
-rw-r--r--shells/ksh93/files/patch-src_lib_libast_features_float37
-rw-r--r--shells/ksh93/pkg-message8
4 files changed, 61 insertions, 4 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 5b86daef4505..2836654f8ccf 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -12,16 +12,15 @@ MASTER_SITES= http://www.research.att.com/~gsf/download/tgz/
MAINTAINER= naddy@mips.inka.de
-BROKEN= "does not build"
RESTRICTED= "Source recipient must acknowledge license"
DISTNAME= ${PORTNAME}-${VERSION}
DISTFILES= INIT.${VERSION}.tgz ast-ksh.${VERSION}.tgz
NO_WRKSUBDIR= yes
MAKE_ARGS= CC='${CC}' CCFLAGS='${CFLAGS}' SHELL='${SH}'
-.if defined(WANT_STATIC)
-MAKE_ARGS+= LDFLAGS=-static
-.endif
+#.if defined(WANT_STATIC) # broken
+#MAKE_ARGS+= LDFLAGS=-static
+#.endif
MAN1= ksh93.1
diff --git a/shells/ksh93/files/patch-src_lib_libast_comp_wc.c b/shells/ksh93/files/patch-src_lib_libast_comp_wc.c
new file mode 100644
index 000000000000..60329af80194
--- /dev/null
+++ b/shells/ksh93/files/patch-src_lib_libast_comp_wc.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/lib/libast/comp/wc.c.orig Mon Oct 8 03:21:02 2001
++++ src/lib/libast/comp/wc.c Mon Oct 8 03:21:20 2001
+@@ -63,7 +63,6 @@
+ wcrtomb(char* s, wchar_t c, mbstate_t* q)
+ {
+ #if _lib_wctomb
+- *q = 0;
+ memset(q, 0, sizeof(*q));
+ return wctomb(s, c);
+ #else
diff --git a/shells/ksh93/files/patch-src_lib_libast_features_float b/shells/ksh93/files/patch-src_lib_libast_features_float
new file mode 100644
index 000000000000..dd83db9b7912
--- /dev/null
+++ b/shells/ksh93/files/patch-src_lib_libast_features_float
@@ -0,0 +1,37 @@
+
+$FreeBSD$
+
+--- src/lib/libast/features/float.orig Wed Oct 10 14:10:50 2001
++++ src/lib/libast/features/float Wed Oct 10 14:12:26 2001
+@@ -125,6 +125,7 @@
+ else
+ printf("#define UINTMAX_DIG ULONG_DIG\n");
+ printf("\n");
++ #if !defined(__alpha__) /* ksh93 doesn't use this */
+ f = 1;
+ w = 1;
+ do
+@@ -145,6 +146,7 @@
+ }
+ else
+ printf("#define FLT_UINTMAX_MAX FLT_ULONG_MAX\n");
++ #endif
+ #ifdef FLT_DIG
+ s = FLT_DIG;
+ #else
+@@ -256,6 +258,7 @@
+ printf("#endif\n");
+
+ printf("\n");
++ #if !defined(__alpha__) /* ksh93 doesn't use this */
+ d = 1.0;
+ w = 1;
+ do
+@@ -276,6 +279,7 @@
+ }
+ else
+ printf("#define DBL_UINTMAX_MAX DBL_ULONG_MAX\n");
++ #endif
+ #ifdef DBL_DIG
+ s = DBL_DIG;
+ #else
diff --git a/shells/ksh93/pkg-message b/shells/ksh93/pkg-message
index 6f69151e760e..2083eb413af7 100644
--- a/shells/ksh93/pkg-message
+++ b/shells/ksh93/pkg-message
@@ -16,3 +16,11 @@ product to ascertain the source code for any AT&T Software.
(c) AT&T Corp. All rights reserved. AT&T is a registered trademark
of AT&T Corp.
+
+------------------------------------------------------------------------
+
+Known problem: Defining the LC_NUMERIC environment variable, or
+any locale setting by which it is implied (LANG, LC_ALL), will cause
+ksh93 to crash. LC_COLLATE, LC_CTYPE, LC_MESSAGES, LC_MONETARY,
+and LC_TIME are safe.
+