aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2002-05-15 11:49:00 +0000
committerThomas Gellekum <tg@FreeBSD.org>2002-05-15 11:49:00 +0000
commit22263f8e8192a1e823a5112708c4011d60e526b5 (patch)
tree964720a3863646dbaa0c0d37083a2447162b2c0b /shells
parentbece67de0793587f5cd34c06133f2abf68d59a4b (diff)
downloadports-22263f8e8192a1e823a5112708c4011d60e526b5.tar.gz
ports-22263f8e8192a1e823a5112708c4011d60e526b5.zip
Include distributed patches.
PR: 38071 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
Notes
Notes: svn path=/head/; revision=59161
Diffstat (limited to 'shells')
-rw-r--r--shells/pdksh/Makefile11
-rw-r--r--shells/pdksh/distinfo2
-rw-r--r--shells/pdksh/files/patch-aa17
3 files changed, 12 insertions, 18 deletions
diff --git a/shells/pdksh/Makefile b/shells/pdksh/Makefile
index a38e18e57a15..588036f30330 100644
--- a/shells/pdksh/Makefile
+++ b/shells/pdksh/Makefile
@@ -6,13 +6,18 @@
#
PORTNAME= pdksh
-PORTVERSION= 5.2.14
+PORTVERSION= 5.2.14.p2
CATEGORIES= shells
MASTER_SITES= ftp://ftp.cs.mun.ca/pub/pdksh/ \
http://gd.tuwien.ac.at/utils/shells/pdksh/ \
ftp://ftp.lip6.fr/pub/unix/shells/pdksh/ \
ftp://ftp.demon.net/pub/mirrors/pdksh/ \
ftp://ftp.rge.com/pub/shells/pdksh/
+DISTNAME= ${PORTNAME}-${PORTVERSION:N*p*}${PORTVERSION:M*p*:R}
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= ${DISTNAME}-patches.1 ${DISTNAME}-patches.2
+PATCH_DIST_STRIP= -p2
MAINTAINER= tg@FreeBSD.org
@@ -20,6 +25,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LDSTATIC=-static
MAN1= ksh.1
+post-patch:
+ @(${ECHO_CMD} ",s/v${PORTVERSION:N*p*}${PORTVERSION:M*p*:R} /v${PORTVERSION:S/p//} /"; \
+ ${ECHO_CMD} "wq") | ed -s ${WRKSRC}/version.c
+
post-install:
@${ECHO} "Updating /etc/shells"
@${CP} /etc/shells /etc/shells.bak
diff --git a/shells/pdksh/distinfo b/shells/pdksh/distinfo
index 2a7154e69ef1..f1cd49d99fb3 100644
--- a/shells/pdksh/distinfo
+++ b/shells/pdksh/distinfo
@@ -1 +1,3 @@
MD5 (pdksh-5.2.14.tar.gz) = 871106b3bd937e1afba9f2ef7c43aef3
+MD5 (pdksh-5.2.14-patches.1) = c91364eb3de43a052c53d263000fe14c
+MD5 (pdksh-5.2.14-patches.2) = 77d7e089e9fe9ca396d520c728f25136
diff --git a/shells/pdksh/files/patch-aa b/shells/pdksh/files/patch-aa
deleted file mode 100644
index e2b07f548c96..000000000000
--- a/shells/pdksh/files/patch-aa
+++ /dev/null
@@ -1,17 +0,0 @@
---- jobs.c.orig Tue Jul 13 18:50:56 1999
-+++ jobs.c Wed Jul 21 08:10:45 1999
-@@ -1846,6 +1846,7 @@
- int alen;
- char **ap;
-
-+#if 0
- if (t->type == TEXEC || t->type == TCOM) {
- /* Causes problems when set -u is in effect, can also
- cause problems when array indices evaluated (may have
-@@ -1870,5 +1871,6 @@
- }
- *c = '\0';
- } else
-+#endif
- snptreef(c, len, "%T", t);
- }