aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-31 05:56:31 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-31 05:56:31 +0000
commitff342e75da01d5086c0d142c5ad503ab3e710332 (patch)
treea4061f5f0723a9e612c9f33033b8974df25c1ae7 /shells
parent3b958fc914e24661941243a8d0ff1d550e4d2616 (diff)
downloadports-ff342e75da01d5086c0d142c5ad503ab3e710332.tar.gz
ports-ff342e75da01d5086c0d142c5ad503ab3e710332.zip
- remove DIST_SUBDIR
- touch -> ${TOUCH} - add post-install target to update /etc/shells (to match pkg-plist @exec) - make sure to remove /etc/shells.bak PR: 26092 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=47202
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh93/Makefile10
-rw-r--r--shells/ksh93/distinfo4
-rw-r--r--shells/ksh93/pkg-plist4
3 files changed, 12 insertions, 6 deletions
diff --git a/shells/ksh93/Makefile b/shells/ksh93/Makefile
index 504ffd9449df..8dbc94da5353 100644
--- a/shells/ksh93/Makefile
+++ b/shells/ksh93/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= naddy@mips.inka.de
RESTRICTED= "Source recipient must acknowledge license"
DISTNAME= ${PORTNAME}-${VERSION}
DISTFILES= INIT.${VERSION}.tgz ast-ksh.${VERSION}.tgz
-DIST_SUBDIR= ${PORTNAME}
NO_WRKSUBDIR= yes
MAKE_ARGS= CC='${CC}' CCFLAGS='${CFLAGS}' SHELL='${SH}'
@@ -27,7 +26,7 @@ MAN1= ksh93.1
.if defined(ACCEPT_AST_LICENSE)
post-patch:
- @touch ${WRKSRC}/lib/package/gen/ast.license.accepted
+ @${TOUCH} ${WRKSRC}/lib/package/gen/ast.license.accepted
.else
IS_INTERACTIVE= yes # must acknowledge license
.endif
@@ -41,4 +40,11 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/arch/freebsd.${ARCH}/man/man1/sh.1 \
${PREFIX}/man/man1/ksh93.1
+post-install:
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/ksh93 /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/ksh93) >/etc/shells
+ @${RM} -f /etc/shells.bak
+
.include <bsd.port.mk>
diff --git a/shells/ksh93/distinfo b/shells/ksh93/distinfo
index 1dd3e937816e..8822111cc449 100644
--- a/shells/ksh93/distinfo
+++ b/shells/ksh93/distinfo
@@ -1,2 +1,2 @@
-MD5 (ksh93/INIT.2001-07-04.0000.tgz) = 5cb81cd79b6c4ffbd3249550541afa52
-MD5 (ksh93/ast-ksh.2001-07-04.0000.tgz) = 95c4d371f2c144759aad029f20717481
+MD5 (INIT.2001-07-04.0000.tgz) = 5cb81cd79b6c4ffbd3249550541afa52
+MD5 (ast-ksh.2001-07-04.0000.tgz) = 95c4d371f2c144759aad029f20717481
diff --git a/shells/ksh93/pkg-plist b/shells/ksh93/pkg-plist
index 92fe399c03d8..9bdf63903058 100644
--- a/shells/ksh93/pkg-plist
+++ b/shells/ksh93/pkg-plist
@@ -1,4 +1,4 @@
@comment $FreeBSD$
bin/ksh93
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
+@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
+@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak