aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-11-30 15:10:12 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-11-30 15:10:12 +0000
commitb9efc6aa44020c0d5099bbd76470964c2f68b916 (patch)
tree878369d4377cc7483360ae0248ed1bd853cd2612 /shells
parent4cba8be7c033bddae13580904a03b73d37057ae9 (diff)
downloadports-b9efc6aa44020c0d5099bbd76470964c2f68b916.tar.gz
ports-b9efc6aa44020c0d5099bbd76470964c2f68b916.zip
- Add WANT_STATIC_BASH knob.
PR: ports/81795 Submitted by: Bjarne Koenig <bkoenig@cs.tu-berlin.de> Approved by: maintainer timeout (5 months)
Notes
Notes: svn path=/head/; revision=150055
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 7676ba0a9206..f390fc18e339 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -56,6 +56,16 @@ CONFIGURE_ARGS= --without-bash-malloc \
--disable-rpath \
--enable-disabled-builtins
+.if defined(WANT_STATIC_BASH) || defined(NO_DYNAMICROOT) || (defined(NOSHARED) && ${NOSHARED:L} != "no")
+.if !defined(WITHOUT_NLS)
+WITHOUT_NLS=yes
+.endif
+CONFIGURE_ARGS+= --enable-static-link
+PKGNAMESUFFIX= -static
+.else
+CONFIGURE_ARGS+= --enable-static-link=no
+.endif
+
.if defined(WITHOUT_HELP)
CONFIGURE_ARGS+= --disable-help-builtin
PLIST_SUB+= HELP="@comment "