aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1994-12-12 02:18:01 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1994-12-12 02:18:01 +0000
commit890071c2a5366dc8a3104a3fb01c1bda05d35898 (patch)
treef2f9b4729cf61d0f3293126ef7f1d9b8e4d7ba94 /shells
parentc38bd5c9424224274e7ea56d0898bf6e722759df (diff)
downloadports-890071c2a5366dc8a3104a3fb01c1bda05d35898.tar.gz
ports-890071c2a5366dc8a3104a3fb01c1bda05d35898.zip
Upgrade to 1.14.3
Notes
Notes: svn path=/head/; revision=554
Diffstat (limited to 'shells')
-rw-r--r--shells/bash/Makefile9
-rw-r--r--shells/bash/files/patch-ab21
-rw-r--r--shells/bash/pkg-comment2
-rw-r--r--shells/bash/pkg-descr2
-rw-r--r--shells/bash/pkg-plist2
-rw-r--r--shells/bash1/Makefile9
-rw-r--r--shells/bash1/files/patch-ab21
-rw-r--r--shells/bash1/files/patch-ac40
-rw-r--r--shells/bash1/files/patch-ad21
-rw-r--r--shells/bash1/pkg-comment2
-rw-r--r--shells/bash1/pkg-descr2
-rw-r--r--shells/bash1/pkg-plist2
-rw-r--r--shells/bash2/Makefile9
-rw-r--r--shells/bash2/files/patch-ab21
-rw-r--r--shells/bash2/pkg-comment2
-rw-r--r--shells/bash2/pkg-descr2
-rw-r--r--shells/bash2/pkg-plist2
-rw-r--r--shells/bash3/Makefile9
-rw-r--r--shells/bash3/files/patch-ab21
-rw-r--r--shells/bash3/pkg-comment2
-rw-r--r--shells/bash3/pkg-descr2
-rw-r--r--shells/bash3/pkg-plist2
22 files changed, 169 insertions, 36 deletions
diff --git a/shells/bash/Makefile b/shells/bash/Makefile
index 61bcee7c9fdd..639fb1b7f59e 100644
--- a/shells/bash/Makefile
+++ b/shells/bash/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: bash
-# Version required: 1.14.2
+# Version required: 1.14.3
# Date created: 21 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.3 1994/09/11 10:08:01 jkh Exp $
+# $Id: Makefile,v 1.4 1994/11/10 12:03:04 jkh Exp $
#
-GNU_MAKE= yes
-DISTNAME= bash-1.14.2
-MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+DISTNAME= bash-1.14.3
+MASTER_SITES= ftp://slc2.ins.cwru.edu/pub/hidden/
.include <bsd.port.mk>
diff --git a/shells/bash/files/patch-ab b/shells/bash/files/patch-ab
index b3851b10a007..5bb8de2d202c 100644
--- a/shells/bash/files/patch-ab
+++ b/shells/bash/files/patch-ab
@@ -1,5 +1,5 @@
-*** cpp-Makefile.orig Thu Sep 29 05:00:51 1994
---- cpp-Makefile Tue Jul 19 14:02:14 1994
+*** cpp-Makefile.orig Mon Dec 12 04:14:30 1994
+--- cpp-Makefile Mon Dec 12 04:14:30 1994
***************
*** 136,144 ****
/* This is guaranteed to work, even if you have the fixed includes!
@@ -22,6 +22,23 @@
#else /* !HAVE_GCC */
CC = CPP_CC
***************
+*** 304,310 ****
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+--- 304,310 ----
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! #CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+***************
*** 383,389 ****
Program = bash
diff --git a/shells/bash/pkg-comment b/shells/bash/pkg-comment
index 779fbe02dfef..08a8fee364bd 100644
--- a/shells/bash/pkg-comment
+++ b/shells/bash/pkg-comment
@@ -1 +1 @@
-bash, the GNU Borne Again Shell. Version 1.14.2
+bash, the GNU Borne Again Shell. Version 1.14.3
diff --git a/shells/bash/pkg-descr b/shells/bash/pkg-descr
index 73770578ee2f..ce0cbf27acfe 100644
--- a/shells/bash/pkg-descr
+++ b/shells/bash/pkg-descr
@@ -1,4 +1,4 @@
-This is GNU Bash, version 1.14.2. Bash is the GNU Project's Bourne
+This is GNU Bash, version 1.14.3. Bash is the GNU Project's Bourne
Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
but also with interactive command line editing, job control on
architectures that support it, Csh-like history features and brace
diff --git a/shells/bash/pkg-plist b/shells/bash/pkg-plist
index 85d851a33d5d..538cc642cbbb 100644
--- a/shells/bash/pkg-plist
+++ b/shells/bash/pkg-plist
@@ -1,3 +1,5 @@
@cwd /usr/local
bin/bash
+bin/bashbug
man/man1/bash.1
+man/man1/bash_builtins.1
diff --git a/shells/bash1/Makefile b/shells/bash1/Makefile
index 61bcee7c9fdd..639fb1b7f59e 100644
--- a/shells/bash1/Makefile
+++ b/shells/bash1/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: bash
-# Version required: 1.14.2
+# Version required: 1.14.3
# Date created: 21 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.3 1994/09/11 10:08:01 jkh Exp $
+# $Id: Makefile,v 1.4 1994/11/10 12:03:04 jkh Exp $
#
-GNU_MAKE= yes
-DISTNAME= bash-1.14.2
-MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+DISTNAME= bash-1.14.3
+MASTER_SITES= ftp://slc2.ins.cwru.edu/pub/hidden/
.include <bsd.port.mk>
diff --git a/shells/bash1/files/patch-ab b/shells/bash1/files/patch-ab
index b3851b10a007..5bb8de2d202c 100644
--- a/shells/bash1/files/patch-ab
+++ b/shells/bash1/files/patch-ab
@@ -1,5 +1,5 @@
-*** cpp-Makefile.orig Thu Sep 29 05:00:51 1994
---- cpp-Makefile Tue Jul 19 14:02:14 1994
+*** cpp-Makefile.orig Mon Dec 12 04:14:30 1994
+--- cpp-Makefile Mon Dec 12 04:14:30 1994
***************
*** 136,144 ****
/* This is guaranteed to work, even if you have the fixed includes!
@@ -22,6 +22,23 @@
#else /* !HAVE_GCC */
CC = CPP_CC
***************
+*** 304,310 ****
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+--- 304,310 ----
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! #CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+***************
*** 383,389 ****
Program = bash
diff --git a/shells/bash1/files/patch-ac b/shells/bash1/files/patch-ac
new file mode 100644
index 000000000000..8c2733eacc55
--- /dev/null
+++ b/shells/bash1/files/patch-ac
@@ -0,0 +1,40 @@
+*** readline.c.bak Tue Dec 6 01:47:48 1994
+--- lib/readline/readline.c Mon Dec 12 04:29:49 1994
+***************
+*** 958,964 ****
+ static void
+ readline_initialize_everything ()
+ {
+! char *t;
+
+ /* Find out if we are running in Emacs. */
+ running_in_emacs = getenv ("EMACS") != (char *)0;
+--- 958,964 ----
+ static void
+ readline_initialize_everything ()
+ {
+! char *t, *t1;
+
+ /* Find out if we are running in Emacs. */
+ running_in_emacs = getenv ("EMACS") != (char *)0;
+***************
+*** 993,999 ****
+ /* Check for LC_CTYPE and use its value to decide the defaults for
+ 8-bit character input and output. */
+ t = getenv ("LC_CTYPE");
+! if (t && (strcmp (t, "iso-8859-1") == 0 || strcmp (t, "iso_8859_1") == 0))
+ {
+ _rl_meta_flag = 1;
+ _rl_convert_meta_chars_to_ascii = 0;
+--- 993,1003 ----
+ /* Check for LC_CTYPE and use its value to decide the defaults for
+ 8-bit character input and output. */
+ t = getenv ("LC_CTYPE");
+! t1 = getenv ("LANG");
+! if (t && (strstr (t, "8859-1") != NULL || strstr (t, "8859_1") != NULL ||
+! strstr (t, "KOI8-R") != NULL || strstr (t, "koi8-r") != NULL) ||
+! t1 && (strstr (t1, "8859-1") != NULL || strstr (t1, "8859_1") != NULL ||
+! strstr (t1, "KOI8-R") != NULL || strstr (t1, "koi8-r") != NULL))
+ {
+ _rl_meta_flag = 1;
+ _rl_convert_meta_chars_to_ascii = 0;
diff --git a/shells/bash1/files/patch-ad b/shells/bash1/files/patch-ad
new file mode 100644
index 000000000000..6c0a3513001c
--- /dev/null
+++ b/shells/bash1/files/patch-ad
@@ -0,0 +1,21 @@
+*** documentation/Makefile.bak Thu Jul 14 20:12:59 1994
+--- documentation/Makefile Mon Dec 12 04:57:07 1994
+***************
+*** 109,116 ****
+ [ -d $(mandir) ] || mkdir $(mandir)
+ $(INSTALL_DATA) bash.1 $(mandir)
+ sed 's:so bash.1:so man1/bash.1:' < builtins.1 > $(mandir)/bash_builtins.1
+! [ -d $(man3dir) ] || mkdir $(man3dir)
+! $(INSTALL_DATA) readline.3 $(man3dir)
+ [ -d $(infodir) ] || mkdir $(infodir)
+ $(INSTALL_DATA) features.info $(infodir)/bash.info
+
+--- 109,116 ----
+ [ -d $(mandir) ] || mkdir $(mandir)
+ $(INSTALL_DATA) bash.1 $(mandir)
+ sed 's:so bash.1:so man1/bash.1:' < builtins.1 > $(mandir)/bash_builtins.1
+! # [ -d $(man3dir) ] || mkdir $(man3dir)
+! # $(INSTALL_DATA) readline.3 $(man3dir)
+ [ -d $(infodir) ] || mkdir $(infodir)
+ $(INSTALL_DATA) features.info $(infodir)/bash.info
+
diff --git a/shells/bash1/pkg-comment b/shells/bash1/pkg-comment
index 779fbe02dfef..08a8fee364bd 100644
--- a/shells/bash1/pkg-comment
+++ b/shells/bash1/pkg-comment
@@ -1 +1 @@
-bash, the GNU Borne Again Shell. Version 1.14.2
+bash, the GNU Borne Again Shell. Version 1.14.3
diff --git a/shells/bash1/pkg-descr b/shells/bash1/pkg-descr
index 73770578ee2f..ce0cbf27acfe 100644
--- a/shells/bash1/pkg-descr
+++ b/shells/bash1/pkg-descr
@@ -1,4 +1,4 @@
-This is GNU Bash, version 1.14.2. Bash is the GNU Project's Bourne
+This is GNU Bash, version 1.14.3. Bash is the GNU Project's Bourne
Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
but also with interactive command line editing, job control on
architectures that support it, Csh-like history features and brace
diff --git a/shells/bash1/pkg-plist b/shells/bash1/pkg-plist
index 85d851a33d5d..538cc642cbbb 100644
--- a/shells/bash1/pkg-plist
+++ b/shells/bash1/pkg-plist
@@ -1,3 +1,5 @@
@cwd /usr/local
bin/bash
+bin/bashbug
man/man1/bash.1
+man/man1/bash_builtins.1
diff --git a/shells/bash2/Makefile b/shells/bash2/Makefile
index 61bcee7c9fdd..639fb1b7f59e 100644
--- a/shells/bash2/Makefile
+++ b/shells/bash2/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: bash
-# Version required: 1.14.2
+# Version required: 1.14.3
# Date created: 21 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.3 1994/09/11 10:08:01 jkh Exp $
+# $Id: Makefile,v 1.4 1994/11/10 12:03:04 jkh Exp $
#
-GNU_MAKE= yes
-DISTNAME= bash-1.14.2
-MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+DISTNAME= bash-1.14.3
+MASTER_SITES= ftp://slc2.ins.cwru.edu/pub/hidden/
.include <bsd.port.mk>
diff --git a/shells/bash2/files/patch-ab b/shells/bash2/files/patch-ab
index b3851b10a007..5bb8de2d202c 100644
--- a/shells/bash2/files/patch-ab
+++ b/shells/bash2/files/patch-ab
@@ -1,5 +1,5 @@
-*** cpp-Makefile.orig Thu Sep 29 05:00:51 1994
---- cpp-Makefile Tue Jul 19 14:02:14 1994
+*** cpp-Makefile.orig Mon Dec 12 04:14:30 1994
+--- cpp-Makefile Mon Dec 12 04:14:30 1994
***************
*** 136,144 ****
/* This is guaranteed to work, even if you have the fixed includes!
@@ -22,6 +22,23 @@
#else /* !HAVE_GCC */
CC = CPP_CC
***************
+*** 304,310 ****
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+--- 304,310 ----
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! #CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+***************
*** 383,389 ****
Program = bash
diff --git a/shells/bash2/pkg-comment b/shells/bash2/pkg-comment
index 779fbe02dfef..08a8fee364bd 100644
--- a/shells/bash2/pkg-comment
+++ b/shells/bash2/pkg-comment
@@ -1 +1 @@
-bash, the GNU Borne Again Shell. Version 1.14.2
+bash, the GNU Borne Again Shell. Version 1.14.3
diff --git a/shells/bash2/pkg-descr b/shells/bash2/pkg-descr
index 73770578ee2f..ce0cbf27acfe 100644
--- a/shells/bash2/pkg-descr
+++ b/shells/bash2/pkg-descr
@@ -1,4 +1,4 @@
-This is GNU Bash, version 1.14.2. Bash is the GNU Project's Bourne
+This is GNU Bash, version 1.14.3. Bash is the GNU Project's Bourne
Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
but also with interactive command line editing, job control on
architectures that support it, Csh-like history features and brace
diff --git a/shells/bash2/pkg-plist b/shells/bash2/pkg-plist
index 85d851a33d5d..538cc642cbbb 100644
--- a/shells/bash2/pkg-plist
+++ b/shells/bash2/pkg-plist
@@ -1,3 +1,5 @@
@cwd /usr/local
bin/bash
+bin/bashbug
man/man1/bash.1
+man/man1/bash_builtins.1
diff --git a/shells/bash3/Makefile b/shells/bash3/Makefile
index 61bcee7c9fdd..639fb1b7f59e 100644
--- a/shells/bash3/Makefile
+++ b/shells/bash3/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: bash
-# Version required: 1.14.2
+# Version required: 1.14.3
# Date created: 21 August 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.3 1994/09/11 10:08:01 jkh Exp $
+# $Id: Makefile,v 1.4 1994/11/10 12:03:04 jkh Exp $
#
-GNU_MAKE= yes
-DISTNAME= bash-1.14.2
-MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+DISTNAME= bash-1.14.3
+MASTER_SITES= ftp://slc2.ins.cwru.edu/pub/hidden/
.include <bsd.port.mk>
diff --git a/shells/bash3/files/patch-ab b/shells/bash3/files/patch-ab
index b3851b10a007..5bb8de2d202c 100644
--- a/shells/bash3/files/patch-ab
+++ b/shells/bash3/files/patch-ab
@@ -1,5 +1,5 @@
-*** cpp-Makefile.orig Thu Sep 29 05:00:51 1994
---- cpp-Makefile Tue Jul 19 14:02:14 1994
+*** cpp-Makefile.orig Mon Dec 12 04:14:30 1994
+--- cpp-Makefile Mon Dec 12 04:14:30 1994
***************
*** 136,144 ****
/* This is guaranteed to work, even if you have the fixed includes!
@@ -22,6 +22,23 @@
#else /* !HAVE_GCC */
CC = CPP_CC
***************
+*** 304,310 ****
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+--- 304,310 ----
+ /**/# The GNU coding standards don't recognize the possibility that
+ /**/# other information besides optimization and debugging might be
+ /**/# passed to cc. A different name should have been used.
+! #CFLAGS = -O -g
+
+ SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
+ $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
+***************
*** 383,389 ****
Program = bash
diff --git a/shells/bash3/pkg-comment b/shells/bash3/pkg-comment
index 779fbe02dfef..08a8fee364bd 100644
--- a/shells/bash3/pkg-comment
+++ b/shells/bash3/pkg-comment
@@ -1 +1 @@
-bash, the GNU Borne Again Shell. Version 1.14.2
+bash, the GNU Borne Again Shell. Version 1.14.3
diff --git a/shells/bash3/pkg-descr b/shells/bash3/pkg-descr
index 73770578ee2f..ce0cbf27acfe 100644
--- a/shells/bash3/pkg-descr
+++ b/shells/bash3/pkg-descr
@@ -1,4 +1,4 @@
-This is GNU Bash, version 1.14.2. Bash is the GNU Project's Bourne
+This is GNU Bash, version 1.14.3. Bash is the GNU Project's Bourne
Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
but also with interactive command line editing, job control on
architectures that support it, Csh-like history features and brace
diff --git a/shells/bash3/pkg-plist b/shells/bash3/pkg-plist
index 85d851a33d5d..538cc642cbbb 100644
--- a/shells/bash3/pkg-plist
+++ b/shells/bash3/pkg-plist
@@ -1,3 +1,5 @@
@cwd /usr/local
bin/bash
+bin/bashbug
man/man1/bash.1
+man/man1/bash_builtins.1