aboutsummaryrefslogtreecommitdiff
path: root/sysutils/LPRng
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-01-20 08:37:23 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-01-20 08:37:23 +0000
commit0dd148c855ce1ee87d6d11f5cdff4fdb3f52b741 (patch)
tree549b01bcd63822da3e8940476cad9e424462bc61 /sysutils/LPRng
parent7e39acb4e53d51c44de60162dc093ab1245f57dc (diff)
downloadports-0dd148c855ce1ee87d6d11f5cdff4fdb3f52b741.tar.gz
ports-0dd148c855ce1ee87d6d11f5cdff4fdb3f52b741.zip
- Update to 3.8.32
- Provide new rc script - Prevent distribution install sample conf in DATADIR as we already install them in PREFIX/etc - Polish pkg-message - Remove FTP from pkg-descr, we have WWW there - Move LIB_DEPENDS before CONFLICTS to pet portlint
Notes
Notes: svn path=/head/; revision=205868
Diffstat (limited to 'sysutils/LPRng')
-rw-r--r--sysutils/LPRng/Makefile21
-rw-r--r--sysutils/LPRng/distinfo6
-rw-r--r--sysutils/LPRng/files/lprng.in38
-rw-r--r--sysutils/LPRng/files/pkg-message.in14
-rw-r--r--sysutils/LPRng/pkg-descr1
-rw-r--r--sysutils/LPRng/pkg-plist7
6 files changed, 63 insertions, 24 deletions
diff --git a/sysutils/LPRng/Makefile b/sysutils/LPRng/Makefile
index 3e8e0e69782c..40e13432d75a 100644
--- a/sysutils/LPRng/Makefile
+++ b/sysutils/LPRng/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= LPRng
-PORTVERSION= 3.8.28
-PORTREVISION= 2
+PORTVERSION= 3.8.32
CATEGORIES= sysutils print
MASTER_SITES= ftp://ftp.lprng.com/pub/%SUBDIR%/ \
ftp://ftp.cise.ufl.edu/pub/mirrors/%SUBDIR%/ \
@@ -20,13 +19,15 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An Enhanced Printer Spooler
-CONFLICTS= cups-base-1.[2-9]*
-
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+CONFLICTS= cups-base-1.[2-9]*
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_RC_SUBR= ${PORTNAME:L}
+
SUB_FILES= pkg-message pkg-install
SUB_LIST= SYSCONFDIR="${SYSCONFDIR}"
@@ -65,6 +66,14 @@ MAN8= lpc.8 checkpc.8 lpd.8
.include <bsd.port.pre.mk>
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
pre-everything::
@${ECHO_MSG} "If you want to replace the default printing system with LPRng, use:"
@${ECHO_MSG} " make PORT_REPLACES_BASE_LPR=yes clean all install"
@@ -82,6 +91,8 @@ pre-everything::
post-patch:
@${ECHO} "#! /bin/sh" > ${WRKSRC}/postinstall.freebsd.sh
+ @${REINPLACE_CMD} -e 's,$${INSTALL} $$$$i $${DATADIR}/$$$$i.sample,true &,' \
+ ${WRKSRC}/Makefile.in
pre-install: apply-slist
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -90,8 +101,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/lpd.conf ${SYSCONFDIR}/lpd.conf.sample
@${INSTALL_DATA} ${WRKSRC}/lpd.perms ${SYSCONFDIR}/lpd.perms.sample
@${INSTALL_DATA} ${WRKSRC}/printcap ${SYSCONFDIR}/printcap.sample
- @${MKDIR} ${LOCALBASE}/etc/rc.d
- @${INSTALL_DATA} ${WRKSRC}/init.freebsd ${LOCALBASE}/etc/rc.d/lprng.sh
.if !defined(NOPORTDOCS)
@${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0555 ${DOCSDIR}
@${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 0555 ${DOCSDIR}/Reference
diff --git a/sysutils/LPRng/distinfo b/sysutils/LPRng/distinfo
index a15b4c8a9080..2f0c2d9b2482 100644
--- a/sysutils/LPRng/distinfo
+++ b/sysutils/LPRng/distinfo
@@ -1,3 +1,3 @@
-MD5 (LPRng-3.8.28.tgz) = 1b3a0abd291b260eab6087ac0e61ed84
-SHA256 (LPRng-3.8.28.tgz) = c22e9c20ac71f97daca79c68b8d70631ef51d34652ff37b8cb8413a3ebcb914d
-SIZE (LPRng-3.8.28.tgz) = 10212500
+MD5 (LPRng-3.8.32.tgz) = edbd3a381a0cc6843df7507e8f9103f1
+SHA256 (LPRng-3.8.32.tgz) = a3f9069846bf1b38164eaec0273668ae8cabd300577801912fa0efae6d541a31
+SIZE (LPRng-3.8.32.tgz) = 11918986
diff --git a/sysutils/LPRng/files/lprng.in b/sysutils/LPRng/files/lprng.in
new file mode 100644
index 000000000000..5a8aa2dcde76
--- /dev/null
+++ b/sysutils/LPRng/files/lprng.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+# PROVIDE: lprng
+# REQUIRE: LOGIN
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# lprng_enable (bool): Set to NO by default.
+# Set it to YES to enable lprng.
+#
+
+. %%RC_SUBR%%
+
+name="lprng"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/sbin/lpd
+
+required_files="/etc/printcap %%SYSCONFDIR%%/lpd.conf %%SYSCONFDIR%%/lpd.perms"
+
+start_precmd=start_precmd
+
+start_precmd()
+{
+ if checkyesno lpd_enable; then
+ warn "lpd must be disabled"
+ return 1
+ fi
+
+ %%PREFIX%%/sbin/checkpc -f
+}
+
+load_rc_config $name
+
+: ${lprng_enable="NO"}
+
+run_rc_command "$1"
diff --git a/sysutils/LPRng/files/pkg-message.in b/sysutils/LPRng/files/pkg-message.in
index 796b60392027..fa5bade03d3f 100644
--- a/sysutils/LPRng/files/pkg-message.in
+++ b/sysutils/LPRng/files/pkg-message.in
@@ -1,17 +1,9 @@
**********************************************************************
-If LPRng is not activated at installation time,
-to activate the LPRng printing system do the following:
-On FreeBSD:
- set'lpd_enable=NO' and 'lprng_enable=YES' in /etc/rc.conf.
- The LPRng startup script is in /usr/local/etc/rc.d/lprng.sh
+To enable LPRng, put the following lines in /etc/rc.conf
- If lprng_enable != NO then the LPRng lpd will run.
-
-- run 'checkpc -f' to make sure that necessary files have been created
-
-- reboot or kill the old lpd using 'killall lpd' and
- start the new one using '%%PREFIX%%/etc/rc.d/lprng.sh start'.
+lpd_enable="NO"
+lprng_enable="YES"
LPRng uses the printcap, lpd.conf, and lpd.perms configuration files
diff --git a/sysutils/LPRng/pkg-descr b/sysutils/LPRng/pkg-descr
index 5ab18c45ca48..05da0ff11dc9 100644
--- a/sysutils/LPRng/pkg-descr
+++ b/sysutils/LPRng/pkg-descr
@@ -9,4 +9,3 @@ do not need to run SUID root; greatly enhanced security checks; and a
greatly improved permission and authorization mechanism.
WWW: http://www.lprng.com/
-FTP: ftp://ftp.lprng.com/
diff --git a/sysutils/LPRng/pkg-plist b/sysutils/LPRng/pkg-plist
index 784ecb1e40ae..cbb8e580c208 100644
--- a/sysutils/LPRng/pkg-plist
+++ b/sysutils/LPRng/pkg-plist
@@ -4,8 +4,8 @@ bin/lpq
bin/lpr
bin/lprm
bin/lpstat
-etc/rc.d/lprng.sh
lib/liblpr.a
+lib/liblpr.la
libexec/filters/lpbanner
libexec/filters/lpf
libexec/filters/pclbanner
@@ -15,6 +15,8 @@ sbin/lpc
sbin/lpd
sbin/lprng_certs
sbin/lprng_index_certs
+%%NLS%%share/locale/de/LC_MESSAGES/LPRng.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/LPRng.mo
%%PORTDOCS%%%%DOCSDIR%%/LISA98.ppt
%%PORTDOCS%%%%DOCSDIR%%/LPRng-Reference.html
%%PORTDOCS%%%%DOCSDIR%%/LPRng-Reference.pdf
@@ -58,9 +60,8 @@ sbin/lprng_index_certs
%%PORTDOCS%%@dirrm %%DOCSDIR%%/PrintingCookbook
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/filters
+@dirrm %%DATADIR%%
%%CWD%%@cwd /
%%SYSCONFDIR%%/lpd.conf.sample
%%SYSCONFDIR%%/lpd.perms.sample
%%SYSCONFDIR%%/printcap.sample
-%%CWD%%@dirrmtry etc/rc.d
-%%CWD%%@dirrmtry etc