aboutsummaryrefslogtreecommitdiff
path: root/sysutils/LPRngTool
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-14 20:30:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-14 20:30:10 +0000
commitfc0222dad20cb93a3d39cdc7807aa053dfdcbdcf (patch)
tree1f62ddb36c90989edfbce7c07b0dc9378e7ea1dc /sysutils/LPRngTool
parent0fa575ea706026f8f393520d55da57dd875aa92b (diff)
downloadports-fc0222dad20cb93a3d39cdc7807aa053dfdcbdcf.tar.gz
ports-fc0222dad20cb93a3d39cdc7807aa053dfdcbdcf.zip
- Fix packing list.
- Respect SYSCONFDIR in pkg-plist. - Remove useless test on PREFIX. - Remove useless HAS_CONFIGURE's. PR: ports/76789 Submitted by: Florent Thoumie <flz@xbsd.org> Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=128842
Diffstat (limited to 'sysutils/LPRngTool')
-rw-r--r--sysutils/LPRngTool/Makefile20
-rw-r--r--sysutils/LPRngTool/pkg-plist6
2 files changed, 16 insertions, 10 deletions
diff --git a/sysutils/LPRngTool/Makefile b/sysutils/LPRngTool/Makefile
index ff4f45d51144..c75b6bf7717f 100644
--- a/sysutils/LPRngTool/Makefile
+++ b/sysutils/LPRngTool/Makefile
@@ -28,21 +28,18 @@ BUILD_DEPENDS= \
#RUN_DEPENDS= ifhp:${PORTSDIR}/print/ifhp
-.if defined(PREFIX)
- CONFIGURE_ARGS+= --prefix="${PREFIX}"
-.endif
.if defined(SYSCONFDIR)
- CONFIGURE_ARGS+= --with-sysconfdir="${SYSCONFDIR}"
+PLIST_SUB+= CWD="" SYSCONFDIR="${SYSCONFDIR:S,^/,,}"
+.else
+SYSCONFDIR= ${PREFIX}/etc
+PLIST_SUB+= CWD="@comment " SYSCONFDIR="${SYSCONFDIR:S,^${PREFIX}/,,}"
.endif
-HAS_CONFIGURE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-HAS_CONFIGURE= yes
-
-CONFIGURE_ARGS+=\
- --with-spool_directory=/var/spool/lpd
+CONFIGURE_ARGS+= --with-spool_directory=/var/spool/lpd \
+ --with-sysconfdir="${SYSCONFDIR}"
MAN1=lprngtool.1
@@ -61,4 +58,9 @@ pre-everything::
fi
@${ECHO_MSG} "Configuring with '${CONFIGURE_ARGS}'"
+post-install:
+ @if [ ! -f ${SYSCONFDIR}/lprngtool.conf ]; then \
+ ${CP} ${SYSCONFDIR}/lprngtool.conf.sample ${SYSCONFDIR}/lprngtool.conf; \
+ fi
+
.include <bsd.port.mk>
diff --git a/sysutils/LPRngTool/pkg-plist b/sysutils/LPRngTool/pkg-plist
index bf899e18d4cd..a494e02f367f 100644
--- a/sysutils/LPRngTool/pkg-plist
+++ b/sysutils/LPRngTool/pkg-plist
@@ -1,4 +1,3 @@
-etc/lprngtool.conf.sample
bin/lprngtool
libexec/filters/atalkprint
libexec/filters/ncpprint
@@ -7,3 +6,8 @@ libexec/filters/printerdb
libexec/filters/testpage.asc
libexec/filters/testpage.ps
libexec/filters/testpage-a4.ps
+@unexec rmdir %D/libexec/filters 2> /dev/null || true
+%%CWD%%@cwd /
+@unexec if cmp -s %D/%%SYSCONFDIR%%/lprngtool.conf %D/%%SYSCONFDIR%%/lprngtool.conf.sample; then rm -f %D/%%SYSCONFDIR%%/lprngtool.conf; fi
+%%SYSCONFDIR%%/lprngtool.conf.sample
+@exec [ -f %B/lprngtool.conf ] || cp %B/%f %B/lprngtool.conf