aboutsummaryrefslogtreecommitdiff
path: root/sysutils/and
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 19:26:43 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-03 19:26:43 +0000
commit0f2e2a2273b06fb3deb6e6dae007ebfff05774c4 (patch)
treeb1300492e688d87bbefdb08d898c0e51f687b21f /sysutils/and
parent9a5ab277e6df0ec27baa15fb3b6fba45769f7ed0 (diff)
downloadports-0f2e2a2273b06fb3deb6e6dae007ebfff05774c4.tar.gz
ports-0f2e2a2273b06fb3deb6e6dae007ebfff05774c4.zip
upgrade to 1.0.8
PR: 46433 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=72448
Diffstat (limited to 'sysutils/and')
-rw-r--r--sysutils/and/Makefile4
-rw-r--r--sysutils/and/distinfo2
-rw-r--r--sysutils/and/files/patch-Makefile15
-rw-r--r--sysutils/and/files/patch-and-OpenBSD.c41
4 files changed, 57 insertions, 5 deletions
diff --git a/sysutils/and/Makefile b/sysutils/and/Makefile
index 5372e568701e..d93e2e796d65 100644
--- a/sysutils/and/Makefile
+++ b/sysutils/and/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= and
-PORTVERSION= 1.0.7
+PORTVERSION= 1.0.8
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_GMAKE= yes
-ALL_TARGET= # empty
+ALL_TARGET= default
MAN5= and.conf.5 and.priorities.5
MAN8= and.8
diff --git a/sysutils/and/distinfo b/sysutils/and/distinfo
index 516c156ca149..49b61cfb182d 100644
--- a/sysutils/and/distinfo
+++ b/sysutils/and/distinfo
@@ -1 +1 @@
-MD5 (and-1.0.7.tar.gz) = c66f2945ec3f4e06e639ee8f290b2e74
+MD5 (and-1.0.8.tar.gz) = 4bef92c5375d8c8bddb98aa7ec6d1b1d
diff --git a/sysutils/and/files/patch-Makefile b/sysutils/and/files/patch-Makefile
index 234f312dbb0a..674ceb6097c1 100644
--- a/sysutils/and/files/patch-Makefile
+++ b/sysutils/and/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Jun 22 03:39:00 2002
-+++ Makefile Sat Jun 22 03:39:19 2002
+--- Makefile.orig Mon Jan 28 01:02:51 2002
++++ Makefile Tue Dec 17 21:15:05 2002
@@ -16,7 +16,7 @@
# (and.init.debian for Debian GNU/Linux or and.init for others;
# leave empty for BSD!)
@@ -24,3 +24,14 @@
# typical Debian or SuSE 7.x configuration
#PREFIX=/usr
+@@ -110,8 +110,8 @@
+ LIBS = -lkvm
+ else
+ ifeq (${ARCH},FreeBSD)
+- CC = gcc -Wall
+- LD = gcc
++ CC ?= gcc -Wall
++ LD = $(CC)
+ LIBS = -lkvm
+ else
+ ifeq (${ARCH},SunOS)
diff --git a/sysutils/and/files/patch-and-OpenBSD.c b/sysutils/and/files/patch-and-OpenBSD.c
new file mode 100644
index 000000000000..5d94253e3724
--- /dev/null
+++ b/sysutils/and/files/patch-and-OpenBSD.c
@@ -0,0 +1,41 @@
+--- and-OpenBSD.c.orig Mon Jan 28 01:02:51 2002
++++ and-OpenBSD.c Sat Dec 21 02:04:58 2002
+@@ -91,17 +91,38 @@
+ abort();
+ }
+ if (openbsd_next >= openbsd_nproc) return NULL;
++#if defined(__FreeBSD__) && __FreeBSD_version >= 50014
++ strncpy(openbsd_proc.command,openbsd_pt[openbsd_next].ki_comm,1023);
++#else
+ strncpy(openbsd_proc.command,openbsd_pt[openbsd_next].kp_proc.p_comm,1023);
++#endif
+ openbsd_proc.command[1023] = 0;
++#if defined(__FreeBSD__) && __FreeBSD_version >= 50014
++ openbsd_proc.pid = openbsd_pt[openbsd_next].ki_pid;
++ openbsd_proc.nice = openbsd_pt[openbsd_next].ki_nice-20;
++ openbsd_proc.uid = openbsd_pt[openbsd_next].ki_ruid;
++ openbsd_proc.gid = openbsd_pt[openbsd_next].ki_rgid;
++#else
+ openbsd_proc.pid = openbsd_pt[openbsd_next].kp_proc.p_pid;
+ openbsd_proc.nice = openbsd_pt[openbsd_next].kp_proc.p_nice-20;
+ openbsd_proc.uid = openbsd_pt[openbsd_next].kp_eproc.e_pcred.p_ruid;
+ openbsd_proc.gid = openbsd_pt[openbsd_next].kp_eproc.e_pcred.p_rgid;
++#endif
+ /* Adapted from top(1) port, as found in the misc@openbsd.org archive */
++#if defined(__FreeBSD__) && __FreeBSD_version >= 50014
++ /* XXX: Accessing ki_paddr causes sig10 ...
++ openbsd_proc.utime = (openbsd_pt[openbsd_next].ki_paddr->p_uticks +
++ openbsd_pt[openbsd_next].ki_paddr->p_sticks +
++ openbsd_pt[openbsd_next].ki_paddr->p_iticks)
++ / openbsd_hz;
++ */
++ openbsd_proc.utime = 0;
++#else
+ openbsd_proc.utime = (openbsd_pt[openbsd_next].kp_proc.p_uticks +
+ openbsd_pt[openbsd_next].kp_proc.p_sticks +
+ openbsd_pt[openbsd_next].kp_proc.p_iticks)
+ / openbsd_hz;
++#endif
+ /*
+ printf("%-20s %5i %3i %i\n",openbsd_proc.command,openbsd_proc.pid,
+ openbsd_proc.nice,openbsd_proc.utime);