aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bacula-server/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2007-01-21 21:56:26 +0000
committerJuergen Lock <nox@FreeBSD.org>2007-01-21 21:56:26 +0000
commitfcb4ce2fc49935440324419ff0e03d4b073ecd0c (patch)
treed795fd65234eacc48ce9d1b144e7181d5d9d01f7 /sysutils/bacula-server/Makefile
parentc9171663d544a04dabba2e2f13b805d910ac50cb (diff)
downloadports-fcb4ce2fc49935440324419ff0e03d4b073ecd0c.tar.gz
ports-fcb4ce2fc49935440324419ff0e03d4b073ecd0c.zip
Add auto seteotmodel option
PR: ports/108167 Submitted by: nox Approved by: dan@langille.org (maintainer), miwi (mentor, implicit)
Notes
Notes: svn path=/head/; revision=182921
Diffstat (limited to 'sysutils/bacula-server/Makefile')
-rw-r--r--sysutils/bacula-server/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index ecedbc311165..4c6066de2ebc 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -79,6 +79,7 @@ OPTIONS= SQLITE3 "Use SqLite-3 database instead of SqLite-2" off
OPTIONS+= MYSQL "Use MySQL database instead of SqLite" off
OPTIONS+= POSTGRESQL "Use PostgreSQL database instead of SqLite" off
OPTIONS+= MTX "Install mtx for control of autochanger devices" off
+OPTIONS+= AUTOSETEOT "Enable auto seteotmodel" off
.endif
OPTIONS+= NLS "Native Language Support via gettext utilities" on
@@ -196,6 +197,9 @@ pre-everything::
@${ECHO_MSG} "The default DB is SQLite-2!"
.endif
@${ECHO_MSG} " WITH_OPENSSL=yes Enable OpenSSL for encrypted communication."
+.if !defined(WITH_AUTOSETEOT)
+ @${ECHO_MSG} " WITH_AUTOSETEOT=yes Enable auto seteotmodel (especially useful with TWO EOF = no.)"
+.endif
@${ECHO_MSG} ""
@${ECHO_MSG} "===> Using ${DBTYPE} as the bacula database."
@${ECHO_MSG} ""
@@ -215,6 +219,10 @@ post-patch:
# In server port don't install filed
@${REINPLACE_CMD} -e '/^fd_subdirs = /s|src/filed||' -e 's|src/console||' ${WRKSRC}/Makefile.in
.endif
+.if defined(WITH_AUTOSETEOT)
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/eotmodel-src-stored-dev.c.patch
+.endif
+
pre-install:
if [ ! -d "${BACULA_DIR}" ]; then \