aboutsummaryrefslogtreecommitdiff
path: root/sysutils/bubblemon2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-30 00:31:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-30 00:31:57 +0000
commit6382f7a641f35ad8b92c3af45549b560f7609a36 (patch)
tree1711fac292ef37a57fce9e8656b140d8caa2c02b /sysutils/bubblemon2
parente006ccdc2aa965d794096ef9f9c9b7b61c3ccd94 (diff)
downloadports-6382f7a641f35ad8b92c3af45549b560f7609a36.tar.gz
ports-6382f7a641f35ad8b92c3af45549b560f7609a36.zip
[new port] sysutils/bubblemon2
Bubblemon2 is a system CPU and memory load monitor for GNOME2 PR: ports/54245 Submitted by: Juan Salaverria <rael@vectorstar.net>
Notes
Notes: svn path=/head/; revision=89860
Diffstat (limited to 'sysutils/bubblemon2')
-rw-r--r--sysutils/bubblemon2/Makefile43
-rw-r--r--sysutils/bubblemon2/distinfo1
-rw-r--r--sysutils/bubblemon2/files/patch-src::gnome1-meter.c10
-rw-r--r--sysutils/bubblemon2/files/patch-src::gnome1-netload.c10
-rw-r--r--sysutils/bubblemon2/pkg-descr9
-rw-r--r--sysutils/bubblemon2/pkg-plist30
6 files changed, 103 insertions, 0 deletions
diff --git a/sysutils/bubblemon2/Makefile b/sysutils/bubblemon2/Makefile
new file mode 100644
index 000000000000..c0b1e201c33b
--- /dev/null
+++ b/sysutils/bubblemon2/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: sysutils/bubblemon2
+# Date created: 08 Jul 2002
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+
+PORTNAME= bubblemon2
+PORTVERSION= 2.0.1
+CATEGORIES= sysutils gnome
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= bubblemon
+DISTNAME= bubblemon-${PORTVERSION}
+
+MAINTAINER= rael@vectorstar.net
+COMMENT= Bubblemon2 is a system CPU and memory load monitor for GNOME2
+
+LIB_DEPENDS= gtop-2.0:${PORTSDIR}/devel/libgtop2
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GNOME= gnomehack gnomeprefix gnomepanel
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= bubblemon-gnome2.1
+MANLANG= "" hu sv
+
+DOCS= AUTHORS COPYING ChangeLog FAQ PROFILING TRANSLATIONS NEWS README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ;' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/bubblemon2/distinfo b/sysutils/bubblemon2/distinfo
new file mode 100644
index 000000000000..0cc32a4f0a48
--- /dev/null
+++ b/sysutils/bubblemon2/distinfo
@@ -0,0 +1 @@
+MD5 (bubblemon-2.0.1.tar.gz) = 8153a682551fcc73344420c4857ea198
diff --git a/sysutils/bubblemon2/files/patch-src::gnome1-meter.c b/sysutils/bubblemon2/files/patch-src::gnome1-meter.c
new file mode 100644
index 000000000000..9313e12cbe5d
--- /dev/null
+++ b/sysutils/bubblemon2/files/patch-src::gnome1-meter.c
@@ -0,0 +1,10 @@
+--- src/gnome1-meter.c.orig Tue Jul 8 02:09:17 2003
++++ src/gnome1-meter.c Tue Jul 8 02:09:25 2003
+@@ -20,6 +20,7 @@
+ * Foundation, Inc., 59 Temple Street #330, Boston, MA 02111-1307, USA.
+ */
+
++#include <sys/types.h>
+ #include <glibtop.h>
+ #include <glibtop/cpu.h>
+ #include <glibtop/mem.h>
diff --git a/sysutils/bubblemon2/files/patch-src::gnome1-netload.c b/sysutils/bubblemon2/files/patch-src::gnome1-netload.c
new file mode 100644
index 000000000000..f7ff3cd0586f
--- /dev/null
+++ b/sysutils/bubblemon2/files/patch-src::gnome1-netload.c
@@ -0,0 +1,10 @@
+--- src/gnome1-netload.c.orig Tue Jul 8 02:12:27 2003
++++ src/gnome1-netload.c Tue Jul 8 02:13:12 2003
+@@ -22,6 +22,7 @@
+ * This is the Gnome 1 specific network load measuring stuff.
+ */
+
++#include <sys/types.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <glibtop/netload.h>
diff --git a/sysutils/bubblemon2/pkg-descr b/sysutils/bubblemon2/pkg-descr
new file mode 100644
index 000000000000..0f6eb30218b5
--- /dev/null
+++ b/sysutils/bubblemon2/pkg-descr
@@ -0,0 +1,9 @@
+Bubblemon displays something that looks like a vial containing water. The water
+level indicates how much memory is in use. The color of the liquid indicates
+how much swap space is used (watery blue means none and angry red means all).
+The system CPU load is indicated by bubbles floating up through the liquid;
+lots of bubbles means high CPU load.
+
+WWW: http://www.nongnu.org/bubblemon/
+
+d92-jwa@nada.kth.se
diff --git a/sysutils/bubblemon2/pkg-plist b/sysutils/bubblemon2/pkg-plist
new file mode 100644
index 000000000000..9bb7888561e5
--- /dev/null
+++ b/sysutils/bubblemon2/pkg-plist
@@ -0,0 +1,30 @@
+libdata/bonobo/servers/GNOME_BubblemonApplet.server
+libexec/bubblemon-gnome2
+share/gnome/gnome-2.0/ui/GNOME_BubblemonApplet.xml
+share/gnome/pixmaps/bubblemon.png
+share/locale/sv/LC_MESSAGES/bubblemon.mo
+share/locale/fr/LC_MESSAGES/bubblemon.mo
+share/locale/pl/LC_MESSAGES/bubblemon.mo
+share/locale/de/LC_MESSAGES/bubblemon.mo
+share/locale/ko/LC_MESSAGES/bubblemon.mo
+share/locale/fi/LC_MESSAGES/bubblemon.mo
+share/locale/da/LC_MESSAGES/bubblemon.mo
+share/locale/sh/LC_MESSAGES/bubblemon.mo
+share/locale/pt/LC_MESSAGES/bubblemon.mo
+share/locale/ro/LC_MESSAGES/bubblemon.mo
+share/locale/es/LC_MESSAGES/bubblemon.mo
+share/locale/no/LC_MESSAGES/bubblemon.mo
+share/locale/hu/LC_MESSAGES/bubblemon.mo
+share/locale/it/LC_MESSAGES/bubblemon.mo
+share/locale/is/LC_MESSAGES/bubblemon.mo
+share/locale/ru/LC_MESSAGES/bubblemon.mo
+%%PORTDOCS%%share/doc/bubblemon2/AUTHORS
+%%PORTDOCS%%share/doc/bubblemon2/COPYING
+%%PORTDOCS%%share/doc/bubblemon2/ChangeLog
+%%PORTDOCS%%share/doc/bubblemon2/FAQ
+%%PORTDOCS%%share/doc/bubblemon2/NEWS
+%%PORTDOCS%%share/doc/bubblemon2/PROFILING
+%%PORTDOCS%%share/doc/bubblemon2/README
+%%PORTDOCS%%share/doc/bubblemon2/TODO
+%%PORTDOCS%%share/doc/bubblemon2/TRANSLATIONS
+%%PORTDOCS%%@dirrm share/doc/bubblemon2