aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cdrdao
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-05-21 15:19:38 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-05-21 15:19:38 +0000
commit2799d745c326d8cb157bcba945577d75432a1baa (patch)
tree5892b53e956317dc34358a4f0d1874849625a893 /sysutils/cdrdao
parent44ad5877b950cfb5f1b7dab7cd4607bf3661905f (diff)
downloadports-2799d745c326d8cb157bcba945577d75432a1baa.tar.gz
ports-2799d745c326d8cb157bcba945577d75432a1baa.zip
Fix potential root exploit.
THE FREEBSD PORT IS NOT VULNERABLE AS IT DOES NOT SET THE SUID BIT, YOU ARE ONLY VULNERABLE, IF YOU SET IT ON YOUR OWN! Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=81618
Diffstat (limited to 'sysutils/cdrdao')
-rw-r--r--sysutils/cdrdao/Makefile2
-rw-r--r--sysutils/cdrdao/files/patch-scsilib::libscg::scsiopen.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index 04226008dcd2..46bc91feac69 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cdrdao
PORTVERSION= 1.1.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/sysutils/cdrdao/files/patch-scsilib::libscg::scsiopen.c b/sysutils/cdrdao/files/patch-scsilib::libscg::scsiopen.c
new file mode 100644
index 000000000000..e39ebd0e8f8c
--- /dev/null
+++ b/sysutils/cdrdao/files/patch-scsilib::libscg::scsiopen.c
@@ -0,0 +1,11 @@
+--- scsilib/libscg/scsiopen.c.orig Sun Nov 25 16:35:10 2001
++++ scsilib/libscg/scsiopen.c Tue May 20 23:01:01 2003
+@@ -239,7 +239,7 @@
+ }
+ if (scg__open(scgp, devname) <= 0) {
+ if (errs && scgp->errstr)
+- js_snprintf(errs, slen, scgp->errstr);
++ js_snprintf(errs, slen, "%s", scgp->errstr);
+ scg_sfree(scgp);
+ return ((SCSI *)0);
+ }