aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cdrtools
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-24 03:46:10 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-24 03:46:10 +0000
commit7293c330ca5401512989718e8581dd004b97bc40 (patch)
treeb74657c6f6f00d84832f8d31877f4538d91323cb /sysutils/cdrtools
parent37a32041b4b56ff6737ca34f7d21a0f32cd121a2 (diff)
downloadports-7293c330ca5401512989718e8581dd004b97bc40.tar.gz
ports-7293c330ca5401512989718e8581dd004b97bc40.zip
- Add knob WITH_CDDB, adds cddb support.
this is also auto-detected and can not be turned off because there is no configure knob to turn off. - Bump PORTREVISION because libcddb just got bumped so people wont' run in to problems with libver stuff.
Notes
Notes: svn path=/head/; revision=139999
Diffstat (limited to 'sysutils/cdrtools')
-rw-r--r--sysutils/cdrtools/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/cdrtools/Makefile b/sysutils/cdrtools/Makefile
index b264b56055fe..0d9feda2c7a8 100644
--- a/sysutils/cdrtools/Makefile
+++ b/sysutils/cdrtools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cdrtools
PORTVERSION?= 2.01
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= sysutils audio
MASTER_SITES= ftp://ftp.berlios.de/pub/cdrecord/ \
ftp://ftp.cs.tu-berlin.de/pub/misc/cdrecord/
@@ -54,6 +54,12 @@ PLIST_SUB= RSCSI="@comment "
IGNORE= The mlockall(2) of your FreeBSD 5.x version causes problems when used by cdrecord. Please update FreeBSD to >= 5.3 in order to use this port
.endif
+.if exists(${LOCALBASE}/lib/libcdio.a) || defined(WITH_CDDB)
+WITH_CDDB= yes
+LIB_DEPENDS+= cddb.3:${PORTSDIR}/audio/libcddb \
+ cdio.6:${PORTSDIR}/sysutils/libcdio
+.endif
+
pre-everything::
.if !defined(WITH_RSCSI)
@${ECHO_MSG} ""
@@ -66,6 +72,10 @@ pre-everything::
@${ECHO_MSG} " this is the preferred method to set it up."
@${ECHO_MSG} ""
.endif
+.if !defined(WITH_CDDB)
+ @${ECHO_MSG} "WITH_CDDB=yes builds with cddb (http://freedb.org) support"
+ @${ECHO_MSG} ""
+.endif
post-extract:
.for i in config.guess config.sub