aboutsummaryrefslogtreecommitdiff
path: root/sysutils/cfengine
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2006-10-09 13:19:33 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2006-10-09 13:19:33 +0000
commitb7ccbcd1bb4c2d1cde350d08af80e341cad60d99 (patch)
treeb5030bf9027481b22c519d6001610b3491cb70ee /sysutils/cfengine
parentd944be3080507c0838e67549b777f5dc73318936 (diff)
downloadports-b7ccbcd1bb4c2d1cde350d08af80e341cad60d99.tar.gz
ports-b7ccbcd1bb4c2d1cde350d08af80e341cad60d99.zip
- Resurrect sysutils/cfengine port removed year ago. It is currently
synced with sysutils/cfengine2 which it is going to replace. The reason for that is Cfengine 2.x being the stable version now, so the need for keeping both old 1.x (sysutils/cfengine) and the new 2.x (sysutils/cfengine2) has been obsoleted. This is currently disconnected from the build.
Notes
Notes: svn path=/head/; revision=175079
Diffstat (limited to 'sysutils/cfengine')
-rw-r--r--sysutils/cfengine/Makefile35
-rw-r--r--sysutils/cfengine/distinfo3
-rw-r--r--sysutils/cfengine/pkg-descr9
-rw-r--r--sysutils/cfengine/pkg-plist48
4 files changed, 95 insertions, 0 deletions
diff --git a/sysutils/cfengine/Makefile b/sysutils/cfengine/Makefile
new file mode 100644
index 000000000000..45e109a858e7
--- /dev/null
+++ b/sysutils/cfengine/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: cfengine
+# Date created: March 16, 1998
+# Whom: jseger@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfengine
+PORTVERSION= 2.1.20
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.iu.hio.no/pub/cfengine/ \
+ ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sergei@FreeBSD.org
+COMMENT= A systems administration tool for networks
+
+USE_BDB= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-berkeleydb=${LOCALBASE} --with-docs
+CPPFLAGS+= -I${BDB_INCLUDE_DIR}
+LDFLAGS+= -L${BDB_LIB_DIR} -l${BDB_LIB_NAME}
+
+.if !defined(NOPORTDOCS)
+INFO= cfengine-Anomalies cfengine-Reference cfengine-Tutorial
+.endif
+
+MAN8= cfagent.8 cfengine.8 cfenvd.8 cfenvgraph.8 cfetoolcheck.8 \
+ cfetoolcreate.8 cfetooldump.8 cfetoolgraph.8 cfetoolimport.8 \
+ cfetoolinfo.8 cfetoolupdate.8 cfexecd.8 cfkey.8 \
+ cfrun.8 cfservd.8 cfshow.8
+
+.include <bsd.port.mk>
diff --git a/sysutils/cfengine/distinfo b/sysutils/cfengine/distinfo
new file mode 100644
index 000000000000..ea91a4bf0d09
--- /dev/null
+++ b/sysutils/cfengine/distinfo
@@ -0,0 +1,3 @@
+MD5 (cfengine-2.1.20.tar.gz) = 2510349fef9ccc47d80f133d4a35322e
+SHA256 (cfengine-2.1.20.tar.gz) = 61bdca73ab60f7a707e02490ada8a357505121759ab0c2a4e6c14afc391253a0
+SIZE (cfengine-2.1.20.tar.gz) = 3684594
diff --git a/sysutils/cfengine/pkg-descr b/sysutils/cfengine/pkg-descr
new file mode 100644
index 000000000000..b1a53d4609d2
--- /dev/null
+++ b/sysutils/cfengine/pkg-descr
@@ -0,0 +1,9 @@
+Cfengine, or the configuration engine is an agent/software robot and a
+very high level language for building expert systems to administrate
+and configure large computer networks. Cfengine uses the idea of
+classes and a primitive form of intelligence to define and automate
+the configuration and maintenance of system state, for small to huge
+configurations. Cfengine is designed to be a part of a computer immune
+system.
+
+WWW: http://www.cfengine.org/
diff --git a/sysutils/cfengine/pkg-plist b/sysutils/cfengine/pkg-plist
new file mode 100644
index 000000000000..ad973e818f39
--- /dev/null
+++ b/sysutils/cfengine/pkg-plist
@@ -0,0 +1,48 @@
+@comment $FreeBSD$
+sbin/cfagent
+sbin/cfconvert
+sbin/cfdoc
+sbin/cfenvd
+sbin/cfenvgraph
+sbin/cfetool
+sbin/cfetoolgraph
+sbin/cfexecd
+sbin/cfkey
+sbin/cfrun
+sbin/cfservd
+sbin/cfshow
+%%EXAMPLESDIR%%/cf.chflags.example
+%%EXAMPLESDIR%%/cf.freebsd.example
+%%EXAMPLESDIR%%/cf.ftp.example
+%%EXAMPLESDIR%%/cf.groups.example
+%%EXAMPLESDIR%%/cf.linux.example
+%%EXAMPLESDIR%%/cf.main.example
+%%EXAMPLESDIR%%/cf.motd.example
+%%EXAMPLESDIR%%/cf.preconf.example
+%%EXAMPLESDIR%%/cf.services.example
+%%EXAMPLESDIR%%/cf.site.example
+%%EXAMPLESDIR%%/cf.solaris.example
+%%EXAMPLESDIR%%/cf.sun4.example
+%%EXAMPLESDIR%%/cf.users.example
+%%EXAMPLESDIR%%/cfagent.conf-advanced.example
+%%EXAMPLESDIR%%/cfagent.conf.example
+%%EXAMPLESDIR%%/cfengine.el
+%%EXAMPLESDIR%%/cfrc.example
+%%EXAMPLESDIR%%/cfrun.hosts.example
+%%EXAMPLESDIR%%/cfservd.conf.example
+%%EXAMPLESDIR%%/update.conf.example
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Anomalies.html
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Anomalies.pdf
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Anomalies.ps
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Reference.html
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Reference.pdf
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Reference.ps
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Tutorial.html
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Tutorial.pdf
+%%PORTDOCS%%%%DOCSDIR%%/cfengine-Tutorial.ps
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%