aboutsummaryrefslogtreecommitdiff
path: root/sysutils/condor
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-01-28 14:27:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-01-28 14:27:18 +0000
commita29aab9eee13b590b11afdc22cd2abdf2382522d (patch)
treefe6cd8b7e3d43b0181f856ed3e2e014a226c986c /sysutils/condor
parent44cb6d7afa2a2bc9ff4c86b2dd2aec37a25006c6 (diff)
downloadports-a29aab9eee13b590b11afdc22cd2abdf2382522d.tar.gz
ports-a29aab9eee13b590b11afdc22cd2abdf2382522d.zip
- Update to 7.0.0
PR: ports/119968 Submitted by: Andy Pavlo <pavlo@cs.wisc.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=206319
Diffstat (limited to 'sysutils/condor')
-rw-r--r--sysutils/condor/Makefile47
-rw-r--r--sysutils/condor/distinfo6
-rw-r--r--sysutils/condor/pkg-message6
-rw-r--r--sysutils/condor/pkg-plist421
4 files changed, 58 insertions, 422 deletions
diff --git a/sysutils/condor/Makefile b/sysutils/condor/Makefile
index 0b47382b9dc9..764990806a44 100644
--- a/sysutils/condor/Makefile
+++ b/sysutils/condor/Makefile
@@ -6,31 +6,31 @@
#
PORTNAME= condor
-PORTVERSION= 6.8.4
+PORTVERSION= 7.0.0
CATEGORIES= sysutils parallel
-MASTER_SITES= http://www.cs.wisc.edu/condor/cgi-bin/downloads/sendfile.pl/${OSREL}/v6.8/
-DISTNAME= condor-${PORTVERSION}-freebsd6-x86-dynamic
+MASTER_SITES= http://www.cs.wisc.edu/condor/cgi-bin/downloads/sendfile.pl/freebsd-${OSREL}/v7.0/
+DISTNAME= condor_src-${PORTVERSION}-all-all
MAINTAINER= pavlo@cs.wisc.edu
COMMENT= Condor High-Throughput Distributed Batch System
+BUILD_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+
ONLY_FOR_ARCHS= amd64 i386
-WRKSRC= ${WRKDIR}/condor-${PORTVERSION}
+WRKSRC= ${WRKDIR}/condor_src-${PORTVERSION}/src/
OPTIONS= SUBMIT_NODE "Configure system to be able to submit jobs" On \
EXECUTE_NODE "Configure system to execute jobs in pool" On \
MANAGER_NODE "Configure system as central manager node" On
+USE_AUTOTOOLS= autoconf:261:env
+USE_BISON= build
+USE_GMAKE= yes
USE_LDCONFIG= yes
-NO_BUILD= yes
-#NO_PACKAGE= yes
USE_PERL5_BUILD= yes
-# We conflict with the developer series version of Condor
-CONFLICTS= condor-devel-[0-9]*
-
.include <bsd.port.pre.mk>
.if defined(PACKAGE_BUILDING)
-IGNORE= requires fully qualified hostname
+#IGNORE= requires fully qualified hostname
.endif
.if defined(WITHOUT_SUBMIT_NODE)
@@ -38,7 +38,6 @@ INSTALL_SUBMIT_NODE=
.else
INSTALL_SUBMIT_NODE= submit,
.endif
-
.if defined(WITHOUT_EXECUTE_NODE)
INSTALL_EXECUTE_NODE=
.else
@@ -54,17 +53,33 @@ INSTALL_MANAGER_NODE= manager,
# Where Condor will store files it needs
LOCAL_DIR= ${DEST_DIR}/var/${PORTNAME}
+pre-everything::
+ @( ${ECHO_MSG} ""; \
+ ${ECHO_MSG} "WARNING: Condor needs approximately 5GB to build!"; \
+ ${ECHO_MSG} " Please make sure your build environment has that much before continuing."; \
+ ${ECHO_MSG} "" )
+
+pre-configure:
+ cd ${WRKSRC} && ./build_init
+
+do-configure:
+ cd ${WRKSRC} && ./configure --with-soft-is-hard
+
+do-build:
+ cd ${WRKSRC} && ${GMAKE} public
+
pre-install:
${MKDIR} ${LOCAL_DIR}/execute
${MKDIR} ${LOCAL_DIR}/spool
${MKDIR} ${LOCAL_DIR}/log
+ ${CP} ${WRKSRC}condor_scripts/condor_configure ${WRKSRC}
do-install:
- ${WRKSRC}/condor_configure --type=${INSTALL_SUBMIT_NODE}${INSTALL_EXECUTE_NODE}${INSTALL_MANAGER_NODE} --install=${WRKSRC}/release.tar --install-dir=${PREFIX} --local-dir=${LOCAL_DIR} --maybe-daemon-owner --overwrite
+ ${WRKSRC}/condor_configure --type=${INSTALL_SUBMIT_NODE}${INSTALL_EXECUTE_NODE}${INSTALL_MANAGER_NODE} --install=${WRKSRC}release_dir --install-dir=${PREFIX} --local-dir=${LOCAL_DIR} --maybe-daemon-owner --overwrite
${MV} ${PREFIX}/etc/examples/ ${PREFIX}/etc/condor_config.examples
${PERL} -pi -e "s|^HOSTALLOW_WRITE = .*|HOSTALLOW_WRITE = *|" ${PREFIX}/etc/condor_config
${PERL} -pi -e "s|^MASTER=.*|MASTER=${PREFIX}/sbin/condor_master|" ${PREFIX}/etc/condor_config.examples/condor.boot
- ${PERL} -pi -e "s|^PS=.*|PS=${PS}|" ${PREFIX}/etc/condor_config.examples/condor.boot
+ ${PERL} -pi -e "s|^PS=.*|PS=\"ps aux\"|" ${PREFIX}/etc/condor_config.examples/condor.boot
${CP} ${PREFIX}/etc/condor_config.examples/condor.boot ${PREFIX}/etc/rc.d/condor
post-install:
@@ -73,7 +88,7 @@ post-install:
${ECHO_MSG} "Set the following parameter in your environment:"; \
${ECHO_MSG} "CONDOR_CONFIG = ${PREFIX}/etc/condor_config"; \
${ECHO_MSG} ""; \
- ${ECHO_MSG} "Sample configuration files may be found in ${PREFIX}/condor_config.examples/"; \
+ ${ECHO_MSG} "Sample configuration files may be found in ${PREFIX}/etc/condor_config.examples/"; \
${ECHO_MSG} ""; \
${ECHO_MSG} "Condor can be started with the following command:"; \
${ECHO_MSG} "${PREFIX}/etc/rc.d/condor start"; \
@@ -82,8 +97,8 @@ post-install:
MAN1= condor_advertise.1 \
condor_checkpoint.1 \
condor_compile.1 \
- condor_configure.1 \
condor_config_val.1 \
+ condor_configure.1 \
condor_findhost.1 \
condor_glidein.1 \
condor_history.1 \
@@ -97,11 +112,11 @@ MAN1= condor_advertise.1 \
condor_q.1 \
condor_qedit.1 \
condor_reconfig.1 \
- condor_rm.1 \
condor_reconfig_schedd.1 \
condor_release.1 \
condor_reschedule.1 \
condor_restart.1 \
+ condor_rm.1 \
condor_run.1 \
condor_stats.1 \
condor_status.1 \
diff --git a/sysutils/condor/distinfo b/sysutils/condor/distinfo
index e7b6736f5330..451d5e75af52 100644
--- a/sysutils/condor/distinfo
+++ b/sysutils/condor/distinfo
@@ -1,3 +1,3 @@
-MD5 (condor-6.8.4-freebsd6-x86-dynamic.tar.gz) = 950fa962f2a9b5af20fc572ea506c5c7
-SHA256 (condor-6.8.4-freebsd6-x86-dynamic.tar.gz) = 5e246718ef080564c6c551cc6f8e762f4381bdbd6717ce4f07b189d5e7b6846e
-SIZE (condor-6.8.4-freebsd6-x86-dynamic.tar.gz) = 91225595
+MD5 (condor_src-7.0.0-all-all.tar.gz) = 06eec3ae274b66d233ad050a047f3c91
+SHA256 (condor_src-7.0.0-all-all.tar.gz) = d04ece5e8c3f0cbe376cfe167c80a794284e4e5165b029d9cb49a3ce9f54bfbd
+SIZE (condor_src-7.0.0-all-all.tar.gz) = 185678206
diff --git a/sysutils/condor/pkg-message b/sysutils/condor/pkg-message
index a65945ec162e..ef9eb218130d 100644
--- a/sysutils/condor/pkg-message
+++ b/sysutils/condor/pkg-message
@@ -7,9 +7,3 @@ your Condor pool.
See the manual for more information about tuning the HOSTALLOW_* paramters
in your system's condor_config file.
-
-IMPORTANT:
-You must set the CONDOR_CONFIG environment variable to the value shown
-below before trying to start the master daemon, or submitting jobs to
-Condor. This is will be fixed in future Condor stable series releases.
-It is already fixed in the condor-devel port.
diff --git a/sysutils/condor/pkg-plist b/sysutils/condor/pkg-plist
index 84c9b233e7f3..28a75024eafa 100644
--- a/sysutils/condor/pkg-plist
+++ b/sysutils/condor/pkg-plist
@@ -10,6 +10,7 @@ bin/condor_findhost
bin/condor_glidein
bin/condor_history
bin/condor_hold
+bin/condor_load_history
bin/condor_prio
bin/condor_q
bin/condor_qedit
@@ -33,7 +34,6 @@ bin/condor_wait
etc/condor_config
etc/condor_config.examples/README
etc/condor_config.examples/condor.boot
-etc/condor_config.examples/condor.generic
etc/condor_config.examples/condor_config.generic
etc/condor_config.examples/condor_config.local.central.manager
etc/condor_config.examples/condor_config.local.ckpt.server
@@ -45,6 +45,8 @@ etc/condor_config.examples/condor_config.local.root.ckpt.server
etc/condor_config.examples/condor_config.local.view_server
etc/condor_config.examples/condor_config.root.generic
etc/condor_config.examples/condor_config.submit.generic
+etc/condor_config.examples/condor_vmgahp_config.vmware
+etc/condor_config.examples/condor_vmgahp_config.xen
etc/condor_config.examples/lamscript
etc/condor_config.examples/mp1script
etc/rc.d/condor
@@ -63,298 +65,6 @@ lib/CondorJavaInfo.class
lib/CondorJavaWrapper.class
lib/Execute.pm
lib/FileLock.pm
-lib/gt3/build-client.xml
-lib/gt3/build-packages.xml
-lib/gt3/build-samples.xml
-lib/gt3/build-services.xml
-lib/gt3/build-tools.xml
-lib/gt3/build.xml
-lib/gt3/client-config.wsdd
-lib/gt3/client-gui-config.xml
-lib/gt3/client-server-config.wsdd
-lib/gt3/lib/axis.jar
-lib/gt3/lib/cas.jar
-lib/gt3/lib/casClients.jar
-lib/gt3/lib/casServer.jar
-lib/gt3/lib/casTests.jar
-lib/gt3/lib/cog-axis.jar
-lib/gt3/lib/cog-jglobus.jar
-lib/gt3/lib/cog-tomcat.jar
-lib/gt3/lib/commons-collections.jar
-lib/gt3/lib/commons-dbcp.jar
-lib/gt3/lib/commons-discovery.jar
-lib/gt3/lib/commons-logging.jar
-lib/gt3/lib/commons-pool.jar
-lib/gt3/lib/cryptix-asn1.jar
-lib/gt3/lib/cryptix.jar
-lib/gt3/lib/cryptix32.jar
-lib/gt3/lib/exolabcore-0.3.5.jar
-lib/gt3/lib/filestreaming.jar
-lib/gt3/lib/gram-rips.jar
-lib/gt3/lib/grim.jar
-lib/gt3/lib/gt3-gahp.jar
-lib/gt3/lib/jaxrpc.jar
-lib/gt3/lib/jboss-j2ee.jar
-lib/gt3/lib/jce-jdk13-120.jar
-lib/gt3/lib/jgss.jar
-lib/gt3/lib/jug-1.0.1.jar
-lib/gt3/lib/log4j-1.2.8.jar
-lib/gt3/lib/mds-aggregator.jar
-lib/gt3/lib/mds-db.jar
-lib/gt3/lib/mds-index.jar
-lib/gt3/lib/mds-providers.jar
-lib/gt3/lib/mjs.jar
-lib/gt3/lib/mmjfs.jar
-lib/gt3/lib/multirft.jar
-lib/gt3/lib/ogsa-samples.jar
-lib/gt3/lib/ogsa.jar
-lib/gt3/lib/ogsa_messaging_jms.jar
-lib/gt3/lib/openjms-0.7.5.jar
-lib/gt3/lib/opensaml.jar
-lib/gt3/lib/pg73jdbc2.jar
-lib/gt3/lib/puretls.jar
-lib/gt3/lib/saaj.jar
-lib/gt3/lib/sdb.jar
-lib/gt3/lib/servlet.jar
-lib/gt3/lib/wsdl4j.jar
-lib/gt3/lib/wsif.jar
-lib/gt3/lib/xalan.jar
-lib/gt3/lib/xercesImpl.jar
-lib/gt3/lib/xindice-1.1b3.jar
-lib/gt3/lib/xindice-servicegroup-stub.jar
-lib/gt3/lib/xindice-servicegroup.jar
-lib/gt3/lib/xml-apis-1.1.jar
-lib/gt3/lib/xmlParserAPIs.jar
-lib/gt3/lib/xmldb-api-20021118.jar
-lib/gt3/lib/xmldb-api-sdk-20021118.jar
-lib/gt3/lib/xmldb-common.jar
-lib/gt3/lib/xmldb-xupdate.jar
-lib/gt3/lib/xmlrpc-1.1.jar
-lib/gt3/lib/xmlsec.jar
-lib/gt3/local-client-config.wsdd
-lib/gt3/local-server-config.wsdd
-lib/gt3/local-server-config.wsdd.in
-lib/gt3/ogsa.properties
-lib/gt3/schema/NStoPkg.properties
-lib/gt3/schema/base/aggregator/data_aggregator_port_type.gwsdl
-lib/gt3/schema/base/gram/condor_gram_rsl.xsd
-lib/gt3/schema/base/gram/examples/condor_gram_rsl_example_1.xml
-lib/gt3/schema/base/gram/examples/gram_rsl_example_1.xml
-lib/gt3/schema/base/gram/examples/gram_rsl_example_2.xml
-lib/gt3/schema/base/gram/examples/gram_rsl_example_3.xml
-lib/gt3/schema/base/gram/examples/lsf_gram_rsl_example_1.xml
-lib/gt3/schema/base/gram/examples/pbs_gram_rsl_example_1.xml
-lib/gt3/schema/base/gram/examples/scheduler_gram_rsl_example_1.xml
-lib/gt3/schema/base/gram/examples/test.xml
-lib/gt3/schema/base/gram/failure_test.xsd
-lib/gt3/schema/base/gram/gram_rsl.xsd
-lib/gt3/schema/base/gram/lsf_gram_rsl.xsd
-lib/gt3/schema/base/gram/managed_job_bindings.wsdl
-lib/gt3/schema/base/gram/managed_job_port_type.gwsdl
-lib/gt3/schema/base/gram/managed_job_port_type.wsdl
-lib/gt3/schema/base/gram/managed_job_port_type.xsd
-lib/gt3/schema/base/gram/managed_job_service.wsdl
-lib/gt3/schema/base/gram/managed_job_types.wsdl
-lib/gt3/schema/base/gram/managed_job_types.xsd
-lib/gt3/schema/base/gram/mmjfs.gwsdl
-lib/gt3/schema/base/gram/mmjfs.wsdl
-lib/gt3/schema/base/gram/mmjfs_bindings.wsdl
-lib/gt3/schema/base/gram/mmjfs_service.wsdl
-lib/gt3/schema/base/gram/pbs_gram_rsl.xsd
-lib/gt3/schema/base/gram/rips.gwsdl
-lib/gt3/schema/base/gram/rips.wsdl
-lib/gt3/schema/base/gram/rips.xsd
-lib/gt3/schema/base/gram/rips_bindings.wsdl
-lib/gt3/schema/base/gram/rips_service.wsdl
-lib/gt3/schema/base/gram/rsl.xsd
-lib/gt3/schema/base/gram/rsl_enum.xsd
-lib/gt3/schema/base/gram/scheduler_gram_rsl.xsd
-lib/gt3/schema/base/index/index_bindings.wsdl
-lib/gt3/schema/base/index/index_service.wsdl
-lib/gt3/schema/base/index/index_service_port_type.gwsdl
-lib/gt3/schema/base/index/index_service_port_type.wsdl
-lib/gt3/schema/base/multirft/multirft_bindings.wsdl
-lib/gt3/schema/base/multirft/multirft_port_type.gwsdl
-lib/gt3/schema/base/multirft/multirft_port_type.wsdl
-lib/gt3/schema/base/multirft/multirft_port_type.xsd
-lib/gt3/schema/base/multirft/multirft_service.wsdl
-lib/gt3/schema/base/multirft/multirft_types.wsdl
-lib/gt3/schema/base/provider/service_data_provider_execution_port_type.gwsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_bindings.wsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_factory_bindings.wsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_factory_port_type.gwsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_factory_port_type.wsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_factory_service.wsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_port_type.gwsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_port_type.wsdl
-lib/gt3/schema/base/servicegroup/xindice_servicegroup_service.wsdl
-lib/gt3/schema/base/streaming/file_stream_bindings.wsdl
-lib/gt3/schema/base/streaming/file_stream_factory_bindings.wsdl
-lib/gt3/schema/base/streaming/file_stream_factory_port_type.gwsdl
-lib/gt3/schema/base/streaming/file_stream_factory_port_type.wsdl
-lib/gt3/schema/base/streaming/file_stream_factory_service.wsdl
-lib/gt3/schema/base/streaming/file_stream_port_type.gwsdl
-lib/gt3/schema/base/streaming/file_stream_port_type.wsdl
-lib/gt3/schema/base/streaming/file_stream_port_type.xsd
-lib/gt3/schema/base/streaming/file_stream_service.wsdl
-lib/gt3/schema/core/admin/admin_bindings.wsdl
-lib/gt3/schema/core/admin/admin_port_type.gwsdl
-lib/gt3/schema/core/admin/admin_port_type.wsdl
-lib/gt3/schema/core/admin/admin_port_type.xsd
-lib/gt3/schema/core/admin/admin_service.wsdl
-lib/gt3/schema/core/admin/admin_types.wsdl
-lib/gt3/schema/core/factory/gsi_factory_service.wsdl
-lib/gt3/schema/core/logging/logging_bindings.wsdl
-lib/gt3/schema/core/logging/logging_port_type.gwsdl
-lib/gt3/schema/core/logging/logging_port_type.wsdl
-lib/gt3/schema/core/logging/logging_port_type.xsd
-lib/gt3/schema/core/logging/logging_service.wsdl
-lib/gt3/schema/core/management/management_bindings.wsdl
-lib/gt3/schema/core/management/management_port_type.gwsdl
-lib/gt3/schema/core/management/management_port_type.wsdl
-lib/gt3/schema/core/management/management_port_type.xsd
-lib/gt3/schema/core/management/management_service.wsdl
-lib/gt3/schema/core/notification/gsi_notification_sink_service.wsdl
-lib/gt3/schema/core/notification/gsi_notification_subscription_service.wsdl
-lib/gt3/schema/core/notification/jms_adapter_bindings.wsdl
-lib/gt3/schema/core/notification/jms_adapter_port_type.gwsdl
-lib/gt3/schema/core/notification/jms_adapter_port_type.wsdl
-lib/gt3/schema/core/notification/jms_adapter_port_type.xsd
-lib/gt3/schema/core/notification/jms_adapter_service.wsdl
-lib/gt3/schema/core/notification/notification.wsdl
-lib/gt3/schema/core/notification/notification.xsd
-lib/gt3/schema/core/ping/ping_bindings.wsdl
-lib/gt3/schema/core/ping/ping_port_type.gwsdl
-lib/gt3/schema/core/ping/ping_port_type.wsdl
-lib/gt3/schema/core/ping/ping_port_type.xsd
-lib/gt3/schema/core/ping/ping_service.wsdl
-lib/gt3/schema/core/proxy/dummy_proxy_service.wsdl
-lib/gt3/schema/core/proxy/proxy_factory_service.wsdl
-lib/gt3/schema/core/types/properties_detail.wsdl
-lib/gt3/schema/core/types/properties_detail.xsd
-lib/gt3/schema/core/types/query.wsdl
-lib/gt3/schema/core/types/query.xsd
-lib/gt3/schema/core/types/servicedata.wsdl
-lib/gt3/schema/core/types/servicedata.xsd
-lib/gt3/schema/core/types/subscription.wsdl
-lib/gt3/schema/core/types/subscription.xsd
-lib/gt3/schema/core/types/timestamp.wsdl
-lib/gt3/schema/core/types/timestamp.xsd
-lib/gt3/schema/generated/ArraySample/ArraySampleService.wsdl
-lib/gt3/schema/generated/GenerateCounter/GenerateCounterService.wsdl
-lib/gt3/schema/ogsi/gwsdl.xsd
-lib/gt3/schema/ogsi/gwsdl_port_type.wsdl
-lib/gt3/schema/ogsi/gwsdl_port_type.xsd
-lib/gt3/schema/ogsi/ogsi.gwsdl
-lib/gt3/schema/ogsi/ogsi.wsdl
-lib/gt3/schema/ogsi/ogsi.xsd
-lib/gt3/schema/ogsi/ogsi_bindings.wsdl
-lib/gt3/schema/ogsi/ogsi_factory.gwsdl
-lib/gt3/schema/ogsi/ogsi_factory.wsdl
-lib/gt3/schema/ogsi/ogsi_factory_bindings.wsdl
-lib/gt3/schema/ogsi/ogsi_factory_service.wsdl
-lib/gt3/schema/ogsi/ogsi_handle_resolver_service.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_factory.gwsdl
-lib/gt3/schema/ogsi/ogsi_notification_factory.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_factory_bindings.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_factory_service.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_service_group.gwsdl
-lib/gt3/schema/ogsi/ogsi_notification_service_group.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_service_group_bindings.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_service_group_service.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_sink_service.wsdl
-lib/gt3/schema/ogsi/ogsi_notification_subscription_service.wsdl
-lib/gt3/schema/ogsi/ogsi_service.wsdl
-lib/gt3/schema/ogsi/ogsi_service_data.wsdl
-lib/gt3/schema/ogsi/ogsi_service_data.xsd
-lib/gt3/schema/ogsi/ogsi_service_group_entry_service.wsdl
-lib/gt3/schema/ogsi/ogsi_service_group_registration.gwsdl
-lib/gt3/schema/ogsi/ogsi_service_group_registration.wsdl
-lib/gt3/schema/ogsi/ogsi_service_group_registration_bindings.wsdl
-lib/gt3/schema/ogsi/ogsi_service_group_registration_service.wsdl
-lib/gt3/schema/ogsi/service_data.xsd
-lib/gt3/schema/ogsi/wsdl.xsd
-lib/gt3/schema/ogsi/wsdl12.xsd
-lib/gt3/schema/ogsi/xsd.xsd
-lib/gt3/schema/samples/any/any_bindings.wsdl
-lib/gt3/schema/samples/any/any_port_type.wsdl
-lib/gt3/schema/samples/any/any_service.wsdl
-lib/gt3/schema/samples/chat/chat_bindings.wsdl
-lib/gt3/schema/samples/chat/chat_port_type.gwsdl
-lib/gt3/schema/samples/chat/chat_port_type.wsdl
-lib/gt3/schema/samples/chat/chat_port_type.xsd
-lib/gt3/schema/samples/chat/chat_service.wsdl
-lib/gt3/schema/samples/counter/counter_bindings.wsdl
-lib/gt3/schema/samples/counter/counter_port_type.gwsdl
-lib/gt3/schema/samples/counter/counter_port_type.wsdl
-lib/gt3/schema/samples/counter/counter_port_type.xsd
-lib/gt3/schema/samples/counter/counter_service.wsdl
-lib/gt3/schema/samples/counter/encoded_counter_service.wsdl
-lib/gt3/schema/samples/counter/gsi_counter_bindings.wsdl
-lib/gt3/schema/samples/counter/gsi_counter_service.wsdl
-lib/gt3/schema/samples/counter/notification_counter_bindings.wsdl
-lib/gt3/schema/samples/counter/notification_counter_port_type.gwsdl
-lib/gt3/schema/samples/counter/notification_counter_port_type.wsdl
-lib/gt3/schema/samples/counter/notification_counter_service.wsdl
-lib/gt3/schema/samples/counter/routable_counter_bindings.wsdl
-lib/gt3/schema/samples/counter/routable_counter_port_type.gwsdl
-lib/gt3/schema/samples/counter/routable_counter_port_type.wsdl
-lib/gt3/schema/samples/counter/routable_counter_port_type.xsd
-lib/gt3/schema/samples/counter/routable_counter_service.wsdl
-lib/gt3/schema/samples/exception/exception_bindings.wsdl
-lib/gt3/schema/samples/exception/exception_port_type.wsdl
-lib/gt3/schema/samples/exception/exception_service.wsdl
-lib/gt3/schema/samples/extension/counter_multiply_bindings.wsdl
-lib/gt3/schema/samples/extension/counter_multiply_port_type.wsdl
-lib/gt3/schema/samples/extension/counter_multiply_service.wsdl
-lib/gt3/schema/samples/extension/counter_notification_service.wsdl
-lib/gt3/schema/samples/google/google_search_service.wsdl
-lib/gt3/schema/samples/gwsdl/base_port_types.gwsdl
-lib/gt3/schema/samples/gwsdl/top_bindings.wsdl
-lib/gt3/schema/samples/gwsdl/top_port_type.gwsdl
-lib/gt3/schema/samples/gwsdl/top_port_type.wsdl
-lib/gt3/schema/samples/gwsdl/top_port_type.xsd
-lib/gt3/schema/samples/gwsdl/top_service.wsdl
-lib/gt3/schema/samples/notification/sink_listener_bindings.wsdl
-lib/gt3/schema/samples/notification/sink_listener_port_type.gwsdl
-lib/gt3/schema/samples/notification/sink_listener_port_type.wsdl
-lib/gt3/schema/samples/notification/sink_listener_port_type.xsd
-lib/gt3/schema/samples/notification/sink_listener_service.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_all_bindings.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_all_port_type.gwsdl
-lib/gt3/schema/samples/ogsi/ogsi_all_port_type.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_all_port_type.xsd
-lib/gt3/schema/samples/ogsi/ogsi_all_service.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_notification_bindings.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_notification_port_type.gwsdl
-lib/gt3/schema/samples/ogsi/ogsi_notification_port_type.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_notification_service.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_service_group_bindings.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_service_group_port_type.gwsdl
-lib/gt3/schema/samples/ogsi/ogsi_service_group_port_type.wsdl
-lib/gt3/schema/samples/ogsi/ogsi_service_group_service.wsdl
-lib/gt3/schema/samples/registry/vo_registry_service.wsdl
-lib/gt3/schema/samples/servicedata/service_data_bindings.wsdl
-lib/gt3/schema/samples/servicedata/service_data_port_type.gwsdl
-lib/gt3/schema/samples/servicedata/service_data_port_type.wsdl
-lib/gt3/schema/samples/servicedata/service_data_port_type.xsd
-lib/gt3/schema/samples/servicedata/service_data_service.wsdl
-lib/gt3/schema/samples/temperature/xmethods_temperature_service.wsdl
-lib/gt3/schema/samples/weather/weather_bindings.wsdl
-lib/gt3/schema/samples/weather/weather_port_type.wsdl
-lib/gt3/schema/samples/weather/weather_service.wsdl
-lib/gt3/schema/security/authentication/gss_secure_conversation.xsd
-lib/gt3/schema/security/authentication/gss_secure_conversation_bindings.wsdl
-lib/gt3/schema/security/authentication/gss_secure_conversation_port_type.gwsdl
-lib/gt3/schema/security/authentication/gss_secure_conversation_port_type.wsdl
-lib/gt3/schema/security/authentication/gss_secure_conversation_port_type.xsd
-lib/gt3/schema/security/authentication/gss_secure_conversation_service.wsdl
-lib/gt3/schema/tests/complex/NestedArrayService.wsdl
-lib/gt3/schema/tests/complex/NestedService.wsdl
-lib/gt3/schema/tests/security/security_test_port_type.gwsdl
-lib/gt3/schema/tests/serialization/serialization_port_type.gwsdl
-lib/gt3/server-config.wsdd
-lib/gt3/server-config.wsdd.in
lib/gt4-gahp.jar
lib/gt4/README.CONDOR_EXTERNAL
lib/gt4/client-config.wsdd
@@ -452,53 +162,12 @@ lib/gt4/share/schema/core/registry/registry_entry_flattened.wsdl
lib/gt4/share/schema/core/registry/registry_entry_service.wsdl
lib/gt4/share/schema/core/registry/registry_flattened.wsdl
lib/gt4/share/schema/core/registry/registry_service.wsdl
-lib/gt4/share/schema/core/samples/authzService/authzService_bindings.wsdl
-lib/gt4/share/schema/core/samples/authzService/authzService_flattened.wsdl
-lib/gt4/share/schema/core/samples/authzService/authzService_service.wsdl
-lib/gt4/share/schema/core/samples/counter/counter_bindings.wsdl
-lib/gt4/share/schema/core/samples/counter/counter_flattened.wsdl
-lib/gt4/share/schema/core/samples/counter/counter_service.wsdl
-lib/gt4/share/schema/core/samples/management/management_bindings.wsdl
-lib/gt4/share/schema/core/samples/management/management_flattened.wsdl
-lib/gt4/share/schema/core/samples/management/management_service.wsdl
lib/gt4/share/schema/core/security/authorization/authz_bindings.wsdl
lib/gt4/share/schema/core/security/authorization/authz_port_type.wsdl
lib/gt4/share/schema/core/security/authorization/authz_service.wsdl
lib/gt4/share/schema/core/security/secconv/secure_conversation_bindings.wsdl
lib/gt4/share/schema/core/security/secconv/secure_conversation_port_type.wsdl
lib/gt4/share/schema/core/security/secconv/secure_conversation_service.wsdl
-lib/gt4/share/schema/core/tests/basic/TestRPCService.wsdl
-lib/gt4/share/schema/core/tests/basic/test_bindings.wsdl
-lib/gt4/share/schema/core/tests/basic/test_flattened.wsdl
-lib/gt4/share/schema/core/tests/basic/test_service.wsdl
-lib/gt4/share/schema/core/tests/c-providers/ResourcePropertiesTest.wsdl
-lib/gt4/share/schema/core/tests/c-providers/ResourcePropertiesTest_bindings.wsdl
-lib/gt4/share/schema/core/tests/c-providers/ResourcePropertiesTest_service.wsdl
-lib/gt4/share/schema/core/tests/interop/notification_consumer_factory_bindings.wsdl
-lib/gt4/share/schema/core/tests/interop/notification_consumer_factory_port_type.wsdl
-lib/gt4/share/schema/core/tests/interop/notification_consumer_factory_service.wsdl
-lib/gt4/share/schema/core/tests/interop/widget_bindings.wsdl
-lib/gt4/share/schema/core/tests/interop/widget_notification_bindings.wsdl
-lib/gt4/share/schema/core/tests/interop/widget_notification_flattened.wsdl
-lib/gt4/share/schema/core/tests/interop/widget_notification_service.wsdl
-lib/gt4/share/schema/core/tests/interop/widget_port_type.wsdl
-lib/gt4/share/schema/core/tests/interop/widget_service.wsdl
-lib/gt4/share/schema/core/tests/invalidate/invalidate_port_type.wsdl
-lib/gt4/share/schema/core/tests/notification/notification_test_bindings.wsdl
-lib/gt4/share/schema/core/tests/notification/notification_test_flattened.wsdl
-lib/gt4/share/schema/core/tests/notification/notification_test_service.wsdl
-lib/gt4/share/schema/core/tests/notification/persistence_test_subscription_manager_bindings.wsdl
-lib/gt4/share/schema/core/tests/notification/persistence_test_subscription_manager_flattened.wsdl
-lib/gt4/share/schema/core/tests/notification/persistence_test_subscription_manager_service.wsdl
-lib/gt4/share/schema/core/tests/performance/basic_perf_test_bindings.wsdl
-lib/gt4/share/schema/core/tests/performance/basic_perf_test_port_type.wsdl
-lib/gt4/share/schema/core/tests/performance/basic_perf_test_service.wsdl
-lib/gt4/share/schema/core/tests/performance/counter_bindings.wsdl
-lib/gt4/share/schema/core/tests/performance/counter_flattened.wsdl
-lib/gt4/share/schema/core/tests/performance/counter_service.wsdl
-lib/gt4/share/schema/core/tests/security/security_test_bindings.wsdl
-lib/gt4/share/schema/core/tests/security/security_test_flattened.wsdl
-lib/gt4/share/schema/core/tests/security/security_test_service.wsdl
lib/gt4/share/schema/core/types/timestamp.wsdl
lib/gt4/share/schema/core/types/timestamp.xsd
lib/gt4/share/schema/ws/addressing/WS-Addressing.xsd
@@ -541,24 +210,29 @@ lib/webservice/condorAccountant.wsdl
lib/webservice/condorCgahp.wsdl
lib/webservice/condorCollector.wsdl
lib/webservice/condorDagman.wsdl
+lib/webservice/condorDbmsd.wsdl
lib/webservice/condorDcskel.wsdl
+lib/webservice/condorEventd.wsdl
lib/webservice/condorGridmanager.wsdl
lib/webservice/condorHad.wsdl
lib/webservice/condorMaster.wsdl
lib/webservice/condorNegotiator.wsdl
-lib/webservice/condorQuill.wsdl
lib/webservice/condorSchedd.wsdl
lib/webservice/condorShadow.wsdl
lib/webservice/condorStartd.wsdl
lib/webservice/condorStarter.wsdl
+lib/webservice/condorTransferd.wsdl
+lib/webservice/condorVMgahp.wsdl
libexec/condor_chirp
libexec/condor_ssh
libexec/gcb_broker
libexec/gcb_relay_server
+libexec/glexec_starter_setup.sh
libexec/glite/condorc-advertiser
libexec/glite/condorc-authorizer
libexec/glite/condorc-initialize
libexec/glite/condorc-launcher
+libexec/glite/condorc-vo-advertiser
libexec/glite/grid_monitor.sh
libexec/globus-gridftp-server
libexec/gridftp_wrapper.sh
@@ -578,6 +252,7 @@ sbin/condor_collector
sbin/condor_config_bind
sbin/condor_configure
sbin/condor_convert_history
+sbin/condor_dbmsd
sbin/condor_fetchlog
sbin/condor_gridmanager
sbin/condor_gridshell
@@ -593,30 +268,32 @@ sbin/condor_negotiator
sbin/condor_off
sbin/condor_on
sbin/condor_preen
-sbin/condor_pvmd
-sbin/condor_pvmgs
+sbin/condor_procd
sbin/condor_quill
sbin/condor_reconfig
sbin/condor_reconfig_schedd
sbin/condor_replication
sbin/condor_reschedule
sbin/condor_restart
+sbin/condor_root_switchboard
sbin/condor_schedd
sbin/condor_shadow
-sbin/condor_shadow.pvm
sbin/condor_shadow.std
sbin/condor_startd
sbin/condor_starter
-sbin/condor_starter.pvm
sbin/condor_starter.std
sbin/condor_store_cred
+sbin/condor_transferd
sbin/condor_updates_stats
sbin/condor_vacate
+sbin/condor_vm-gahp
+sbin/condor_vm_vmware.pl
+sbin/condor_vm_xen.sh
sbin/filelock_midwife
sbin/filelock_undertaker
sbin/gahp_server
+sbin/gcb_broker_query
sbin/grid_monitor.sh
-sbin/gt3_gahp
sbin/gt4_gahp
sbin/install_release
sbin/nordugrid_gahp
@@ -624,8 +301,14 @@ sbin/unicore_gahp
sbin/uniq_pid_command
sbin/uniq_pid_midwife
sbin/uniq_pid_undertaker
+sql/common_createddl.sql
+sql/oracle_createddl.sql
+sql/oracle_dropddl.sql
+sql/pgsql_createddl.sql
+sql/pgsql_dropddl.sql
src/chirp/chirp_client.c
src/chirp/chirp_client.h
+src/chirp/chirp_protocol.h
src/drmaa/Makefile.in
src/drmaa/README
src/drmaa/STATUS
@@ -645,6 +328,7 @@ src/drmaa/libDrmaa.c
@dirrm src/drmaa
@dirrm src/chirp
@dirrm src
+@dirrm sql
@dirrm libexec/glite
@dirrm lib/webservice
@dirrm lib/gt4/share/schema/wsrf/servicegroup
@@ -660,21 +344,9 @@ src/drmaa/libDrmaa.c
@dirrm lib/gt4/share/schema/ws/addressing
@dirrm lib/gt4/share/schema/ws
@dirrm lib/gt4/share/schema/core/types
-@dirrm lib/gt4/share/schema/core/tests/security
-@dirrm lib/gt4/share/schema/core/tests/performance
-@dirrm lib/gt4/share/schema/core/tests/notification
-@dirrm lib/gt4/share/schema/core/tests/invalidate
-@dirrm lib/gt4/share/schema/core/tests/interop
-@dirrm lib/gt4/share/schema/core/tests/c-providers
-@dirrm lib/gt4/share/schema/core/tests/basic
-@dirrm lib/gt4/share/schema/core/tests
@dirrm lib/gt4/share/schema/core/security/secconv
@dirrm lib/gt4/share/schema/core/security/authorization
@dirrm lib/gt4/share/schema/core/security
-@dirrm lib/gt4/share/schema/core/samples/management
-@dirrm lib/gt4/share/schema/core/samples/counter
-@dirrm lib/gt4/share/schema/core/samples/authzService
-@dirrm lib/gt4/share/schema/core/samples
@dirrm lib/gt4/share/schema/core/registry
@dirrm lib/gt4/share/schema/core/notification
@dirrm lib/gt4/share/schema/core/management
@@ -686,49 +358,4 @@ src/drmaa/libDrmaa.c
@dirrm lib/gt4/etc
@dirrm lib/gt4/endorsed
@dirrm lib/gt4
-@dirrm lib/gt3/schema/tests/serialization
-@dirrm lib/gt3/schema/tests/security
-@dirrm lib/gt3/schema/tests/complex
-@dirrm lib/gt3/schema/tests
-@dirrm lib/gt3/schema/security/authentication
-@dirrm lib/gt3/schema/security
-@dirrm lib/gt3/schema/samples/weather
-@dirrm lib/gt3/schema/samples/temperature
-@dirrm lib/gt3/schema/samples/servicedata
-@dirrm lib/gt3/schema/samples/registry
-@dirrm lib/gt3/schema/samples/ogsi
-@dirrm lib/gt3/schema/samples/notification
-@dirrm lib/gt3/schema/samples/gwsdl
-@dirrm lib/gt3/schema/samples/google
-@dirrm lib/gt3/schema/samples/extension
-@dirrm lib/gt3/schema/samples/exception
-@dirrm lib/gt3/schema/samples/counter
-@dirrm lib/gt3/schema/samples/chat
-@dirrm lib/gt3/schema/samples/any
-@dirrm lib/gt3/schema/samples
-@dirrm lib/gt3/schema/ogsi
-@dirrm lib/gt3/schema/generated/GenerateCounter
-@dirrm lib/gt3/schema/generated/ArraySample
-@dirrm lib/gt3/schema/generated
-@dirrm lib/gt3/schema/core/types
-@dirrm lib/gt3/schema/core/proxy
-@dirrm lib/gt3/schema/core/ping
-@dirrm lib/gt3/schema/core/notification
-@dirrm lib/gt3/schema/core/management
-@dirrm lib/gt3/schema/core/logging
-@dirrm lib/gt3/schema/core/factory
-@dirrm lib/gt3/schema/core/admin
-@dirrm lib/gt3/schema/core
-@dirrm lib/gt3/schema/base/streaming
-@dirrm lib/gt3/schema/base/servicegroup
-@dirrm lib/gt3/schema/base/provider
-@dirrm lib/gt3/schema/base/multirft
-@dirrm lib/gt3/schema/base/index
-@dirrm lib/gt3/schema/base/gram/examples
-@dirrm lib/gt3/schema/base/gram
-@dirrm lib/gt3/schema/base/aggregator
-@dirrm lib/gt3/schema/base
-@dirrm lib/gt3/schema
-@dirrm lib/gt3/lib
-@dirrm lib/gt3
@dirrm etc/condor_config.examples