aboutsummaryrefslogtreecommitdiff
path: root/sysutils/conky
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-08 05:07:14 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-08 05:07:14 +0000
commit6b1622d5ff775f8920d297977fcf9ecd87607772 (patch)
treef6fd5bec7a08beeffab6e5b3312e01c611dedee3 /sysutils/conky
parent63402e204c280c160615c8cd0ef2f7f7838ccf92 (diff)
downloadports-6b1622d5ff775f8920d297977fcf9ecd87607772.tar.gz
ports-6b1622d5ff775f8920d297977fcf9ecd87607772.zip
- Fix build with llvm/clang and other miscellanous compile issues
- Bump PORTREVISION PR: ports/164893 Submitted by: Brandon Gooch <jamesbrandongooch@gmail.com> & Nikos Ntarmos <ntarmos@ceid.upatras.gr> (maintainer)
Notes
Notes: svn path=/head/; revision=292931
Diffstat (limited to 'sysutils/conky')
-rw-r--r--sysutils/conky/Makefile10
-rw-r--r--sysutils/conky/files/patch-configure102
-rw-r--r--sysutils/conky/files/patch-src-ccurl_thread.c10
-rw-r--r--sysutils/conky/files/patch-src-conky.c11
-rw-r--r--sysutils/conky/files/patch-src-freebsd.c38
5 files changed, 161 insertions, 10 deletions
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index e1bcec05be55..b5061b2281c2 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -7,7 +7,7 @@
PORTNAME= conky
PORTVERSION= 1.8.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= sysutils
MASTER_SITES= SF
@@ -39,6 +39,7 @@ PORTDOCS= README AUTHORS ChangeLog TODO NEWS \
OPTIONS+= APCUPSD "Enable APCUPSD support" Off \
AUDACIOUS "Enable Audacious support" Off \
+ INOTIFY "Enable inotify support" Off \
MPD "Enable MPD support" Off \
NCURSES "Enable ncurses support" Off \
RSS "Enable RSS support" Off \
@@ -82,6 +83,13 @@ CONFIGURE_ARGS+= --enable-audacious
CONFIGURE_ARGS+= --disable-audacious
.endif
+.if defined(WITH_INOTIFY)
+LIB_DEPENDS+= inotify.0:${PORTSDIR}/devel/libinotify
+CONFIGURE_ARGS+= --enable-inotify
+.else
+CONFIGURE_ARGS+= --disable-inotify
+.endif
+
.if defined(WITH_LUA) || defined(WITH_LUA_CAIRO) || defined(WITH_LUA_IMLIB2)
USE_LUA= 5.1+
CONFIGURE_ARGS+= --enable-lua
diff --git a/sysutils/conky/files/patch-configure b/sysutils/conky/files/patch-configure
index 97e4645d6745..15d693ec9228 100644
--- a/sysutils/conky/files/patch-configure
+++ b/sysutils/conky/files/patch-configure
@@ -1,6 +1,22 @@
--- configure.orig
+++ configure
-@@ -11645,7 +11645,7 @@
+@@ -1002,6 +1002,7 @@
+ enable_xft
+ enable_nvidia
+ enable_alsa
++enable_inotify
+ enable_debug
+ enable_testing
+ enable_profiling
+@@ -1729,6 +1730,7 @@
+ --enable-nvidia enable if you want nvidia support [default=no]
+ --disable-alsa disable if you do not want ALSA support
+ [default=yes]
++ --enable-inotify enable if you want inotify support [default=no]
+ --enable-debug compile with debug symbols [default=no]
+ --enable-testing use strict compiler flags for testing [default=no]
+ --enable-profiling specify compiler flags for use with gprof and gcov
+@@ -11647,7 +11649,7 @@
if test x$want_apcupsd = xyes; then
@@ -18,3 +34,87 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: iostats not supported on $uname... disabling" >&5
$as_echo "$as_me: iostats not supported on $uname... disabling" >&6;}
want_iostats="not supported on $uname"
+@@ -16071,20 +16073,65 @@
+
+ done
+
+-# check if we have inotify support
+-for ac_header in sys/inotify.h
+-do :
+- ac_fn_c_check_header_mongrel "$LINENO" "sys/inotify.h" "ac_cv_header_sys_inotify_h" "$ac_includes_default"
+-if test "x$ac_cv_header_sys_inotify_h" = x""yes; then :
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_SYS_INOTIFY_H 1
+-_ACEOF
+
++# Check whether --enable-inotify was given.
++if test "${enable_inotify+set}" = set; then :
++ enableval=$enable_inotify; want_inotify="$enableval"
++else
++ want_inotify=no
+ fi
+
+-done
++if test x$want_inotify = xyes; then
++ ac_fn_c_check_header_mongrel "$LINENO" "sys/inotify.h" "ac_cv_header_sys_inotify_h" "$ac_includes_default"
++if test "x$ac_cv_header_sys_inotify_h" = xyes; then :
++
++else
++ want_inotify=no
++fi
+
+
++fi
++if test x$want_inotify = xyes; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for inotify_init in -linotify" >&5
++$as_echo_n "checking for inotify_init in -linotify... " >&6; }
++if ${ac_cv_lib_inotify_inotify_init+:} false; then :
++ $as_echo_n "(cached) " >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-linotify $LIBS"
++cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h. */
++
++#include <sys/inotify.h>
++
++char inotify_init ();
++int
++main ()
++{
++return inotify_init ();
++ ;
++ return 0;
++}
++_ACEOF
++if ac_fn_c_try_link "$LINENO"; then :
++ ac_cv_lib_inotify_inotify_init=yes
++else
++ ac_cv_lib_inotify_inotify_init=no
++fi
++rm -f core conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_inotify_inotify_init" >&5
++$as_echo "$ac_cv_lib_inotify_inotify_init" >&6; }
++if test "x$ac_cv_lib_inotify_inotify_init" = xyes; then :
++ conky_LIBS="$conky_LIBS -linotify"
++else
++ want_inotify=yes
++fi
++
++fi
++
+
+
+ $as_echo "#define DEFAULTNETDEV \"eth0\"" >>confdefs.h
+@@ -16102,7 +16153,7 @@
+ $as_echo "#define DEFAULT_TEXT_BUFFER_SIZE 256" >>confdefs.h
+
+
+-$as_echo "#define MAX_NET_INTERFACES 16" >>confdefs.h
++$as_echo "#define MAX_NET_INTERFACES 64" >>confdefs.h
+
+
+
diff --git a/sysutils/conky/files/patch-src-ccurl_thread.c b/sysutils/conky/files/patch-src-ccurl_thread.c
new file mode 100644
index 000000000000..1520bbe065d2
--- /dev/null
+++ b/sysutils/conky/files/patch-src-ccurl_thread.c
@@ -0,0 +1,10 @@
+--- src/ccurl_thread.c.orig 2010-10-06 00:29:36.000000000 +0300
++++ src/ccurl_thread.c 2012-03-05 01:08:23.000000000 +0200
+@@ -33,7 +33,6 @@
+ #endif /* DEBUG */
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ /*
diff --git a/sysutils/conky/files/patch-src-conky.c b/sysutils/conky/files/patch-src-conky.c
index 3ff8111fa879..df0fa1507c53 100644
--- a/sysutils/conky/files/patch-src-conky.c
+++ b/sysutils/conky/files/patch-src-conky.c
@@ -1,5 +1,14 @@
--- src/conky.c.orig 2010-10-06 00:29:36.000000000 +0300
-+++ src/conky.c 2010-10-10 00:06:31.000000000 +0300
++++ src/conky.c 2012-03-05 01:03:43.000000000 +0200
+@@ -119,7 +119,7 @@
+ #include "openbsd.h"
+ #endif
+
+-#if defined(__FreeBSD_kernel__)
++#if defined(__FreeBSD_kernel__) && (__FreeBSD_kernel__ + 0)
+ #include <bsd/bsd.h>
+ #endif
+
@@ -2072,9 +2072,11 @@
OBJ(xmms2_percent) {
snprintf(p, p_max_size, "%2.0f", cur->xmms2.progress * 100);
diff --git a/sysutils/conky/files/patch-src-freebsd.c b/sysutils/conky/files/patch-src-freebsd.c
index 957d8911c9e7..2547bfb8cc74 100644
--- a/sysutils/conky/files/patch-src-freebsd.c
+++ b/sysutils/conky/files/patch-src-freebsd.c
@@ -1,6 +1,18 @@
---- src/freebsd.c.orig 2010-10-24 03:14:05.000000000 +0300
-+++ src/freebsd.c 2010-10-24 03:13:05.000000000 +0300
-@@ -266,7 +266,9 @@
+--- src/freebsd.c.orig 2010-10-06 00:29:36.000000000 +0300
++++ src/freebsd.c 2012-03-05 01:02:25.000000000 +0200
+@@ -38,6 +38,11 @@
+ #include <sys/types.h>
+ #include <sys/user.h>
+
++#if defined(__FreeBSD__) && (!defined(__FreeBSD_kernel__) || !(__FreeBSD_kernel__ + 0))
++# undef __FreeBSD_kernel__
++# define __FreeBSD_kernel__ __FreeBSD__
++#endif
++
+ #include <net/if.h>
+ #include <net/if_mib.h>
+ #include <net/if_media.h>
+@@ -266,7 +271,9 @@
{
int n_processes;
@@ -10,15 +22,19 @@
info.procs = n_processes;
return 0;
-@@ -278,6 +280,7 @@
+@@ -278,9 +285,10 @@
int n_processes;
int i, cnt = 0;
+ pthread_mutex_lock(&kvm_proc_mutex);
p = kvm_getprocs(kd, KERN_PROC_ALL, 0, &n_processes);
for (i = 0; i < n_processes; i++) {
- #if (__FreeBSD__ < 5) && (__FreeBSD_kernel__ < 5)
-@@ -288,6 +291,7 @@
+-#if (__FreeBSD__ < 5) && (__FreeBSD_kernel__ < 5)
++#if (defined(__FreeBSD__) && (__FreeBSD__ < 5)) || (defined(__FreeBSD_kernel__) && (__FreeBSD_kernel__ < 5))
+ if (p[i].kp_proc.p_stat == SRUN) {
+ #else
+ if (p[i].ki_stat == SRUN) {
+@@ -288,6 +296,7 @@
cnt++;
}
}
@@ -26,7 +42,15 @@
info.run_procs = cnt;
return 0;
-@@ -748,6 +752,7 @@
+@@ -296,7 +305,6 @@
+ void get_cpu_count(void)
+ {
+ int cpu_count = 0;
+- size_t cpu_count_len = sizeof(cpu_count);
+
+ if (GETSYSCTL("hw.ncpu", cpu_count) == 0) {
+ info.cpu_count = cpu_count;
+@@ -748,6 +756,7 @@
CRIT_ERR(NULL, NULL, "Cannot read sysctl \"vm.stats.vm.v_page_count\"");
}