aboutsummaryrefslogtreecommitdiff
path: root/sysutils/consolekit
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-08-27 13:52:48 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-08-27 13:52:48 +0000
commit258696c5c74e5ca741be867f1b4b450d574d1fd6 (patch)
tree92614c80cd51198254bcbbb1eb5e58c2955b5096 /sysutils/consolekit
parentb9ce6c6b0a88d7dbc7c2b7c6d2ad44a817fbf27e (diff)
downloadports-258696c5c74e5ca741be867f1b4b450d574d1fd6.tar.gz
ports-258696c5c74e5ca741be867f1b4b450d574d1fd6.zip
Add ConsoleKit, a framework for defining and tracking users. It's required
by recent versions of PolicyKit and can be used by gdm to track users and sessions.
Notes
Notes: svn path=/head/; revision=198383
Diffstat (limited to 'sysutils/consolekit')
-rw-r--r--sysutils/consolekit/Makefile36
-rw-r--r--sysutils/consolekit/distinfo3
-rw-r--r--sysutils/consolekit/files/consolekit.in57
-rw-r--r--sysutils/consolekit/pkg-descr6
-rw-r--r--sysutils/consolekit/pkg-plist16
5 files changed, 118 insertions, 0 deletions
diff --git a/sysutils/consolekit/Makefile b/sysutils/consolekit/Makefile
new file mode 100644
index 000000000000..bd87ae2fdfde
--- /dev/null
+++ b/sysutils/consolekit/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ConsoleKit
+# Date Created: 26 Aug 2006
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= consolekit
+PORTVERSION= ${RELVERSION}.${SNAPSHOT}
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://people.freebsd.org/~flz/local/
+DISTFILES= ConsoleKit-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Framework for defining and tracking users
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+RELVERSION= 0.2.2
+SNAPSHOT= 20070827
+
+WRKSRC= ${WRKDIR}/ConsoleKit-${RELVERSION}
+USE_BZIP2= yes
+USE_XORG= x11
+USE_GNOME= gnomehack gnometarget
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-pid-file=/var/run/${PORTNAME}.pid
+
+USE_RC_SUBR= consolekit
+USE_GNOME_SUBR= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/consolekit/distinfo b/sysutils/consolekit/distinfo
new file mode 100644
index 000000000000..68548f3636dc
--- /dev/null
+++ b/sysutils/consolekit/distinfo
@@ -0,0 +1,3 @@
+MD5 (ConsoleKit-0.2.2.20070827.tar.bz2) = aa07b028d83314ea9118941e7a8814c5
+SHA256 (ConsoleKit-0.2.2.20070827.tar.bz2) = 2edf92492193631bb7d22535aa818b1d9c67821e8ac2197d0f7cabbabfd0125f
+SIZE (ConsoleKit-0.2.2.20070827.tar.bz2) = 308872
diff --git a/sysutils/consolekit/files/consolekit.in b/sysutils/consolekit/files/consolekit.in
new file mode 100644
index 000000000000..7eada3e639c2
--- /dev/null
+++ b/sysutils/consolekit/files/consolekit.in
@@ -0,0 +1,57 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: consolekit
+# REQUIRE: DAEMON dbus
+#
+# Add the following line to /etc/rc.conf to enable the ConsoleKit daemon:
+#
+# consolekit_enable="YES"
+#
+
+. %%RC_SUBR%%
+. %%GNOME_SUBR%%
+
+consolekit_enable=${consolekit_enable-${gnome_enable}}
+
+name=consolekit
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/console-kit-daemon"
+pidfile="/var/run/${name}.pid"
+
+start_precmd="consolekit_precmd"
+stop_postcmd="consolekit_postcmd"
+
+local_force_depend()
+{
+ _depend="$1"
+ if [ -f %%LOCALBASE%%/etc/rc.d/${_depend}.sh ]; then
+ _depend="${_depend}.sh"
+ fi
+
+ if ! %%LOCALBASE%%/etc/rc.d/${_depend} forcestatus 1>/dev/null 2>&1 &&
+ ! %%LOCALBASE%%/etc/rc.d/${_depend} forcestart; then
+ return 1
+ fi
+ return 0
+}
+
+consolekit_precmd()
+{
+ if ! checkyesno dbus_enable
+ then
+ local_force_depend dbus || return 1
+ fi
+
+ mkdir -p $(dirname $pidfile)
+}
+
+consolekit_postcmd()
+{
+ rm -f $pidfile
+}
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/sysutils/consolekit/pkg-descr b/sysutils/consolekit/pkg-descr
new file mode 100644
index 000000000000..31ea86e35301
--- /dev/null
+++ b/sysutils/consolekit/pkg-descr
@@ -0,0 +1,6 @@
+ConsoleKit is a framework for defining and tracking users, login
+sessions, and seats. The primary motivations for this framework are to
+facilitate fast-user-switching and multi-seat capabilities, and to
+enable more sophisticated policy decisions for desktop sessions.
+
+WWW: http://www.freedesktop.org/Software/hal
diff --git a/sysutils/consolekit/pkg-plist b/sysutils/consolekit/pkg-plist
new file mode 100644
index 000000000000..eba97e96bcaf
--- /dev/null
+++ b/sysutils/consolekit/pkg-plist
@@ -0,0 +1,16 @@
+bin/ck-list-sessions
+etc/ConsoleKit/seats.d/00-primary.seat
+etc/dbus-1/system.d/ConsoleKit.conf
+include/ConsoleKit/ck-connector/ck-connector.h
+lib/libck-connector.la
+lib/libck-connector.so
+lib/libck-connector.so.0
+libdata/pkgconfig/ck-connector.pc
+libexec/ck-collect-session-info
+libexec/ck-get-x11-display-device
+libexec/ck-get-x11-server-pid
+sbin/console-kit-daemon
+@dirrm include/ConsoleKit/ck-connector
+@dirrm include/ConsoleKit
+@dirrm etc/ConsoleKit/seats.d
+@dirrm etc/ConsoleKit