aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dar/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-02-09 10:00:04 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-02-09 10:00:04 +0000
commite5a555b22ed752d031160b36039ca1744282012c (patch)
treed9891b233a7aeac44440b06e85da731e46777d36 /sysutils/dar/Makefile
parente972d1edf6b9181232136784a0c88f1fd40e2d54 (diff)
downloadports-e5a555b22ed752d031160b36039ca1744282012c.tar.gz
ports-e5a555b22ed752d031160b36039ca1744282012c.zip
- use external libintl to avoid updating lib/charset.alias problem
Noticed by: kris
Notes
Notes: svn path=/head/; revision=128355
Diffstat (limited to 'sysutils/dar/Makefile')
-rw-r--r--sysutils/dar/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/dar/Makefile b/sysutils/dar/Makefile
index 954fa8fe8778..19936aeec3e9 100644
--- a/sysutils/dar/Makefile
+++ b/sysutils/dar/Makefile
@@ -16,12 +16,14 @@ COMMENT= A full featured command-line backup tool, aimed for disks
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+=--with-libintl-prefix=${PREFIX}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.else
CONFIGURE_ARGS+=--disable-nls
@@ -30,4 +32,8 @@ PLIST_SUB+= NLS="@comment "
MAN1= dar.1 dar_cp.1 dar_manager.1 dar_slave.1 dar_xform.1
+post-patch:
+ @${REINPLACE_CMD} -Ee 's,(_nl_expand_alias) \(0\),\1 (),g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>