aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dmidecode
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-12-06 10:04:50 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-12-06 10:04:50 +0000
commit3ddb88bc981c25f07e71ffeee7fc5ddefb5c11ca (patch)
treecc72098b6f7ecf41696011a538be8a08e3fb124a /sysutils/dmidecode
parent3873cbcc24918941961ac6a9273fbb54eae789f3 (diff)
downloadports-3ddb88bc981c25f07e71ffeee7fc5ddefb5c11ca.tar.gz
ports-3ddb88bc981c25f07e71ffeee7fc5ddefb5c11ca.zip
sysutils/dmidecode: add dmidecode to periodic/daily to track hardware changes
To enable tracking dmidecode diffs in daily mail the admin should set the variable daily_status_dmidecode_enable to "YES" in /etc/periodic.conf PR: 188941 Submitted by: marck Approved by: sunpoet (timeout)
Notes
Notes: svn path=/head/; revision=403097
Diffstat (limited to 'sysutils/dmidecode')
-rw-r--r--sysutils/dmidecode/Makefile10
-rw-r--r--sysutils/dmidecode/files/dmidecode.in53
-rw-r--r--sysutils/dmidecode/files/patch-Makefile4
3 files changed, 64 insertions, 3 deletions
diff --git a/sysutils/dmidecode/Makefile b/sysutils/dmidecode/Makefile
index abe79545e193..2b4f3229cf61 100644
--- a/sysutils/dmidecode/Makefile
+++ b/sysutils/dmidecode/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dmidecode
PORTVERSION= 2.12
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SAVANNAH
@@ -17,9 +18,16 @@ ONLY_FOR_ARCHS= i386 amd64 ia64
MAKE_ENV= DOCSDIR="${DOCSDIR}"
USES= tar:bzip2
-PLIST_FILES= man/man8/dmidecode.8.gz \
+PLIST_FILES= etc/periodic/daily/dmidecode \
+ man/man8/dmidecode.8.gz \
sbin/dmidecode
PORTDOCS= AUTHORS CHANGELOG README
+USE_RC_SUBR= dmidecode
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
+ ${INSTALL_SCRIPT} ${WRKDIR}/dmidecode \
+ ${STAGEDIR}${PREFIX}/etc/periodic/daily
.include <bsd.port.pre.mk>
diff --git a/sysutils/dmidecode/files/dmidecode.in b/sysutils/dmidecode/files/dmidecode.in
new file mode 100644
index 000000000000..70020a9d6d33
--- /dev/null
+++ b/sysutils/dmidecode/files/dmidecode.in
@@ -0,0 +1,53 @@
+#!/bin/sh -
+#
+# Copyright (c) 2001-2014 The FreeBSD Project
+# Copyright (c) 2014 Dmitry Morozovsky <marck@rinet.ru>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions
+# are met:
+# 1. Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+# SUCH DAMAGE.
+#
+# $FreeBSD$
+#
+
+# If there is a global system configuration file, suck it in.
+#
+if [ -r /etc/defaults/periodic.conf ]
+then
+ . /etc/defaults/periodic.conf
+ source_periodic_confs
+fi
+
+dmidecode=%%PREFIX%%/sbin/dmidecode
+
+. /etc/periodic/security/security.functions
+
+rc=0
+
+case "$daily_status_dmidecode_enable" in
+ [Yy][Ee][Ss])
+ $dmidecode 2>/dev/null |
+ check_diff dmidecode - "${host} hardware dmi status:"
+ rc=$?;;
+ *) rc=0;;
+esac
+
+exit $rc
diff --git a/sysutils/dmidecode/files/patch-Makefile b/sysutils/dmidecode/files/patch-Makefile
index 18b1d5be0600..591677f737d9 100644
--- a/sysutils/dmidecode/files/patch-Makefile
+++ b/sysutils/dmidecode/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-09-04 23:07:45.000000000 +0200
-+++ Makefile 2013-09-04 23:09:52.000000000 +0200
+--- Makefile.orig 2010-10-11 14:08:16 UTC
++++ Makefile
@@ -12,30 +12,29 @@
# (at your option) any later version.
#