aboutsummaryrefslogtreecommitdiff
path: root/sysutils/dump9660
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 00:51:22 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-19 00:51:22 +0000
commitf47ffc5236dc8b4885be0831cf4250adde1dfef7 (patch)
treebd033cb028592a673e08edfdc53e761504c91436 /sysutils/dump9660
parent2940f0e8efd6a8c1560679ac1539e34d49f1c30e (diff)
downloadports-f47ffc5236dc8b4885be0831cf4250adde1dfef7.tar.gz
ports-f47ffc5236dc8b4885be0831cf4250adde1dfef7.zip
New port: sysutils/dump9660
Dump9660 is a tool for creating ISO 9660 compliant CD images suitable for use with tools such as FreeBSD's burncd. Dump9660 supports the El Torrito bootable CD and Microsoft Joliet extensions as well as the Rock Ridge and Plan 9 system use extensions. PR: ports/39847 Submitted by: William Josephson <wkj-freebsd@honk.eecs.harvard.edu>
Notes
Notes: svn path=/head/; revision=73462
Diffstat (limited to 'sysutils/dump9660')
-rw-r--r--sysutils/dump9660/Makefile32
-rw-r--r--sysutils/dump9660/distinfo1
-rw-r--r--sysutils/dump9660/files/patch-Makefile20
-rw-r--r--sysutils/dump9660/files/patch-ab92
-rw-r--r--sysutils/dump9660/files/patch-ac36
-rw-r--r--sysutils/dump9660/pkg-comment1
-rw-r--r--sysutils/dump9660/pkg-descr15
-rw-r--r--sysutils/dump9660/pkg-plist2
8 files changed, 199 insertions, 0 deletions
diff --git a/sysutils/dump9660/Makefile b/sysutils/dump9660/Makefile
new file mode 100644
index 000000000000..943cdbe6bd8a
--- /dev/null
+++ b/sysutils/dump9660/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: dump9660
+# Date Created: 14 Jun 2002
+# Whom: wkj
+#
+# $FreeBSD$
+#
+
+PORTNAME= dump9660
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.eecs.harvard.edu/~wkj/Software/dump9660/
+DISTNAME= dump9660
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dump9660-port@eecs.harvard.edu
+
+MAN8= mk9660.8
+MAN5= proto.5
+MLINKS= mk9660.8 dump9660.8
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+# 386(=i386), alpha, sparc
+# PowerPC should be OK, too
+OBJTYPE!= ${UNAME} -m | ${SED} -e 's;i.86;386;'
+MAKE_ENV += systype=${OPSYS} objtype=${OBJTYPE}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,@@LOCAL@@,${PREFIX},g' ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/dump9660/distinfo b/sysutils/dump9660/distinfo
new file mode 100644
index 000000000000..aca3a6900972
--- /dev/null
+++ b/sysutils/dump9660/distinfo
@@ -0,0 +1 @@
+MD5 (dump9660.tgz) = 2e3c4b72043eb52263eb750d61bd414d
diff --git a/sysutils/dump9660/files/patch-Makefile b/sysutils/dump9660/files/patch-Makefile
new file mode 100644
index 000000000000..b4ae98547528
--- /dev/null
+++ b/sysutils/dump9660/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Sun Jun 2 06:32:39 2002
++++ Makefile Sat Jan 18 16:46:15 2003
+@@ -51,14 +51,9 @@
+ # Plan 9 section two corresponds to Unix sections two and three
+
+ install: $(BINARIES)
+- cp $(BINARIES) $(HOME)/bin/$$systype/$$objtype
+- cp mk9660.man $(HOME)/etc/man/man8/mk9660.8
+- cp proto.man $(HOME)/etc/man/man3/proto.3
+-
+-install-sys: $(BINARIES)
+- cp $(BINARIES) /usr/local/bin
+- cp mk9660.man /usr/local/man/man8/mk9660.8
+- cp proto.man /usr/local/man/man3/proto.3
++ cp $(BINARIES) ${PREFIX}/bin
++ cp mk9660.man ${PREFIX}/man/man8/mk9660.8
++ cp proto.man ${PREFIX}/man/man5/proto.5
+
+ dump9660: $(OFILES) $(LIBS)
+ $(CC) -o $@ $(OFILES) $(LDFLAGS)
diff --git a/sysutils/dump9660/files/patch-ab b/sysutils/dump9660/files/patch-ab
new file mode 100644
index 000000000000..bba87b0ecb78
--- /dev/null
+++ b/sysutils/dump9660/files/patch-ab
@@ -0,0 +1,92 @@
+--- mk9660.man.orig Fri May 31 23:07:00 2002
++++ mk9660.man Sun Jun 23 15:55:06 2002
+@@ -2,7 +2,7 @@
+ .SH NAME
+ dump9660, mk9660 \- create an ISO-9660 CD image
+ .SH SYNOPSIS
+-.B disk/mk9660
++.B mk9660
+ [
+ .B -:D
+ ]
+@@ -27,7 +27,7 @@
+ ]
+ .I image
+ .PP
+-.B disk/dump9660
++.B dump9660
+ [
+ .B -:D
+ ]
+@@ -62,8 +62,6 @@
+ an ISO-9660 CD image containing the
+ files named in
+ .I proto
+-(default
+-.BR /sys/lib/sysconfig/proto/allproto )
+ from the file tree
+ .I src
+ (default
+@@ -71,7 +69,9 @@
+ The
+ .I proto
+ file is formatted as described in
+-.IR mkfs (8).
++.IR proto (5)
++(see also Plan 9's
++.IR mkfs (8)).
+ .PP
+ The created CD image will be in ISO-9660
+ format, but by default the file names will
+@@ -100,7 +100,7 @@
+ flag is given, the system use fields at the end of
+ each directory entry will be populated with
+ Plan directory information (owner, group, mode,
+-full name); this is interpreted by
++full name); this is interpreted by Plan 9's
+ .IR 9660srv .
+ .PP
+ If the
+@@ -160,7 +160,7 @@
+ flag causes
+ .B mk9660
+ to replace colons in scanned file names with spaces;
+-this is the inverse of the map applied by
++this is the inverse of the map applied by Plan 9's
+ .IR dossrv (4)
+ and is useful for writing Joliet CDs containing data
+ from FAT file systems.
+@@ -192,7 +192,7 @@
+ the
+ .I dump
+ file system
+-(see
++(see Plan 9's
+ .IR fs (4)).
+ The dump is file-based rather than block-based:
+ if a file's contents have not changed since the last
+@@ -219,13 +219,16 @@
+ a Joliet directory tree.
+ .IP
+ .EX
+-disk/mk9660 -9cj -s /n/bootes -p plan9proto cdimage
++mk9660 -9cj -s /n/bootes -p plan9proto cdimage
+ .EE
+-.SH SOURCE
+-.B /sys/src/cmd/disk/9660
+ .SH "SEE ALSO"
+-.I 9660srv
+-(in
+-.IR dossrv (4)),
+-.IR cdfs (4),
+-.IR mkfs (8)
++.IR proto (5)
++.SH "HISTORY"
++.I Dump9660
++and
++.I mk9660
++were written in the fall of 2000 for Unix and Plan 9 by Russ Cox and
++William Josephson. The first public release was as a part of the
++Fourth Edition Plan 9 distribution. William Josephson subsequently
++cleaned up the Unix port and made it publicly available in the spring
++of 2002.
diff --git a/sysutils/dump9660/files/patch-ac b/sysutils/dump9660/files/patch-ac
new file mode 100644
index 000000000000..a29b261201c3
--- /dev/null
+++ b/sysutils/dump9660/files/patch-ac
@@ -0,0 +1,36 @@
+--- proto.man.orig Sun Jun 23 15:56:51 2002
++++ proto.man Sun Jun 23 15:58:12 2002
+@@ -1,13 +1,8 @@
+-.TH PROTO 2
++.TH PROTO 5
+ .SH NAME
+ rdproto \- parse and process a proto file listing
+ .SH SYNOPSIS
+ .nf
+-.ft L
+-#include <u.h>
+-#include <libc.h>
+-#include <disk.h>
+-.ft
+ .PP
+ .B
+ typedef void Protoenum(char *new, char *old, Dir *d, void *a)
+@@ -116,16 +111,7 @@
+ if
+ .I proto
+ was processed, \-1 if it could not be opened.
+-.SH FILES
+-.TF /sys/lib/sysconfig/proto/portproto
+-.TP
+-.B /sys/lib/sysconfig/proto/
+-directory of prototype files.
+-.TP
+-.B /sys/lib/sysconfig/proto/portproto
+-generic prototype file.
+ .SH SOURCE
+-.B /sys/src/libdisk/proto.c
++.B libunix/proto.c
+ .SH SEE ALSO
+-.IR mk9660 (8),
+-.IR mkfs (8)
++.IR mk9660 (8)
diff --git a/sysutils/dump9660/pkg-comment b/sysutils/dump9660/pkg-comment
new file mode 100644
index 000000000000..77eb133ef67c
--- /dev/null
+++ b/sysutils/dump9660/pkg-comment
@@ -0,0 +1 @@
+Create an ISO 9660 image, possibly incrementally
diff --git a/sysutils/dump9660/pkg-descr b/sysutils/dump9660/pkg-descr
new file mode 100644
index 000000000000..d8cd7c159c64
--- /dev/null
+++ b/sysutils/dump9660/pkg-descr
@@ -0,0 +1,15 @@
+Dump9660 is a tool for creating ISO 9660 compliant CD images suitable
+for use with tools such as FreeBSD's burncd. Dump9660 supports the El
+Torrito bootable CD and Microsoft Joliet extensions as well as the
+Rock Ridge and Plan 9 system use extensions. Mk9660 is a front end for
+dump9660 that provides the traditional ability to create CD images
+from a subtree of the file system. Dump9660 is similar in
+specification, but creates and updates backup CD images in the style
+of the Plan 9 dump file system. The dump is file-based rather than
+block-based: if a file's contents have not changed since the last
+backup, only its directory entry will be rewritten.
+
+WWW: http://www.eecs.harvard.edu/~wkj/Software/dump9660/
+
+- William Josephson and Russ Cox
+dump9660-port@eecs.harvard.edu
diff --git a/sysutils/dump9660/pkg-plist b/sysutils/dump9660/pkg-plist
new file mode 100644
index 000000000000..0277bdcdfce3
--- /dev/null
+++ b/sysutils/dump9660/pkg-plist
@@ -0,0 +1,2 @@
+bin/dump9660
+bin/mk9660