aboutsummaryrefslogtreecommitdiff
path: root/sysutils/eventlog
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-14 12:40:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-14 12:40:41 +0000
commit15b7aa1860be31fad68c061658e69249bcaad906 (patch)
tree10c29682f132b3a861b878098ba7433e0ad755f5 /sysutils/eventlog
parentc29df0f29f5e32d0dae1c951b3c034ceeb840815 (diff)
downloadports-15b7aa1860be31fad68c061658e69249bcaad906.tar.gz
ports-15b7aa1860be31fad68c061658e69249bcaad906.zip
The EventLog library aims to be a replacement of the simple syslog() API
provided on UNIX systems. The major difference between EventLog and syslog is that EventLog tries to add structure to messages. Where you had a simple non-structrured string in syslog() you have a combination of description and tag/value pairs. EventLog provides an interface to build, format and output an event record. The exact format and output method can be customized by the administrator via a configuration file. PR: ports/105370 Submitted by: Ivan Lago <ivan.lago at ifom-ieo-campus.it>
Notes
Notes: svn path=/head/; revision=177246
Diffstat (limited to 'sysutils/eventlog')
-rw-r--r--sysutils/eventlog/Makefile20
-rw-r--r--sysutils/eventlog/distinfo3
-rw-r--r--sysutils/eventlog/pkg-descr10
-rw-r--r--sysutils/eventlog/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/eventlog/Makefile b/sysutils/eventlog/Makefile
new file mode 100644
index 000000000000..afd4c369a1b7
--- /dev/null
+++ b/sysutils/eventlog/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: eventlog
+# Date created: 10 november 2006
+# Whom: Ivan Lago <ivan.lago@ifom-ieo-campus.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eventlog
+PORTVERSION= 0.2.5
+CATEGORIES= sysutils
+MASTER_SITES= http://www.balabit.com/downloads/syslog-ng/2.0/src/
+
+MAINTAINER= ivan.lago@ifom-ieo-campus.it
+COMMENT= Replacement of the simple syslog() API providing structure to messages.
+
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/eventlog/distinfo b/sysutils/eventlog/distinfo
new file mode 100644
index 000000000000..5a737c8995bb
--- /dev/null
+++ b/sysutils/eventlog/distinfo
@@ -0,0 +1,3 @@
+MD5 (eventlog-0.2.5.tar.gz) = a6bdba91f88540cc69b398fd138d86cd
+SHA256 (eventlog-0.2.5.tar.gz) = 914319726bcd01a4055b1c5e09671085875af6de2b0d8589841916139574ee11
+SIZE (eventlog-0.2.5.tar.gz) = 312164
diff --git a/sysutils/eventlog/pkg-descr b/sysutils/eventlog/pkg-descr
new file mode 100644
index 000000000000..b19cc4cb6257
--- /dev/null
+++ b/sysutils/eventlog/pkg-descr
@@ -0,0 +1,10 @@
+The EventLog library aims to be a replacement of the simple syslog() API
+provided on UNIX systems. The major difference between EventLog and syslog
+is that EventLog tries to add structure to messages.
+
+Where you had a simple non-structrured string in syslog() you have a
+combination of description and tag/value pairs.
+
+EventLog provides an interface to build, format and output an event record.
+The exact format and output method can be customized by the administrator
+via a configuration file.
diff --git a/sysutils/eventlog/pkg-plist b/sysutils/eventlog/pkg-plist
new file mode 100644
index 000000000000..5212696d7c18
--- /dev/null
+++ b/sysutils/eventlog/pkg-plist
@@ -0,0 +1,8 @@
+include/eventlog/evtlog.h
+include/eventlog/evtmaps.h
+lib/libevtlog.a
+lib/libevtlog.la
+lib/libevtlog.so
+lib/libevtlog.so.0
+libdata/pkgconfig/eventlog.pc
+@dirrm include/eventlog