aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-kmod
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2008-06-23 18:53:54 +0000
committerEd Schouten <ed@FreeBSD.org>2008-06-23 18:53:54 +0000
commit371d172508990e96b751b5ec062076a2ecdcf4e0 (patch)
tree00f66e67a317808455b0c28ca23f05dc79763f6e /sysutils/fusefs-kmod
parentc8338dd7652002d347c1b189798737c04874c4b5 (diff)
downloadports-371d172508990e96b751b5ec062076a2ecdcf4e0.tar.gz
ports-371d172508990e96b751b5ec062076a2ecdcf4e0.zip
Make fusefs-kmod work again, after the addition of D_NEEDMINOR.
Drivers that use the clone_* KPI need to be marked with D_NEEDMINOR to work right now. Without this patch, we'll get a kernel panic when allocating the first device node. Approved by: philip (mentor)
Notes
Notes: svn path=/head/; revision=215642
Diffstat (limited to 'sysutils/fusefs-kmod')
-rw-r--r--sysutils/fusefs-kmod/Makefile2
-rw-r--r--sysutils/fusefs-kmod/files/patch-fuse_module__fuse_dev.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index 65950f56242c..6c1cc74bcd06 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1.20080208
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils kld
MASTER_SITES= http://mercurial.creo.hu/repos/fuse4bsd-hg/index.cgi/archive/
PKGNAMESUFFIX= -kmod
diff --git a/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_dev.c b/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_dev.c
new file mode 100644
index 000000000000..92adf7a6a745
--- /dev/null
+++ b/sysutils/fusefs-kmod/files/patch-fuse_module__fuse_dev.c
@@ -0,0 +1,17 @@
+--- fuse_module/fuse_dev.c
++++ fuse_module/fuse_dev.c
+@@ -52,8 +52,13 @@
+ .d_read = fusedev_read,
+ .d_write = fusedev_write,
+ .d_version = D_VERSION,
++#ifndef D_NEEDMINOR
++#define D_NEEDMINOR 0
++#endif
+ #if ! DO_GIANT_MANUALLY
+- .d_flags = D_NEEDGIANT,
++ .d_flags = D_NEEDMINOR|D_NEEDGIANT,
++#else
++ .d_flags = D_NEEDMINOR,
+ #endif
+ };
+