aboutsummaryrefslogtreecommitdiff
path: root/sysutils/fusefs-kmod
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-04-03 02:16:54 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-04-03 02:16:54 +0000
commit3d203fcb21cac4f3dd094f2bac5f8aa5a820b7d6 (patch)
treebdcf2d9d1efcd1e76428abdbd2340fc6d7195c1b /sysutils/fusefs-kmod
parent09cec24050fbc389d107cbe8ba116cc197bc0040 (diff)
downloadports-3d203fcb21cac4f3dd094f2bac5f8aa5a820b7d6.tar.gz
ports-3d203fcb21cac4f3dd094f2bac5f8aa5a820b7d6.zip
- When KERNCONF is set in /etc/make.conf and /usr/src is a symlink,
fuse's Makefile uses hardcoded /usr/obj/usr/src/sys/${KERNCONF}. This causes build failure. Fix this by getting correct obj directory from /usr/src/Makefile.inc1. PR: ports/122257 Submitted by: rafan Approved by: Anish Mistry <amistry at am-productions.biz> (maintainer)
Notes
Notes: svn path=/head/; revision=210414
Diffstat (limited to 'sysutils/fusefs-kmod')
-rw-r--r--sysutils/fusefs-kmod/files/patch-fuse_module__Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/sysutils/fusefs-kmod/files/patch-fuse_module__Makefile b/sysutils/fusefs-kmod/files/patch-fuse_module__Makefile
new file mode 100644
index 000000000000..efe11cd31ddd
--- /dev/null
+++ b/sysutils/fusefs-kmod/files/patch-fuse_module__Makefile
@@ -0,0 +1,12 @@
+--- fuse_module/Makefile.orig 2008-03-30 21:36:21.000000000 +0800
++++ fuse_module/Makefile 2008-03-30 21:39:23.000000000 +0800
+@@ -22,7 +22,8 @@
+
+ .if defined(KERNCONF)
+ KERNCONF1!= echo ${KERNCONF} | sed -e 's/ .*//g'
+-KERNCONFDIR= /usr/obj/usr/src/sys/${KERNCONF1}
++KRNLOBJDIR!= make -C /usr/src -f /usr/src/Makefile.inc1 -V KRNLOBJDIR
++KERNCONFDIR= ${KRNLOBJDIR}/${KERNCONF1}
+ .endif
+
+ .if defined(KERNCONFDIR)