aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ganglia-monitor-core/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2005-04-27 17:52:41 +0000
committerBrooks Davis <brooks@FreeBSD.org>2005-04-27 17:52:41 +0000
commitc37ee5c26038db1fe96d66436265350d602e0644 (patch)
tree02b457cee73d06906779a9ffd70dee0f6a1d3ae3 /sysutils/ganglia-monitor-core/Makefile
parent5a033a05f043d71b270a12a621b8e343e5983677 (diff)
downloadports-c37ee5c26038db1fe96d66436265350d602e0644.tar.gz
ports-c37ee5c26038db1fe96d66436265350d602e0644.zip
Add a new utility script, gmetasnap which manages tarball snapshots of
the gmetad rrd databases. Add support for ganglia.sh for saving and restoring these snapshots at shutdown and startup respectivly. This makes it easier to use a ramdisk for rrddir which is necessicary for large clusters as the load of updating the databases rapidly consumes all available CPU.
Notes
Notes: svn path=/head/; revision=134272
Diffstat (limited to 'sysutils/ganglia-monitor-core/Makefile')
-rw-r--r--sysutils/ganglia-monitor-core/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/sysutils/ganglia-monitor-core/Makefile b/sysutils/ganglia-monitor-core/Makefile
index be090e25b5d8..70c689b03be0 100644
--- a/sysutils/ganglia-monitor-core/Makefile
+++ b/sysutils/ganglia-monitor-core/Makefile
@@ -7,7 +7,7 @@
PORTNAME= monitor-core
PORTVERSION= 3.0.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= sysutils net parallel
.if !defined(PORTDEV)
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -109,6 +109,7 @@ post-build:
do-install:
.if defined (WITH_GMETAD)
cd ${WRKSRC}/gmetad && make install
+ ${INSTALL_SCRIPT} ${FILESDIR}/gmetasnap.sh ${PREFIX}/sbin/gmetasnap
${INSTALL_MAN} ${WRKSRC}/mans/gmetad.1 ${MANPREFIX}/man/man1
${INSTALL_DATA} ${GMETAD_CONF} ${PREFIX}/etc/gmetad.conf.sample
.endif