aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-07 18:42:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-07 18:42:25 +0000
commit336b31c3940aea29270fc9fd9b51d3ba1633729e (patch)
treeab986f61fb6fef3625ba83cee9ea5d304243bfe8 /sysutils/gnome-control-center/Makefile
parentd02465ee5bd1e47c51b942f66a4c99d7dc742601 (diff)
downloadports-336b31c3940aea29270fc9fd9b51d3ba1633729e.tar.gz
ports-336b31c3940aea29270fc9fd9b51d3ba1633729e.zip
Update to GNOME 2.2.
This is Phase I. All existing ports have been updated to their GNOME 2.2 counterparts.
Notes
Notes: svn path=/head/; revision=75035
Diffstat (limited to 'sysutils/gnome-control-center/Makefile')
-rw-r--r--sysutils/gnome-control-center/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index 6c86e56bdac8..c171fbafba7d 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.0.3.2
+PORTVERSION= 2.2.0.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.0
+MASTER_SITE_SUBDIR= sources/control-center/2.2
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gnome-desktop-2.0:${PORTSDIR}/x11/gnomedesktop
+LIB_DEPENDS= gnome-desktop-2.3:${PORTSDIR}/x11/gnomedesktop \
+ metacity-private.0:${PORTSDIR}/x11-wm/metacity
USE_BZIP2= yes
USE_X_PREFIX= yes
@@ -24,6 +25,7 @@ USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack gnomehier
USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
@@ -31,5 +33,7 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|Xft\.h|Xft2.h|g' \
+ ${WRKSRC}/capplets/font/main.c
.include <bsd.port.mk>