aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-system-monitor
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /sysutils/gnome-system-monitor
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Notes
Notes: svn path=/head/; revision=147261
Diffstat (limited to 'sysutils/gnome-system-monitor')
-rw-r--r--sysutils/gnome-system-monitor/Makefile7
-rw-r--r--sysutils/gnome-system-monitor/distinfo4
-rw-r--r--sysutils/gnome-system-monitor/files/patch-src::proctable.c12
-rw-r--r--sysutils/gnome-system-monitor/pkg-plist3
4 files changed, 15 insertions, 11 deletions
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index 0638e562902c..9c5ce1123877 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/sysutils/gnomesystemmonitor/Makefile,v 1.51 2005/10/04 03:07:41 ahze Exp $
#
PORTNAME= gnomesystemmonitor
-PORTVERSION= 2.10.1
+PORTVERSION= 2.12.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-monitor/2.10
+MASTER_SITE_SUBDIR= sources/gnome-system-monitor/2.12
DISTNAME= gnome-system-monitor-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -24,7 +25,7 @@ INSTALLS_OMF= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui libwnck
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lutil"
diff --git a/sysutils/gnome-system-monitor/distinfo b/sysutils/gnome-system-monitor/distinfo
index dfde097daf11..04fc6c3149c0 100644
--- a/sysutils/gnome-system-monitor/distinfo
+++ b/sysutils/gnome-system-monitor/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-system-monitor-2.10.1.tar.bz2) = 22acb1699193f8bd2ced656d44f57377
-SIZE (gnome2/gnome-system-monitor-2.10.1.tar.bz2) = 766187
+MD5 (gnome2/gnome-system-monitor-2.12.1.tar.bz2) = 31924d02786622151c0fb30314d1f85d
+SIZE (gnome2/gnome-system-monitor-2.12.1.tar.bz2) = 785235
diff --git a/sysutils/gnome-system-monitor/files/patch-src::proctable.c b/sysutils/gnome-system-monitor/files/patch-src::proctable.c
index 49a699641476..70b2f9e30c64 100644
--- a/sysutils/gnome-system-monitor/files/patch-src::proctable.c
+++ b/sysutils/gnome-system-monitor/files/patch-src::proctable.c
@@ -1,7 +1,7 @@
---- src/proctable.c.orig Tue Nov 30 01:28:31 2004
-+++ src/proctable.c Wed Dec 1 13:25:55 2004
-@@ -772,6 +772,12 @@
-
+--- src/proctable.c.orig Fri Jul 22 18:58:42 2005
++++ src/proctable.c Mon Jul 25 22:25:58 2005
+@@ -853,6 +853,12 @@ static void cb_exclude(ProcInfo* info, G
+ }
+static int
@@ -13,7 +13,7 @@
static void
refresh_list (ProcData *procdata, const unsigned *pid_list, const guint n)
{
-@@ -863,10 +869,15 @@
+@@ -945,10 +951,15 @@ proctable_update_list (ProcData * const
pid_list = glibtop_get_proclist (&proclist, which, arg);
@@ -22,7 +22,7 @@
/* FIXME: total cpu time elapsed should be calculated on an individual basis here
** should probably have a total_time_last gint in the ProcInfo structure */
glibtop_get_cpu (&cpu);
- total_time = cpu.total - total_time_last;
+ total_time = MAX(cpu.total - total_time_last, 1);
+ if (cpu.frequency) {
+ total_time /= (cpu.frequency/100);
+ }
diff --git a/sysutils/gnome-system-monitor/pkg-plist b/sysutils/gnome-system-monitor/pkg-plist
index 6f9dcfca6975..e7455e4cedcb 100644
--- a/sysutils/gnome-system-monitor/pkg-plist
+++ b/sysutils/gnome-system-monitor/pkg-plist
@@ -75,10 +75,13 @@ share/locale/sv/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ta/LC_MESSAGES/gnome-system-monitor.mo
share/locale/th/LC_MESSAGES/gnome-system-monitor.mo
share/locale/tr/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/ug/LC_MESSAGES/gnome-system-monitor.mo
share/locale/uk/LC_MESSAGES/gnome-system-monitor.mo
share/locale/vi/LC_MESSAGES/gnome-system-monitor.mo
share/locale/zh_CN/LC_MESSAGES/gnome-system-monitor.mo
share/locale/zh_TW/LC_MESSAGES/gnome-system-monitor.mo
+@unexec rmdir %D/share/locale/ug/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/ug 2> /dev/null || true
@dirrm share/gnome/omf/gnome-system-monitor
@dirrm share/gnome/help/gnome-system-monitor/C/figures
@dirrm share/gnome/help/gnome-system-monitor/C